v1.79 Reboots

I have seen a few reboots under v1.79. Seems to happen with 2+ users. I was away from my unit so will try to distinguish OS from server puke when I get home later


  • No sign of an OS Level reboot, but additional kiwi server reboots. Leaving wspr off for now
  • One of my Kiwis running WSPR on 160, 80, 60 and 40m simultaneously has frozen 5 times after 1.79 update. Never froze before.
    The other Kiwi running WSPR on 30, 20, 17 and 15m  is running with no problem 24/24h.
    Maybe this observation helps.
    Frank,  LX1DQ
  • Yes, catched this myself a few times after 1.79 update.
    Thought that it's BB Black glitch.
    In /var/log/messages it looks like kiwid is restarting.

  • WSPR seems to speed up the freeze but I let mine run overnight just monitoring some CW and it froze after 8 hours.  Yesterday with wspr it did it about 4 times in 8 hours.
  • jksjks
    edited April 2017
    Could you guys check something for me please?

    Login as root to your Beagle and go to the /tmp directory with a "cd /tmp" command.
    Then type "lt" to list the files. Are there any core dump files like this?

    root@kiwi:~# cd /tmp

    root@kiwi:/tmp# lt

    total 35M

    -rw------- 1 root root 52M Apr 28 01:01 core-kiwid-11-0-0-1096-1493341278

    If so, use the name of the most recent one (will be first in the list) in a "gdb" command and get a backtrace using the gdb "bt" command. Then please email the output to support@kiwisdr.com Thanks!

    root@kiwi:/tmp# gdb /usr/local/bin/kiwid core-kiwid-11-0-0-1096-1493341278 

    GNU gdb (GDB) 7.4.1-debian

    Copyright (C) 2012 Free Software Foundation, Inc.

    License GPLv3+: GNU GPL version 3 or later <http://gnu.org/licenses/gpl.html>;

    This is free software: you are free to change and redistribute it.

    There is NO WARRANTY, to the extent permitted by law.  Type "show copying"

    and "show warranty" for details.

    This GDB was configured as "arm-linux-gnueabihf".

    For bug reporting instructions, please see:


    Reading symbols from /usr/local/bin/kiwid...done.

    [New LWP 1096]

    [Thread debugging using libthread_db enabled]

    Using host libthread_db library "/lib/arm-linux-gnueabihf/libthread_db.so.1".

    Core was generated by `/usr/local/bin/kiwid -debian 7 -use_spidev 0 -bg'.

    Program terminated with signal 11, Segmentation fault.

    #0  0xb6c0119e in __GI___libc_free (mem=0x5be2c) at malloc.c:3724

    3724 malloc.c: No such file or directory.

    (gdb) bt

    #0  0xb6c0119e in __GI___libc_free (mem=0x5be2c) at malloc.c:3724

    #1  0x00011860 in kstr_free (s=0x2e07f4 ",\276\005") at str.c:216

    #2  0x00011992 in kstr_cat (s1=0x2e07f4 ",\276\005", cs2=0x2e0800 "\350&K\003\060") at str.c:253

    #3  0x00046ac8 in rx_common_cmd (name=<optimized out>, conn=0x13f20e0, cmd=<optimized out>) at rx/rx_util.cpp:546

    #4  0x00047968 in c2s_waterfall (param=0x13f20e0) at rx/rx_waterfall.cpp:266

    #5  0x00043894 in stream_tramp (param=<optimized out>) at rx/rx_server.cpp:285

    #6  0x00050c1e in trampoline () at support/coroutines.cpp:456

    #7  0x00050c08 in TaskRemove (id=<optimized out>) at support/coroutines.cpp:661

    #8  0x8badf00c in ?? ()

    #9  0x8badf00c in ?? ()

    Backtrace stopped: previous frame identical to this frame (corrupt stack?)

    (gdb) q


  • Hi John,

    It happened to me this afternoon using v1.79, but I only noticed because my antenna switching no longer worked. So I did a reboot afterwards in order to to re-initialise the GPIO ports which may have cleared the logs.

    I tried your commands but no core dump files found.

    I'll keep a lookout for future events.



  • no kiwi core dump files founf in /tmp
  • jksjks
    edited April 2017
    Okay, I think I see something wrong now..

  • Yep, definitely a bug. v1.80 will go out in a couple of hours, or you can get it now by restarting the server.

    Sorry about that. Getting more difficult to keep this thing afloat. I appreciate everyone's assistance.

  • Kudos and thank you.
Sign In or Register to comment.