The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz

Missing the Waterfall and Main Controls [we need your help debugging this problem]

edited December 2023 in Problems and Issues

Hi all,

After a long time online the kiwi suddenly fails to show the Waterfall and the Controls.

I tried several Browsers - all the same behavior (local and remote).

Also in Admin Mode after logging in...


I did the "ssh procedure" with the "up" command - after update still the same problem.

Any ideas? 73 Chris

Comments

  • A bit difficult to tell just from the browser console. But it might be configuration file or dx label database corruption.

    Can you (or do you know how to) open port 22 (ssh) on your router and link it to your Kiwi? If so, please do so and email the serial number of your Kiwi to support@kiwisdr.com so I can connect and see what's going on. If you've set the debian/root password to something else please email that too.

  • Yes, definitely a corrupted or missing dx label file. Unless you have a custom one you'd like to restore you can restore the default by doing:

    cdp

    cp unix_env/kiwi.config/dist.dx.json ../kiwi.config/dx.json

    cp unix_env/kiwi.config/dist.dx_config.json ../kiwi.config/dx_config.json

    ku


  • Hi Jks you are my hero :-).

    It's working again! Thank you so much.


    73 Chris😀

  • Okay, that's good.

    But those files being missing or corrupted isn't supposed to cause the user interface to get stuck like that. So I need to figure out why that is happening and fix it.

  • jksjks
    edited December 2023

    If anyone else has this problem -- I could use some help.

    Before applying the "quick fix" above please email support@kiwisdr.com if you are able to open the ssh port (22) on your Kiwi, so I might connect and try to figure out the root cause of this problem.

    We've had another case reported now, so this was not just an isolated instance.

Sign In or Register to comment.