Server has closed connection [fixed in v1.571]

edited December 2022 in Problems Now Fixed

Impossible to observe one´s Kiwis with this behaviour. For instance legitimate users. If I leave the Admin page open and go elsewhere, after a (too) short period, when I come back, it says this thing and is "reloading". If it really was reloading and would show the page it would be OK but after reloading it stops for asking the Admin password. So, useless to leave Admin page open. I have read all written about this before but did not find any solution to override this. I know why it is written in the code originally. It would be nice to control this myself if I wanted this auto close down on or off. Back in the days I could leave Admin page open like forever for one screen if I wanted.

Best regards,



  • I don't know what you mean by "and go elsewhere". Are you talking about a mobile browser where user interface focus is taken away from the browser app? Because a desktop browser certainly doesn't (and shouldn't) have any problem with this. I just tried an admin connection from my iPhone. And aside from being useless due to the small screen I had no problems with disconnection no matter what I did.

    The real question here is why does your browser or network make the web socket disconnect? That's the real issue.

    For those not familiar: Before this change it was common for admin connections to have a situation where the connection with the Kiwi server was dropped, but there was no indication on the browser side. It looked like everything was fine. Only when you went to enter data it became obvious that you were typing/clicking into a "dead" page. For user connections it's obvious. The waterfall and audio stops. But there was no similar feedback for admin connections.

  • When I change the tab in chrome for a few minutes, and return to the admin-tab, I get this message that the connection was closed.

    Maybe that's what PSO meant with "go elsewhere"

  • Yes, By "going elsewhere", I ment another tab, one tab for admin, one tab for the Kiwi to see the changes I had maybe just made, one tab for another KiwiSDR and so on. So just leaving the Admin tab causes it to close connection very soon. That is strange.

    Firts I thougt it had something to do with Edge´s Efficiency mode which puts unused Tabs to "sleep" after five minutes but it was not that. I disabled the sleep thing and it still closes server connection. Very strange wouldn´t you say :😁.

    Now I did a test with MS Edge, Efficiency mode disabled, leaving Kiwi´s Admin Tab open for the whole night. I did the same thing with Firefox. Guess what happened?

    MS Edge of course had closed the Admin Tab connection and was asking for a password.

    But Firefox was alive and kicking after 10 hours and I could just hop in to do what ever I needed. And yes it was really alive, not just pretending to be.

    So we can point our finger to MS Edge/Google Chrome. Aren´t they the same nowadays? Edge is based on Chromium?


  • Simple solution. I use Firefox to observe my Kiwi´s Admin tabs. 😁


  • Okay, I see what Chrome is doing. The Kiwi code does a roundtrip keep alive transaction every five seconds. If 30 seconds passes without receiving a keep alive the client (admin page) decides the server or network has disconnected and reloads the page (after a delay).

    After a few minutes, for a non-focused tab, Chrome will slow down the Javascript timers such that the 5 second keep alive timer is delayed to once every 60 seconds. Naturally this doesn't work with the code expecting an answer within 30 seconds. So the solution is to increase the disconnect period beyond 60 seconds.

    But I'm also going to add an admin setting that disables the automatic reload of the admin page and just shows a warning message instead.

  • OMG John you are a clever guy! Beyond my understandig this stuff. Good if you found us a solution so could use also Edge.

    Happy New year to You and All.


Sign In or Register to comment.