No admin password set. Can only connect from same local network as Kiwi. Client ip =

Time to pick the hive mind here.

My kiwi was off line for a day or 2 and is now again on line. Using the same ethernet switch, getting the same IP address as before, trying to access from the same pc as I always do that is not changed in any way either. I can access http://kiwisdr.local:8073/ from that pc as well as http://kiwisdr.local:8073/status

But not http://kiwisdr.local:8073/admin

System tells me I am not on the same network.

NB. not using wifi, only cabled connections for Kiwi and Raspberry Pi into the same Ethernet switch.

How can I get past that issue ?


-- Was posted in wrong category --


  • Hi, if you try to open URL http://<Kiwisdr_IP_local>:8073/admin you have same error? How you assign IP address on your network (DHCP or static)? You have same network mask on both devices? If you try ping host kiwisdr.local what IP address you see?

  • Yes same error.


    Masks all the same

    Ping no issues from none of my systems.

    I created a solution by editing admin.json from WinSCP. Add admin password and false for autologin.

  • Now that you're in what is the local ip address of the Kiwi? People seem to have this problem occasionally. I've never been able to track it down. That's why the ip address of the attempted connection is shown when the check fails. Maybe I should show the local address of the Kiwi it's comparing against as well.

  • jksjks
    edited August 2022

    Actually, the necessary information to debug this is recorded in the log (I forgot I made that change a while back). If you could look through the log and email the appropriate messages to it would help me find this problem.

    Go to the admin console tab. Connect and type at the bottom of the page:

    msl | gr pwd

    This command will take some time to run. Then search for the message containing "CANT LOGIN". Cut and paste it, and the two previous lines containing "PWD" messages, and email them to me. It should be similar to the following:

    Mon Aug 29 22:44:48 00:11:41.575 0... [02] L PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip ip_client ip_server[IPv4] nm /24 0xffffff00

    Mon Aug 29 22:44:48 00:11:41.578 0... [02] L PWD admin config pwd set FALSE, auto-login TRUE

    Mon Aug 29 22:44:48 00:11:41.578 0... [02] L PWD admin CANT LOGIN: no config pwd set, not is_local

    Thank you!

  • I have seen a similar problem after power issues when the kiwi has started before the network is ready.

    I can get in as a user but not as the admin.

    Fixed with a reboot.

    Fixed properly with brownout protector and delayed start.

Sign In or Register to comment.