The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz
Today's v1.694 update is hopefully a working version of the failed v1.691,692 release of a few days ago.
See the first post of the "v1.694" thread below for the CHANGE_LOG notes.
Please visit kiwisdr.com (documentation) and kiwisdr.nz (online store)

Kiwi losing ethernet connectivity

My relatively recent Kisisdr dropped off of the network. Thinking tht there might have been some memory corruption, I wrote an SD Card, and booted off of 1.39.0. That seems to work: After copying the image to memory the beagle powers off. However, when I reboot, after removing the card, I see about 5 minutes of the blue light blinking: short pulse, short pulse, and a longer pause, repeating. After that I see 3 'cylons' followed by a 1, 2 cylons another 1, and then further blinks. Apologies since the last time I read blinking lights to read binary was probably 35 years ago. I might try to read the address, but for one thing: There is not ethernet activity indicated at either the switch or the port on the Kiwisdr. It is possible that the ethernet on the beagle died? Purchased last July, and no obvious problems until october, when ti seemed to drop off the net when I was away....

Any suggestions? Much thanks in advance

Comments

  • edited November 2021

    what are you using to power it? or it may just be updating......

  • Thanks for the response. First, it it was updating, wouldn't I seem network activity on the ethernet switch? There seems to be NO activity

    About power. Its a 5 volt, 2 amp Acopian 2 amp supply, and its now delivering 4.9v across the power supply terminals. The sdr continues to run, repeating the series of cylons, etc. I've read about this being a common problem, but again, not consistent with the lack of ethernet activity.

    Sorry if I'm missing something.

  • can you tweak your acopian up to 5.05?

  • No controls. Would that make such a difference to connectivity? Eventually I could hook up another supply.... at least a switcher to check....

  • edited November 2021

    if your voltage sags below a threshold, which I forget what it is, things can go awry.



  • Tried a 2.5 amp which showed a 5.2v output, same result. Of course, maybe there is a drop during startup, but its not apparent. Very much appreciate your suggestions.

  • unplug the kiwi cape and see what the BBG alone does

  • I understand that this will establish if the BBG has a problem and/or test the power supply.

    I does generate a question: How do you power the BBG stand-alone? This is a SEEED beagle, and I only see a micro-usb port. Does a standard micro=-sb output power supply work?


    Again, thanks.

  • Does a standard micro-usb output power supply work?

    Yes. And the Beagle alone will draw < 500 mA on the micro-USB.

  • edited November 2021

    Thanks JKS and WA2ZKD. Tried booting without the cape and a 1amp 5v supply. Still no lights on the ethernet on either the router or BBG side. Tried additional cables. My guess is that something is wrong with the BBG ethernet. I could try connecting the BBG to a pc as suggested in the helpful docs pointed to by WA2ZKD My assumption, verified, I think by the document is that the BBG ethernet should show both traffic and speed of connection by the lights on the ethernet port.

    Is this seem likely given the symptoms? How to address this? Bought the whole cape and bbg in July. Should I replace it?

    Or are there other possibilities?

  • edited December 2021

    Now that the forum is accepting comments, I can share how I got the kiwisdr back up. Thanks to the tips from JKS and WA2ZKD, I tested the BBG alone. It appeared like the BBG ethernet was not functioning. Replacements are backlogged, but I managed to get one from ebay (not overpaying by much) which did the trick. I had bought the kit from Master Electronics/Online Components.

    Might I have any luck contacting them or SEEED for a refund or replacement? I'll try, of course, but thought I would see if anyone has experiences.

    Thanks for the help.

  • Hi Eric,

    I've had two KiWi BBG's with blown up Ethernet chips.

    With hindsight I'm now fairly sure in both cases this was due to a nearby lightning surge.

    Here's the original thread, please read the whole thing, as some of my earlier assumptions were incorrect.

    http://forum.kiwisdr.com/index.php?p=/discussion/comment/5520

    Regards,

    Martin

  • Thanks so much for pointing this out. I will read much more carefully but this kit was installed in a kiwi plastic case (no shorting....) and died during a time with very little thunder activity (Late october). I'll investigate.

Sign In or Register to comment.