The KiwiSDR 2 online store is open for orders! Please visit

Update error [fixed]

edited June 2020 in Problems Now Fixed
Hi all

I'm trying to get my KiwiSDR to update from 1.391 to 1.395 but see this error in the log and no update happens

Tue Jun 2 01:50:51 01:52:08.678 .... UPDATE: build error, check /root/build.log file, status=0x00000200 WIFEXITED=1 WEXITSTATUS=2
Tue Jun 2 01:50:51 01:52:08.683 .... task update_task:P3:T003(-) exited by returning

On the Update page this message is displayed.

Installed version: v1.391, built May 24 2020 01:05:54
Update to version v1.395 in progress

Havr tried reboots of kiwsdr and the Beagle - any ideas?



  • edited June 2020
    If you're comfortable with Linux commandline, you can ssh into the beaglebone as root (the ID number of your board should be the password if you haven't already changed it), navigate to /root/Beagle_SDR_GPS and execute an "up" command.
    See what the failure is at that point. If you're logged on locally you can also see the build.log file contents.

    If not that comfortable or au fait with commandline administration. you should also be able, from the admin interface and from the same local network as the Kiwi, to go to the "Console" tab, click on connect. Enter "tail -n 30 /root/build.log" (as that's referenced in the logfile excerpt you've included above) in the shell command box, hit return, and see what the output is. That would determine the next course of action.

  • I fixed it already.

    This problem is an unfortunate interaction between the caching of DRM object files to speed up builds and the recent removal of the -DDEBUG compilation option (suggested by Howard Su). But only when an update jumps across certain gaps in distro version numbers. In this case it was a Kiwi running v1.391 updating to v1.395 causing the problem. Kiwis set to receive updates continuously and are up and connected to the Internet in order to receive them obviously have no problem.

    There is a better way to fix the issue using only the admin page:
    Go to the admin page console tab.
    Click the "connect" button.
    In the field at the bottom type the following Linux shell commands:
    tail -100 /root/build.log
    If there is an error message in the link step about "NextTask" then do the following:
    This is shorthand for "make clean_dist" which is a "make clean" (mc) plus removing all the DRM object files.
    Then build as usual:
    This will take a long time. If it finishes without error go to the "control" tab and click the restart button.
  • Brilliant, thanks I was hoping it wasn't something I had our hadn't done. Hopefully it will be up more now, so should receive the updates properly.
    1.395 appeared last night so all is good.

Sign In or Register to comment.