Reflashing BBB with Kiwi-1 with image v1.682

edited June 2 in Problems and Issues

Hi,

Due ethernet port failure have ordered a new BBB from Farnell (verified it is with 4Gb flash) and tried to install the current image for BBB v1.682. After download the SHA256 checksum is correct, extracted it with 7-zip and copied the image with Win32diskimager on an 8Gb SD card. The verify of the copied image passes so guess the card should be OK. After inserted the card in the BBB and holding the boot botton while applying power. The image was than copied to the BBB by flashing leds back and forth for abt. 5 min and self powered off after completed.

Removed the SD card and powered it again. After applying power the leds on the RJ45 connector ligths on for few seconds and than get off by never getting on again. Also on the DHCP leases list don't see IP being assigned. Have no serial adapter to check on the terminal whats going on but from the blue leds pattern seems its doing something.

Than tried to reflash with an old image from the SD card which was supplied with the Kiwi and works. Gets IP assigned and after network update working with current version (v1.685 at the time of writing). Could leave as it is but running under old Debian 8.5. Would prefere the current Debian release.

Any sugestions or if somebody tried to reflash a BBB with image v1.682?

Is there an archive of previous images I can try?

73 de s57rw - Andrej

Comments

  • jksjks
    edited June 2

    I just now went through the entire procedure myself to verify that it still works (it does). You might try another SD card and see if that helps.

    I used the procedure for Beagle / Debian Linux (instead of Windows) where you download (using wget) and run the script:

    wget http://kiwisdr.com/files/kiwiSDR-download-KiwiSDR-BBG_BBB-Debian-11-create-micro-SD-flasher.sh

    bash ./kiwiSDR-download-KiwiSDR-BBG_BBB-Debian-11-create-micro-SD-flasher.sh

    This script downloads the file KiwiSDR_v1.682_BBG_BBB_Debian_11.9.img.xz, uncompresses it and writes it to an sd card.

    Here is the progression of the 4 blue LEDs when the Beagle is successfully booting off the SD card rather than the eMMC on the Beagle. The LED that double flashes is the one toward the outside of the enclosure. If LED #3 is not lit in the 4th step ("reads Linux from SD card") then booting from the SD card is not occurring.

    LED on = @
    LED off = -
    LED double flashing = d
    LED intermittent flashing = f
    LED "cylon" pattern = c (one LED lit at a time, back and forth motion)
    
    1234
    @@@@    power up
    ----    pause
    d--@    reads UBoot from eMMC
    d-@-    reads Linux from SD card
    dfff    setup
    cccc    re-flash process running
    ----    done
    


  • Hi,

    Tnx for your above and your time.

    Have tried making the image by ssh to the BBB with same 8Gb card, script was executed without errors but didn't work. After reboot the image wasn't copied and Kiwi restarted working with what was on the onboard flash memory. Tried holding the boot botton with a wooden stick while powering up (4 leds lit) but after abt. 1min it got stuck by only 2nd led on.

    Same procedure with a new 32Gb SD card and all the same. Purchased a new card and 32Gb was the minimum what was available in a local computer shop.

    Tried again with the 32Gb card but making image under windows using Win32diskimager. This time removed the Kiwi board from the BBB. After releasing the boot botton BBB started copying the image and after done, reboot it worked having now it running under Debian 11.9. Manually forced it to update to current version over net and have it with v1.685.

    As conclusion don't know what went wrong with previous tries. Most probably not reliable SD cards as was found many times where others had similar problems. Or does it make any difference if you are reflashing without the Kiwi board on the BBB? The old image as mentioned in my 1st post was loaded and worked having the Kiwi board installed.

    Anyway I have now a fully updated and working Kiwi with current Debian release. Now can go back to the club contest location makeing it publick while not used.

    Great feature that the ant extention is builded into the release don't needing to install it manually 😀

    73 and tnx again - S57RW

  • jksjks
    edited June 3

    Believe it or not, this was probably a power supply problem. We've seen over the years that writing SD cards requires a substantial amount of extra peak current. So a power supply that operates a Beagle + Kiwi board normally may not also be able to power an SD write operation on top of that.

    This explains why running a Beagle + SD write alone (without the Kiwi board) worked. The current saved from not having the Kiwi board was enough to handle the SD write peak currents.

    I have updated the operating guide instructions to mention this issue.

    YogicatS57RW
  • edited June 4

    Hi,

    PSU problem can be a probable cause of troubles since without Kiwi board all worked. I have a 5V 3A switching PSU which is running the Kiwi since years. Using it since it is quiet enough. But have never tested it what is the voltage drop or its ripple when loading it with around 2 amps or slightly more. For the china stuff if it is written on the box that it is 3A doesn't really mean it is 😁 Or maybe it can survive 3A shortly but can have a significant voltage drop. Also there is abt. 2m of thin wire running from it which certainly produces voltage drops at higher currents.

    In the comming days will try to test it with a scope to see whats going on and will write here the findings...

    73 Andrej - S57RW

  • jksjks
    edited June 4

    Yes, you are correct. The "other" problem is the length of the cable and size of the wire used in the cable. This can cause I^2R voltage drop even if the power supply current delivery is not a problem.

Sign In or Register to comment.