Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (rx.kiwisdr.com, map.kiwisdr.com)

Please visit kiwisdr.com (documentation) and kiwisdr.nz (online store)

New out of box KIWI updating issue. Compiles the same files over and over again. [git fetch issue]

edited January 2020 in Problems Now Fixed
Hi,

Just got my brand new Kiwi SDR and connected it up to the network and started it up. As expected it went into update mode, but after more than an hour it is still flashing away its blue LED and if I try to connect to the kiwi port 8073, I get a message saying that it is compiling file #1 through to #60. The query is that it is compiling these files over and over again. It has gone round several times in the now hour and 15 minutes since I turned it on.

Is this normal?
If it is stuck, is it OK to switch off and let it start again? I don't want to corrupt the file system with a hard power cycling event.

Not sure what to do next. This isn't what it says to expect in the documentation.

Just for extra info, it has a suitable power supply supplied by the seller (Martin Lynch UK) and it is connected to an antenna and gps antenna. It is connected on a network cable and the local network has good Internet access.

Thanks for any help you can give.

Tony G0BZB
«1

Comments

  • @Tony1951 , I'm sure you removed the SanDisk card after the initial startup? If you didn't, each time the KiwiSDR restarts it will reload from the SanDisk card.
    Ron
    KA7U
    Tony1951
  • edited January 2020
    Thanks for the suggestion Ron, but it isn't that. The Sandisk came in a separate container and the operating system was pre-loaded. I expected it to seek and apply a more up to date system, but it just goes around and around in an endless loop of trying to compile about sixty files. It doesn't come out of that.

    I left it two hours the first time, one and a half the second and now we are on the third attempt.

    Deeply puzzled - and I'm a linux neophyte so getting nowhere.

    I've checked and rechecked.

    It has good power, good internet connection and is properly assembled. It came assembled actually. I didn't have to do anything other than plug it in.

    Hoping for a solution.... :))
  • @Tony1951 , If you didn't load from the SanDisk, I'd reload from the SanDisk, then remove it from the BeagleBone after it loads and shuts down. Then I'd restart the BB while it has an Internet connection and let it update again. Good luck.
    Ron
    KA7U
  • edited January 2020
    Thanks Ron. I will try that. This has been going around in circles for nearly seven hours with no progress.

    73s

    de G0BZB - Tony
  • Yes, I would try what Ron suggests.

    Something is not right with what you describe. The feature of displaying the compiled file number when connecting as a user was removed a while ago because it conflicts with the new way compiles are performed. So this means the update process does not have the current version (v1.376) installed on your Kiwi for some reason. It's now impossible to say what you have and this is likely why the build process is failing. A complete re-install from the sd card should fix the issue.
  • I just ran the entire process here and it worked fine. Took 50 minutes from re-flashing with the sd card to v1.376 running.
  • Thanks JKS. I did a reinstall from the card, and that part went well. So far since then, it has been behaving as it did before for the last 30 minutes. It is going round and round and compiling the files.

    I logged into the admin page, and there under the Update tab, I can see the following information:

    Installed version V1.2 built January 30th 2020 18.27:42.

    This accords with the time I did teh re install from the card.

    Below that, it says:

    Update to version 1.376 in progress.

    There are also options on that page which look like I can stop the Kiwi from updating. I am assuming that if those are set to prevent updating and looking for updates, when I re-boot it, it will probably come up and at least work as a radio so that I can test it out.

    Hopefully, someone can help with a solution, but I certainly appreciate any help offered - so thanks. This info I just found may help you point the way forward.

    Cheers.

    Tony G0BZB
  • OKAY - I stopped it updating so that I can test the radio and on reboot, it works. The software version is obviously early though (v1.2). so the features available are not those I have seen on up to date Kiwis online. It's rather bare bones in comparison. No agc for a start. I also can't drag the waterfall about, or use the keyboard arrow keys to fine tune the frequency. There may well be more differences I haven't found yet in my two minute scan around the v1.2 software.

    Maybe if the 1.2 version is incompatible with the current updating procedures / software, I should get the seller to supply a new disk with a compatible version. I might be able to download a version, but I have never created a flash disk before. I do have a usb port adaptor which might enable me to use the disk in my dashcam for this, but I'm not that happy with having to do this on a brand new shop bought item. It must have been hanging about in the seller's stock for a while.

    I obviously need to do some more digging to find out definitively if that is what is wrong and it is the incompatibility between early firmware and the new update files.
  • Are you able to open port 22 (ssh) on your router and point it to the Kiwi's local ip address so that I can connect and see what's going on? Because v1.2 is so old it unfortunately has none of the debugging tools that make it easier for me to connect.
  • jksjks
    edited January 2020
    You can certainly run it using v1.2 but it will bear no resemblance to, and have few of the features of, the current version. After all v1.2 is 3.5 years old.. (our postings crossed and I did not see your latest before composing this)
  • jksjks
    edited January 2020
    So this is either a defective BeagleBone (like a defective eMMC causing filesystem problems) or your network connection or ISP is somehow corrupting the update process. There is simply no way the stock update process from v1.2 to the current version is broken. It happens successfully many times each day. My inbox would be full otherwise.

    ML will have no clue how to make an sd card with the current version. Such an image doesn't even exist (they take hours to construct). The network update process is the way to go.
  • I did that jks.

    I sent you a pm with the details - at least I hope I sent it as a pm..... or else my kiwi is wide open...
  • Hi Tony. Thanks for that. It came through as a proper pm and I am successfully logged in. You can also email support@kiwisdr.com
    Will get back to you shortly.
  • Thanks for your help. I appreciate it. I will keep looking as often as I can in case you want me to do something else. I do have a visitor coming shortly, but I will sneak a look as often as possible without being outright rude to them. :)))
  • jksjks
    edited January 2020
    Well, I've never seen this before. In a browser from a computer on the same network as the Kiwi (i.e. using the same Internet connection) what happens when you connect to this site? https://github.com/jks-prv/Beagle_SDR_GPS (the place where the Kiwi sources are kept).
  • I can connect fine to that site wirelessly from my chromebook. One difference of course is that the KIWI is doing it by wire.

    My adsl connection comes in at the back of the house and that is where the router is. My radio antenna is at the front of the house and that is where my Raspberry Pi wispr decoder is currently, and where I want the Kiwi. To get around the issue of not having wire trailing through the house from front to back, I have set up a wireless bridge router beside the kiwi. It is on the same network absolutely and does dchp for the kiwi or anything connected by wire to it. The kiwi is plugged into that router. I tested it with my Raspberry Pi and it worked fine with the Pi's wifi switched off. It did its wispr spots and uploaded them to the server at wsprnet.org by the wireless bridge connection.

    I don't think it can be that bridge set up. I hope not. I also tried to update the kiwi by plugging it directly into the adsl router at the back of the house and got the same results - just going round and round for an hour or more and messages saying that it was compiling the same files over and over again when I tried to login to port 8073.

    I will have a go at logging into that git hub link with a wired connection from my chrome book with the wifi switched off and let you know the result
  • jksjks
    edited January 2020
    I gather your ISP is maybe TalkTalk? Interestingly, github.com seems to have a mirror of the Kiwi sources right at their location in Manchester. Incredibly, when the Kiwi connects to github.com to fetch the v1.376 sources it fails. I don't know why. I tried downloading manually from the Kiwi using two different protocols (git: https:) They both fail. The v1.376 Makefile comes across okay because that is fetched using a different mechanism from a different site. But you are never getting the v1.376 sources. I can ping github.com at TalkTalk, so I don't think it's their problem. Either github.com has a configuration problem or your ip address has been blacklisted for some reason.
  • Using a wireless connection on your local network shouldn't be a problem. As long as the traffic is being routed through the same ADSL connection as the Kiwi traffic. When you're at that site try clicking on the green "Clone or download" button at the right side and save the Kiwi sources as a .zip file (it's about 34 MB). It would interesting to know if this fails or not.
  • Ok JKS - Thanks.

    I just downloaded the zip file on both my chromebook (wireless connection direct to the adsl router) and also on an old linux netbook with a wired connection into the same wireless bridge as the kiwi is using and out to the adsl router and Internet.

    This presumably rules out problems with the network link to the repository and also the question of my IP address being blacklisted.

    The zip archive came down fine onto both computers, the wifi chrome book and the wired only linux netbook.
  • Wow, okay. Let me do some more investigation then.
  • edited January 2020
    Just wondering if I should swap the network cable that links the kiwi to the router? I think you may be updating because when I look at status on the admin page the cpu activity on the kiwi is running pretty high. It is a new unused cable, but you never know. It could be faulty? I will wait for confirmation from you so I don't interrupt anything.

    EDIT:

    I checked on kiwilocal:8073 and I got no updating message so I swapped to a known good network cable.

    I will wait for further instructions.

    Cheers
  • jksjks
    edited January 2020
    Kiwi has stopped responding.. Did it power itself off? Have the LEDs stopped flashing? (also check for yellow/green network LEDs on Ethernet RJ45 connector). Please power-cycle it and I'll continue installing the software.
  • edited January 2020
    Thanks so much mate. I really appreciate your help.

    I also noticed that the sound had vanished during the evening. I don't think it is a user error. It just went silent.

    What happens when it finishes? Will it just reset and come up normal ? :)
  • edited January 2020
    I have switched it off and on again. The lights are flashing b0th network light and the
    blue one which I assume refers to its building activity. The lights were still flashing up until I power cycled it and they have all begun again now.

    Sorry that I did not spot your remark which preceded my last message.
  • Bloody hell! Its IP has changed.... The last two digits are .1.8.

    Sorry about all this mularchy.....
  • edited January 2020
    Have opned the port again on the router. This must be a total pain for you...

    You should be able to get back in now.
  • Yes, DHCP might assign a different local ip address after a power cycle unless the ip is locked-down on the router. Now that it's 1.8 you'll have to adjust the ssh NAT entry as I can't get in because it's still probably mapped to 1.7
  • jksjks
    edited January 2020
    Still can't get in. You might have to power-cycle the router to flush any stale table entries. Hopefully the NAT mapping has been saved. Is your public ip fixed or dynamic? (power cycling the router might change the pubic ip if dynamic).
  • jksjks
    edited January 2020
    I can ping your public ip (uncommon for a residential ip) so it must be okay.
Sign In or Register to comment.