Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (,

Please visit (documentation) and (online store)

Kiwi BBAI software installation instructions [updated 4-Mar-24]



  • edited October 2019
    Just for info - over last13hrs peaked at 45C, 14 channels of WSPR (via wsprdaemon).
    Will try to combine two antennas on this one SDR and run just the BeagleBoneAI + KiwiSDR tomorrow.
    This loop is not good higher HF but is lowest noise.

  • Thank you John for the BBAI version. I've followed your instructions at the top of this thread and it all worked. Only hint of difficulty was right at the end of the build, when it said:

    systemctl enable kiwid.service
    Synchronizing state of kiwid.service with SysV service script with /lib/systemd/systemd-sysv-install.
    Executing: /lib/systemd/systemd-sysv-install enable kiwid
    sed: can't read /root/.ssh/authorized_keys: No such file or directory
    Makefile:845: recipe for target 'c_ext_clang_conv_install' failed
    make[1]: [c_ext_clang_conv_install] Error 2 (ignored)
    Press "return" key to reboot else control-C:

    However it worked OK on the reboot.

    Now to the difficult bit - the cooling. Just got it on the bench next to an 80mm fan at the moment.

    Richard G4DYA
  • @Richard Thanks -- fixed that.
  • Would it be worth adding "connmanctl disable wifi" to the basic instructions?
    If someone is not interested in the Wifi dark arts they could at least turn it off.

    BTW 36hr, 14wspr 1.5GHz
    Stats: 0 dropped, 0 underruns, 0 sequence, 0 realtime
  • I'm attempting to provide cooling for a BBAI in a Seeed case. Without the end plates, two 5V 25mm fans side-by-side works well.

    First, I installed the AI but didn't use star washers next to the board - components are too close for comfort. Instead I used two star washers between the standoffs and the case. I didn't use the nylon standoff at all because there's a chip capacitor very close to the hole.


    Next I stuck two fans to the Kiwi board and connected them to the bottom of the 5v barrel jack. I added a bit of draught excluder to the side of one fan.


    Then connected the Kiwi to the AI.


    Then stuck the lid on. Without anything at the end I held it together with Gaffa tape!


    This arrangement keeps the CPU temperature well below 50° C. With the end plates on, it obstructs the airflow quite badly and is noisy. Next step is to try some sort of mesh grille. After that, I might try some sort of conduction cooling with chunky slabs of copper inside and heatsinks outside.

    Richard G4DYA

  • Have things running here. 42degC so OK, will make it better later. KiwiSDR webpage come sup, have audio. But can't get into admin page with
  • edited November 2019
    Question on updating, should it be possible to update via the admin pages yet? (or should we pull the dev branch) I saw mention of merge earlier.
    It recognised the new version (check only) but on forced build it seemed to stop at "UPDATE: building new version.."
    On check the processes via SSH CPU was at 1.3% could not recognise the build task and temp had dropped right off so I rebooted it (after giving it reasonable time).

    Small note on CPU clock, the default seems to be 1GHz (not 500MHz as in the alpha notes), with my laptop heat pipe the difference seems to be about 7C between 1GHz and 1.5GHz (which I ran it at for over four days).
  • The Kiwi repo "dev" and "master" branches are now closely synchronized again after dev having held the AI stuff exclusively for a long time. I think it will automatically revert to the usual update scheme because the current version number on the master branch (v1.338) is greater than what was in the last dev branch you manually pulled (335 or 336). So you shouldn't have to do anything I think.
  • As recently discovered, reducing the audio CIC filtering a bit in order to fit 14-channel mode into the FPGA actually increases the audio noise by 5-6 dB. So in v1.339 I've had to restore the full CIC filtering and instead remove the single waterfall to make room (i.e. rx14_wf1 has become rx14_wf0 so you'll get audio FFTs instead of waterfalls for all 14 channels).

    In fact I had to remove the signal gen logic as well to get a few needed logic slices. Vivado now reports the FPGA logic as 100% used. If/when any of the new ideas for CIC processing are implemented then it might be possible that this situation will improve.
  • OK on losing the waterfall, was half useful for checking I'd not broken something while moving antenna leads but I can use another radio for checks.
    The goal was 14ch and it's working pretty well so far, still amazed you got the "full HF" compliment going so quickly.

    My attempts at update have not worked so far so I will take a backup before I try anything else.

    FPGA 100% used - that must be a challenge, bet ideas spring up while on other tasks.
  • WRT to waterfall.... channel 0 still has it and you can shut off 2200M during daylight hours to do other testing
  • The latest 1.339 losses it but for good reason.
    I did move the channels around as12m is hardly worth the bother here so I had that on 0.

    Having wished for 14 channels in one box I'm now wondering if two AI's running max 7(8) WSPR and as many public full channels as possible would suit the project visibilty better.
    I.E. anyone can connect and use an online Kiwi for normal stuff, TDOA etc but the full compliment of HF WSPR is covered on two Kiwi+ two antenna ports.

    Users! give them what they want and they just change the requirement...
  • FWIW, on a wspr-only system I think you can have 2 different antennas for the bottom and top of the LF-HF spectrum by using LPF and HPF filters and combining the outputs to go to kiwi. Just make sure the outputs aren't such that the "opposite" band is shunted.
  • I was doing that, was very hard to keep the common mode noise out while combining CAT5 and Coax runs so went back to separate.
    I did try a cheap satellite combiner for a few days, to add the vertical to the mag loop (over 5MHz) the loss seemed to reduce CM issues but obviously didn't help RX.

    BTW I see UK Farnell is out of BBAI stock currently, mouser still have hundreds (if you don't mind paying extra 40%!).
  • edited November 2019
    you might try one of these for your CM issue
  • edited November 2019
    The BB version seems to be over-riding the Kiwi's network settings at boot and using DHCP regardless of whether it's configured for DHCP or static. If you're using a non-NATted static IP this can be very confusing.

    To get a static IP, it's necessary to use connmanctl:

    Find a filename in /var/lib/connman/ starting with "ethernet", e.g ethernet_01234567890ab_cable, then as root:

    connmanctl config ethernet_01234567890ab_cable --ipv4 manual ip_address netmask gateway_ip

    Then add the IP addresses for a couple of your ISP's nameservers:

    connmanctl config ethernet_01234567890abcdef_cable --nameservers
  • Be very careful with the Mini-Circuits T1-6+. It's not really a classic flux-coupled transformer so much as a transmission-line transformer. This means that the CM rejection depends greatly on getting the sense of the windings correct. Inter-winding capacitance is not small.
    I discovered this in re-laying out the antenna switch. A newer lay out turned out to have far worse rejection when used with the T1-6+, which I used because of the better VLF coverage, than it did with a T1-1 version. There seems to be no indication of this in Mini-Circuits specifications.
  • edited November 2019
    OK so I eventually had a go at updating my AI stuck at 1.335.

    I'd tried a few non aggressive things then decided I'd probably learn more by wiping it with the original image.
    Decided to back it up first and failed two times with two cards, one even got stuck in the micro SD card slot and I had to take the Kiwi apart to get it out, visually it didn't look much different to one that did eject but be careful and note that the card is flipped in comparison to the BBG. Remember also the image could potentially be much larger from the AI's larger on board storage (Assumption, I don't know what the driver is)

    Long story short (not much tolerance left) even booted with the original image I could not work out how to make it write to the eMMC (it fires up a live interface it seems)
    I probably need to go back and read some more...

    Then after a reboot (back to 1.335) I ssh to it, cd to Beagle_SDR_GPS, kd, then up one directory and (with a frown as I know I'll probably be laughed at for the clumsy method).

    rm -r Beagle_SDR_GPS/
    git clone
    cd Beagle_SDR_GPS/
    git checkout dev not needed -see next jks comment
    make clean
    make install

    Shut it down (as I'd be trying to do the image stuff without the cape, powered from USB-C)
    Powered up via the Kiwi and it booted fine to 1.344, next reboot updated itself to 1.347,

    Now someone can tell me what I should have done....
  • The instructions in the first post of this thread were changed some time ago to remove the need to checkout the "dev" branch as all the BBAI changes have been merged into the master branch now. So try that instead.
  • OK thought I'd copied the command from the first post, will use the normal branch next time.
    Ah no! I did it from the bash history, numpty error!
    At least I got beyond the first install version and it is automatically updating now.
  • I forgot to mention, I picked up a second hand Flir One thermal camera (Android type).
    When running the Kiwi and AI through the barrel socket the inductor is only slightly warmer than surroundings and the overall kit is fairly well balanced (with the laptop heatpipe bodge). If I tried powering it through the USB-C socket there was a surprising amount of heat around the socket and components connected.
    I’d say for now rather than untested it may be “inadvisable”. I also could hear some ticking like something was resetting, seemed to run but I’d say don’t try that unless you have test kit and good reason to. I didn’t try reception as got spooked by the localised heat and ticking.

    I'm not sure why but the images saved from the Flir camera are corrupt or at least won't work on the older Android tablet I'm using otherwise I'd have added some for detail.
  • I was thinking about getting a thermal camera too. But then I immediately read how those devices don't have the proper optics to give enough resolution to clearly differentiate small SMT components. There is all sorts of info on the net about how people have made attachments to hack surplus IR lens onto their devices to get around the problem. All of this is not very appealing after spending hundreds/thousands of dollars on a camera and not having much time to muck around.

    I need this to do some A/B measurements on the BBAI Schottky diode problem.
  • I have access to a pro-grade IR camera system as used in a development lab for new designs. I'll see if I can get it to use.
  • The thing about heat is that it's blurred anyway so as long as you have a contrast and some detail from the visual camera the info is there.
    I'd probably not go too high end as technology is changing and the works Fluke thermal is probably not much better than this mobile phone add on bought a good few years later.

    If I can find my old phone I'll try that for saving images as this tablet is not compatible.
    I did try using my phone to take a picture of the tablet screen while looking at a powered on BBG but ran short of hands.

    Only thing I would caution from reviews is the later version Flir's Android/iPhone cameras seem to be lower resolution unless you go up the cost scale.
    I did also see mention that it is easier to recover images from Seek cameras, on different devices and operating systems, than Flir.
  • edited November 2019
    Here's an image that you can expect from a seek reveal pro.
    The problem with small components is the minimum focus distance. If you go closer, the image just blurs out.
  • Found my old phone.

    The Flir One uses a visual camera to add detail, obvious drawback is parallax, makes it next to useless close up.

    First is the AI with fan (mainly) on the heat pipe fins, second is what's on top of the case and why I don't open the lid very far.

    That Seek looks very useful, good reviews too.
  • I ran through the instructions a couple time and I still get this:


    Any ideas?

    Steve KD2OM

  • jksjks
    edited December 2019
    The clang compiler (a much better C compiler) is supposed to be automatically installed by the BBAI build process (the regular BBG/B process does so as well). Is this Kiwi accessible from the Internet? Is there a way you could open the ssh port (22) to it?
  • edited December 2019
    I certainly can open it. It is open now.

    I didn't see page two, my bad. I guess I can just install clang using apt, but will wait for john to look at it.
  • jksjks
    edited December 2019
    I see what's wrong. I'm building on your Kiwi now to test the fix. For BBAI we rolled back clang++ to g++ due to a terrible compiler bug that is affecting some new development. But the way it was rolled back wasn't quite right. The fix will be part of today's v1.358 release. Thanks for mentioning this!
Sign In or Register to comment.