The KiwiSDR 2 online store is open for orders! Please visit
Today's v1.694 update is hopefully a working version of the failed v1.691,692 release of a few days ago.
See the first post of the "v1.694" thread below for the CHANGE_LOG notes.
Please visit (documentation) and (online store)

FPGA not working / not responding [a broken ADC clock will now result in this]

edited December 2023 in Problems Now Fixed

Hello everybody,

I tried to reanimate my old KiwiSDR (kit, #1697) but ran in some issues I just can't fix at the moment. Since I haven't used it for several years now, first idea was to update it and take a look around. I did not back up anything (intentionally, factory reset is just fine with me), downloaded the Debian 10 image and flashed it via SD card, which ran just fine. After reboot (cf. the beginning of the messages-log in attachment), i think it comes up fine, upgrades itself via github, but then it stops working with the looping error "FPGA not responding: 0xffff" (cf. the end of the messages). I repeated flashing from scratch, same result.

I found, but powercycling and reattaching the board (several times) did not solve the issue. What seems to be new after updating are the boot-time errors like

Nov 7 20:23:09 beaglebone kernel: [   1.218944] bone-pinmux-helper: probe of ocp:P8_07_pinmux failed with error -22

which I did not notice before.

Then I reflashed it again with the Debian 9 image and disabled internet access for the KiwiSDR, which means it comes up (and stays) with version 1.486. Now there's no "FPGA not responding" error loop, the server is coming up (also after reboot, powercycling, etc.) but the spectrum is completely dark (client: Firefox 119 @ Arch Linux):

And even after several hours there is no gps fix although satellites seem to be received.

After reenabling internet access, it is upgrading to 1.633 and the "FPGA not responding" error reoccurs. The ./d output is:

Any clue?

Thx and 73



Sign In or Register to comment.