KIWI no longer on www reachable after software update

a radio friend lost www acces to his 2 Kiwi's he thinks after a software update 1598 1599 now 1.601

Question: is this a general problem that can happen after auto software update

The ports 8073 8074 "open" test fails in the adm page should that test be "ok"'

I guess yes but nothing is written about what happens if the test fails.

Must the "Debian" version 8.5 be updated to a higher version ?

I can not find a clear answer The Linux language about that subject is confusing for me.

I think to have understand that it is possible to upgrade the firmware

By booting the kiwi with an new image on an SSD

But is it necessary regarding the connection problem ?

We want the Kiwi's back online

Any advice highly appreciated Jaap


  • It is rare for a software upgrade to cause problems, and I don't think this is a Debian version problem, as I have a mixture of 8 and 10 on my KiWis and they all continue to behave as normal.

    You say that you have lost www access, but then go on to say you can access the admin page ?

    Is this via a local connection ? Is the KiWi actually still working on the local connection but you have simply lost external internet connectivity ?



  • I need l lot more information about this situation.

    Like Martin said, it sounds to me that your friend has local access to his two Kiwis but access via the Internet has stopped working. As evidenced by the admin network tab "check port open" button returning "No" for both checks (the domain-based and ip address-based queries).

    Many questions:

    How are these Kiwis known on the Internet? Via ip address or a domain name of some sort? (private or DDNS domain name). What is setup exactly on the five entry menu of the admin connect tab?

    If the Kiwis are known by a static ip address: Is it possible the ISP has changed the ip address? You can check by going to the admin console tab and using the pubip command. See if it matches the public ip reported on the admin network tab and also what is used by the check open port button.

    If you already know the ISP changes the ip on a regular basis, and use a DDNS to compensate, do you know the DDNS is still working? So you use the Kiwi DDNS at the bottom of the admin connect page?

    Another problem is that port forwarding via NAT in the Internet router could have stopped working (necessary for port 8073). Was the NAT setup manually in the router? If yes, is it still set? Is it still forwarding to the correct local ip address? Do you use the Kiwi "auto add NAT rule" function at the top of the admin network tab? When you turn it off and on does it say it worked?

    Have you tried rebooting the Kiwi completely?

    What happens when you use the blue buttons at the top of the admin console page? "check github", "ping DNS", "ping kiwisdr". Does each of those work?

  • jksjks
    edited June 8

    Wait. You posted this in the "BeagleBone AI-64" category. Are these BBAI-64 based systems? Doesn't seem likely since you talk about Debian 8 and 10 which are used with BBG/BBB. BBAI-64 uses Debian 11.

    To answer you other question: No, if you were running v1.598/599 recently then the update to v1.601/602 should have worked fine even though you're using Debian 8.5.

    My guess is that this is really a network, router or ISP problem and doesn't have anything to do with the Kiwi itself.

  • Thanks for reactions

    Helpful to learn that the Debian version 8.x should work normal

    Reading the Kiwi home page one could think a Debian upgrade is needed.

    Like Debian 8.x is no longer supported

    The port check at /adm was here negative

    I have to open those 8073 8074 ports on the router where the internet is connected

    will test


  • The very first sentence in that description says Debian 8 can continue to be used in most cases: If your Kiwi currently runs Debian 8, and a recent version of the Kiwi software (v1.472 or later), you can continue to do so.

  • btw what is meant by Debian Green / black ?

    Now i have the 2 Kiwis again here

    I can not open the Kiwi page even if i type the address

    a ports scann shows the Kiwi is hiding there it seems

    It can onl;y be seen by the ip/port scanner

    details of the scann:

    Port 22 (TCP)

    OpenSSH 6.7p1 Debian 5+deb8u3 protocol 2.0

    I have not yet loaded an image for a reboot flash

    Simply I can not find the right image for this Kiwi's

    Also because no information labels found on its silver shiny aluminium housing...

    I have not found a Debian for a silver coloured KIWI...

    I ask a "Wiki Linux man" in the neighbourhood to put a light on it.

    tia Jaap

  • It's good the Kiwi shows the ssh port open.

    The best thing for you to do is open the ssh port to the Internet so I can connect and see what's happening. If you know how use NAT port mapping on your router to do something like this:

    your_public_ip:8022 =>

    your_public_ip:8023 => 192.168.8.???:22 (for the second Kiwi)

    Then email your public ip address and the 4-digit serial numbers of the two Kiwis to The serial numbers are the passwords necessary for the ssh. You may have to remove the end plates and top of the silver enclosure to see the serial number written on the top of the Kiwi PCB if you don't know what they are.

  • Re "BeagleBone Black": Two versions of the Kiwi were sold. A "board-only" version was for people who already had an original BeagleBone Black and simply wanted to add the Kiwi board to it. The full Kiwi kit included a BeagleBone Green, which was Seeed's simplified version of the BB-Black. The Kiwi works with either one as well now with the BBAI and BBAI-64.

  • the Board got an LAN ip address in can be pinged and PuTTY sees it but i can nog log in

    ti have seen a message that this is a Beaglebone Black so i need an image that works for this board but how to find this image

  • 1 time i had this message upon trying to log in

  • With ssh you don't login as user "admin". Login as user "root" or "debian".

    Try clearing the browser cache: hold shift key before clicking the reload icon (circle-arrow symbol, third from left). If that doesn't help then there is probably corruption of the Kiwi server files somehow.

  • There is not a different image for the BeagleBone Black versus the Green.

    They use the same Kiwi-customized Debian 10 image described in our documentation.

Sign In or Register to comment.