Any Web Browsers not working

Chrome, Firefox and opera web browsers not connecting to Kiwisdr.... Putty works OK, WinSCP works OK...

use command 'up' to recompile... didn't work... use different computer same....

what can I do now?


  • what is URL of the kiwi?

  • edited May 2023

    This is surely not a browser problem.

    Chrome, Firefox and opera web browsers not connecting to Kiwisdr.... Putty works OK, WinSCP works OK...

    Looks for me as if the kiwi-daemon (kiwid) is not running. When logged in via putty, you can check this by running ps -A | grep "kiwid" - if no line is listed, you know for sure that kiwid doesn't run, for whatever reason. Maybe it can't start due to an incomplete or aborted update. I'd login via putty, rename the original directory Beagle_SDR_GPS to something else (in order to keep all settings for later access), and then try to do a complete clone & build.

  • Yes, Nothing Listed....

  • I tried to install a new copy of kiwisdr from the webpage.....

    and it didn't power down like it said it would do when done.....

    so I cut the power off then powered on..... then same thing.....

    Using this command with SSH.... ps -A | grep "kiwid"

    Still the same.....

    What should I do Now?

  • When you're re-flashing from an sd card do you get the "back-and-forth" pattern in the 4 blue LEDs? It should go on for about 5 minutes or so. Then all the LEDs go dark for several minutes before the Beagle finally powers down.

    Another question: You're not using the sd card that came in the box with the Kiwi unaltered are you? I mean if you're using that card you've downloaded a Debian 10 image onto it as the webpage now mentions, right? (because the factory image on the original sd card is no longer useable)

    Or if you're using your own sd card you've downloaded the Debian 10 based image onto it, right?

  • jksjks
    edited May 2023

    If you know how to open port 22 (ssh) on your router, so I could connect to Debian on your Beagle, then please do that and email your Kiwi's serial number and your public ip address (or domain name) to

    You have to know how to connect to your router (usually via a web interface to its ip address) and setup a NAT mapping of port 22 from your public ip address to the local ip address of the Kiwi.

  • I was holding down the wrong button, The Reset button.... The button for Boot is on the other end of power supply.... When I did it right everything worked fine... I am now up and running again.... Thanks for all of the help.....

  • Using V 1.601,

    I can't use the password for ssh (Putty or Winscp). Even in admin tap set to 1234 dose not work... even after Kiwisdr server restart or Beagle reboot.

    What can I do to fix this?

  • OH, I forgot... FT8 Autorun Dose not work also... It worked before upgrade to V 1.601 and that's when I couldn't get web page...

  • get into the admin page, open the console and you can change PW

  • FT8 Fields went blank... I had put then in before... OK Now.

  • how do you do that ..... change PW?

  • Got it....

    logon as = debian

    password = serial number of kiwi

  • I can login with putty & Winscp...

    When I go to root it says access denied.

    in putty I just do 'su' then password works.... How do I copy file from kiwisdr to windows?

  • Please try to be more clear. It's not always easy to understand your respective context.

    My vague guess: You don't know your actual root password? If so, you can do the following:

    • Login via ssh (putty) with debian as username and your serial# as password. Then:
    • sudo su (if asked for password, enter your serial#)
    • passwd (blindly enter new password for user root as desired, then enter the same password again)
    • look into /etc/ssh/sshd_config - it must contain the line PermitRootLogin Yes to allow root logins via ssh. If the line is different, change it accordingly. (And make sure it doesn't begin with a #) If you made changes, enter then service ssh restart for the changes to take immediate effect.

    Afterwards you should be able to login directly as root with the new root password.

    How do I copy file from kiwisdr to windows?

    Ehm... What about WinSCP you mentioned yourself?

  • It says :

    #LoginGraceTime 2m

    #PermitRootLogin prohibit-password

    #StrictModes yes

    #MaxAuthTries 6

    #MaxSessions 10

    Delete : prohibit-password and change to Yes?

  • Delete '#' to make statement work, if you put yes.... error results...

    I'm using Debian V 10.11

    Don't work using Winscp

    I want to use Winscp to go into root and then into kiwi.config to get then files to backup...





  • Yes, Now everything works OK now with Winscp....

    I was logging on as debian with serial#....I should have done root with serial#....

    Now I can save files for backup....

  • Congratulations!

    Is your kiwi publicly accessible? If yes, and if you really can login as root with your serial#, you should urgently change your root password into something significantly longer and more complicated. The serial# is way too short and unsecure.

  • Ok, Thanks... Friend.

Sign In or Register to comment.