Firefox version 103 audio/waterfall problems [fixed in Kiwi v1.546 update]

jksjks
edited July 27 in Problems Now Fixed

[update: fixed in v1.546]

Info courtesy NV6H: Don't restart Firefox and let it update to version 103.

There appears to be an audio system or scheduling bug in this version. This problem has happened in the past with Firefox and also Chrome. Switch to another browser if necessary.

Comments

  • I just turned off auto-update in the preferences. Thanks for the heads up.

  • Okay, fixed in the Kiwi v1.546 release.

    FF 103 enables audio/video "suspend until user gesture" like most other browsers. This change interacted badly with Kiwi audio workaround code already existing for Firefox.

  • The 1.546 release didn't fixed the <buffer underrun> errors in FF 103 for me.

    No problems with Chrome.

  • "suspend until user gesture" - what a nonsense!

    A typical example for "Trying to improve things but actually make them worse."


                            
  • jksjks
    edited July 27

    @Alsace Perhaps, but this has been a standard feature on most browsers for some years now to combat auto-start videos and audio from mostly advertisements. And I for one am very glad this has been adopted (although I am also a heavy user of ad blockers).

    I believe the suspend behavior can be disabled by browser preference.

  • @pe1rdp Do you mean for your own Kiwi? Because I see that it is running v1.545 and not 546. The 546 version was released only a few hours after 545 and while the update time window (2-6am local) was over Europe. So some Kiwis updated to 545 but won't get 546 until 24 hrs later unless there is manual intervention.

  • Hi John,


    Last night I forced the update and no more audio underruns. No more problems with FF103.


    Thanks,


    Arno

  • @jks Thanks.

    Well, advertisements cannot bother me, since I am systematically blocking whatever annoys me. Anyway, My FF103 seems to work again, and I am happy.

  • jksjks
    edited July 29

    I forgot to add:

    Most browsers, including FF, have a way to specify the default and per-website audio/video blocking.

    The recent issue w/ FF 103 is that they changed the default from “allow A/V” to “block A/V” (most other browsers did this some time ago).

    To change this behavior bring up "Preferences > Privacy & Security > Permissions > Autoplay > Settings…" and change as desired.

  • edited July 31

    How do you "force an update" ? I'm assuming you mean a KIWI update.

    My kiwi version is 1.543.

    My Firefox version is 103.0

    I'm using the NorthUtahsdr/kiwi. It had no trouble until I noticed it on 7/30/22.

    Other sdr/kiwi's behave normally.

  • How do you "force an update" ?

    admin-Tab "Update", then "Build Now"

    After abt. 20..30 minutes your kiwi should be up again with the latest version.

  • hello do you mean by that in the picture? this happened to all the SDRs i tested

    I also seen under runs and waterfall stops in a few of them and immediate changed to another Sdr seed.

    This happened to all my browers: fiefox 103.00 with two ad blockers , Chrome and the in built edge


  • Tto add this "OPEN WEbRX' start screen happened always in my Android smarphone since 4 years ago

  • I'm done trying to explain this. It's so simple. Maybe someone can try. I'm extremely busy working on useful stuff..

  • OK I'll try.

    Nearly all browsers have now implemented various security features to prevent the automatic playing of various types of Audio and Video media. This is intended to help prevent malware from being loaded when a bad website site is selected.

    The basic problem is not with the KiWi itself, but is due to changes made to the browser when updates are applied. In most cases in order to prevent having to manually start the KiWi, it is possible to change the security settings per site within the browser. Some browsers, particularly those on mobile devices do not always provide the ability to do this. In all of these cases, it is only possible for the person using the browser to change the security settings.

    However every once in a while updates to the browser will be incompatible with existing KiWi code, and this usually requires John to provide a fix in one of the next releases of the KiWi firmware.

    Although John can update the KiWi code, the owners of individual KiWi's will either have to ensure that Auto Updates are enabled, or will have to manually update the Kiwi themselves, before the new code is loaded. Depending upon the location of the KiWi, particularly those on very remote sites, it may take some time before all Kiwi's are updated, especially if a site visit is required to perform this action.

    There is nothing that a KiWi user can do to force an update of the KiWi firmware, this can only be performed by the KiWi owner. If you are experiencing problems, you need to change the security settings in your browser, or if that doesn't work, try a different browser. All browsers are updated at different times, and it is not ususual to find that the behaviour of each one is slightly different.

    Regards,

    Martin

Sign In or Register to comment.