forum.kiwisdr.com won't connect using my home static IP [fixed]

edited June 26 in Problems Now Fixed

I have an odd issue, I suspect that the forum server has blacklisted my home static IP address. None of my devices (phone, tablet, pc) will connect, server closed connection message or can't connect to server. If I use a VPN on the PC, my IP address of course is different and I can log in and view the site OK, at least for a while. I do get the same behaviour at times, then have to switch to a new VPN server with a different address to connect. Is there an automatic blacklist daemon running or something like that that could be rejecting my IP?

Wayne WA2N

Comments

  • jksjks
    edited June 23

    Yes, we have had this exact issue before. When the ip blacklist was first started some overly-broad IP ranges were suggest and not checked carefully enough. They ended up snaring legitimate IPs, including residential Internet service.

    Please email your blocked ip address (or the /24 block it's part of if you don't want to be specific) to support@kiwisdr.com and I'll sort it out.

    Thanks

  • Done, thanks

  • Well, I have no email from you. You could try sending a forum private message to me instead.

  • Sent a pm just now with my ip. Had to log on from a hotspot as nordvpn server ops also are quickly detected and blocked too.

  • jksjks
    edited June 26

    Okay, give it a try and see if it works for you.

    I will try to explain. Your particular issue is not because of an IP blacklist problem. Rather, a problem with the "fail-to-ban" (f2b) rules that the proxy and forum servers use to try and dampen the onslaught of IP probing they receive. There are f2b rules that will permaban an IP address if it gets too many http "404" failures within a certain amount of time. Something that tends to occur if someone if probing a server for weaknesses.

    Unfortunately it seems the Kiwi forum database contains some references, perhaps related to the upgrade we did some time ago, that cause 404s. I don't know why this is and it would be extremely difficult to work out. Instead, I have added f2b exceptions that ignore these references.

    It's too difficult to unravel the logs and unban IPs that were f2b'd for this reason. So if anyone else thinks this problem is effecting them please email or pm me.

    Update: I found a way to unban most of the improperly banned IPs.

  • Got it. Access seems ok from my static IP now. TNX!

Sign In or Register to comment.