Blank Frequency and no demodulation [fixed]

edited June 11 in Problems Now Fixed

Hi,

I have used my Kiwisdr for the last 5 years without any issue and suddenly it is not working. It is only used on my local network.

When I log in the receiver I have a blank frequency and no audio. I am running latest v1.537 from this morning.

Looking into the console I see this error:

freq_dsp_to_car no demod?

kiwisdr.min.js:52 Uncaught TypeError: Cannot set properties of undefined (setting 'offset_frequency')

  at demodulator_set_offset_frequency (kiwisdr.min.js:52:21646)

  at freqmode_set_dsp_kHz (kiwisdr.min.js:52:85347)

  at freqset_complete (kiwisdr.min.js:52:89196)

  at HTMLInputElement.onchange (VM320:1:1)

demodulator_set_offset_frequency @ kiwisdr.min.js:52

freqmode_set_dsp_kHz @ kiwisdr.min.js:52

freqset_complete @ kiwisdr.min.js:52

onchange @ VM320:1

kiwisdr.min.js:52 freq_dsp_to_car no demod?

kiwisdr.min.js:52 Uncaught TypeError: Cannot set properties of undefined (setting 'offset_frequency')

  at demodulator_set_offset_frequency (kiwisdr.min.js:52:21646)

  at freqmode_set_dsp_kHz (kiwisdr.min.js:52:85347)

  at freqset_complete (kiwisdr.min.js:52:89196)

  at HTMLFormElement.onsubmit (VM321:1:1)

demodulator_set_offset_frequency @ kiwisdr.min.js:52

freqmode_set_dsp_kHz @ kiwisdr.min.js:52

freqset_complete @ kiwisdr.min.js:52

onsubmit @ VM321:1

kiwisdr.min.js:52 $toggle_or_set_mute set=0 muted=0


Any suggestion will be appreciated.

Comments

  • I have no idea what the "VM320/VM321" stuff is. That's a problem. What happens when you try other Kiwis running v1.537 and earlier from rx.kiwisdr.com? What browser are you using? What happens when you try another browser?

  • I am using Chrome/102.0.5005.63. Tried Firefox and my iphone Safari and Chrome on IOS 15.5 and also iPad. All having same issue.

    Tried other kiwis on v1.537 and works fine with all listed above browsers/devices.

    I hope it is not hardware related. From Log FPGA is running and I see waterfall.

    When I switch between vfo a and b I am able to enter a frequency but still no audio.

  • Line 52 of kiwi.min.js is giving the error

  • It's possible this is somehow a bad build of the software. If the admin page works go to the "update" tab, click "build now". Then the "console" tab, click "connect", and type "m blog" into the field at the bottom that says "enter shell command".

    It will take a minute or so, but you should start to see messages from the build. The build should complete in less than 30 minutes. The server will automatically restart when the build finishes.

  • Still same issue after build. Time on upper right is undefined. Strange.

    Here is a screen shot of what I see if it can help:


  • Can this Kiwi be made available from the Internet? Is so please set a temporary admin password and email to support@kiwisdr.com I think there must be some corruption of the build files somehow.

  • jksjks
    edited June 4

    I looked at this for a long time. It ranks up there with the most bizarre Kiwi problems I have ever seen. I have no idea what is wrong. My guess is that there is a severe networking problem somewhere that is corrupting data. Like a bad Ethernet cable or switch/router. But there are things about this issue that make absolutely no sense whatsoever.

    There are periods of time when everything works absolutely fine. The audio is severely glitched but the waterfall seems okay. When I first made a user connection it was as you described: waterfall okay, but no audio and nothing in the frequency entry box. Also, many of the UI elements (icons etc) were very slow to load, tens of seconds, but ultimately did load. But I did not see any of the errors in the browser console you mentioned. It looked completely normal.

    Then FIVE MINUTES after just sitting there the audio popped to life! Except for the glitching it sounded fine. Even the frequency entry box worked. I have NEVER seen this before. Now on a refresh the page loads fine right away. So something has changed.

    As I write this I just saw some periods where the audio and waterfall both stopped together for several seconds, then resumed. I think this points to a network issue.

    Admin connections are a bit strange too. Initially it will take 10 or 20 seconds before a connect will occur. But then the admin password prompt will finally appear. Everything seems normal after that.

    Is there anything else besides a router in the path between the Kiwi and the Internet? Like some firewall filtering device or a network data caching device? (pfSense box, etc). Is there wifi in the path from Kiwi to Internet router?

    Since you are having problems from a local browser connection I would try changing things in the network path and see if there is an improvement.

  • From about 20:00 UTC June 3 to 10:00 UTC June 4, I saw similar problems with any kiwi in my country. The admin page took a long time to load. The waterfall was stopped. Maybe there is some connection? The ISP reported problems on its end.

  • I think the culprit was the gl.inet AR-300 router used as wIfI extender.

    I have connected it directly to my main router. I have seen 7 audio underrun issues.

    Now it is more responsive and work as expected on load.

    Will continue to monitor.

    Thanks a lot for the help on troubleshooting. This is greatly appreciated1

  • jksjks
    edited June 5

    Okay. That's pretty weird though. For the audio to get corrupted (audible glitching, not underruns which are normal and can happen for other unrelated reasons) it would have to be at point where the data is not under the protection of Ethernet, IP packet or WiFi checksum protection.

    That is, the raw data would have to be sitting un-encapsulated in a router buffer someplace before it was glitched and subsequently wrapped in an ip packet and forwarded on. I wouldn't think this likely. But who knows. We've seen all kinds of strange stuff over the years.

    The other point is that the waterfall always looked okay. But that's a little bit misleading because the WF is a low duty cycle process (23 Hz max). So statistically it could withstand a lot of dropouts before you'd really notice (the glitch could occur in the long time period between short line draw bursts). The audio on the other hand will reveal even the smallest defect. The ear is super sensitive to discontinuities like that.

Sign In or Register to comment.