Kiwi reverse proxy doesn't work anymore

Hi, I already dug through the FAQ-pages but I can't find a solution for my Kiwi reverse proxy problem.

Since the 1st of May, the Kiwi reverse proxy won't work. Because the KiwiSDR is located 5 km from here, I asked my friends to reset their modem and SDR. After that it worked again so I was pleased, I think version 1.515 was installed.

Yesterday (2/5), everything was working fine and a new update 1.516 was installed. I just was listening to the SDR (exactly 17:13 UTC) as suddenly the hated white screen came up (page currently unavailable). After that it was not accessible any more.

Today I went to the SDR, gave the modem and SDR another reset but nothing helped. Of course the SDR is accessible in local and admin, I downloaded a new update version 1.517 and checked all the previously checked boxes etc. Everything as it was before and has worked for the last 3 years.

At the bottom of the Connect Tab I read "Status: Reverse proxy enabled and running". Without changing anything I tried a "Click to (re)register". Unfortunately this also doesn't help.

I took the SDR to my house, another provider and IP-Address. I also tried a Mifi I used till December 2021, same settings which were working at that time. I'm lost, two different internet providers and IP-Addresses and a Mifi 4G tried but no working Kiwi reverse proxy!

73, René (PE0RL) The Netherlands.

Comments

  • The last time the proxy saw a registration request was on 3 may at 10:37:59 UTC. Your Kiwi was running v1.516 at that time. The only problem was it didn't send a valid public ip address during that particular registration. The previous time (2 mat 16:56:40 UTC) and all earlier times it did. It never tried to register while running v1.517

    So I don't know what the issue is. But in general the proxy is working fine.

  • Thanks John for the quick reply! Unfortunately I don't know what to do next. A few years ago I had to apply for the Kiwi reverse proxy because my provider (the biggest one in the country) had put me on the black list because I used the default KiwiSDR setting http://ip-adres:8073. The result, when I entered a browser I saw a dangerous looking warning page and the only mail you could receive was a mail of them which you could answer, the rest of all internet was blocked. It took me a long helpdesk talk to get my internet back, even the helpdesk didn't know what to do with this "stealth" security branch of their own provider! All SDR admin pages seem okay and as you read, I can't go back to the default Kiwi setting and disable the reverse proxy, I don't want the trouble again. I just resend a registration request on 19:45 UTC, lets see what happens, he just restarted.

  • The KiwiSDR just restarted but no result, so also not from this other internet provider and IP-address. Why doesn't it send a valid public IP-address? Which setting if responsable for sending a valid address each time a reset is done? I'm retired and not a learned network engineer...

  • jksjks
    edited May 3

    kiwisdr.com sees no recent registration requests. Nothing since the one from about 9 hours ago.

    I have no idea why a valid public ip isn't being sent. I think this means there is some local network issue but it very difficult to say what it is.

    Can you even browse to the kiwisdr.com site? Does my.kiwisdr.com respond with correct info? Also, try clearing all the blacklist entries on the admin network tab.

  • It's getting even worse, I can't even check for updates anymore.

    Installed version: v1.517, built May 3 2022 11:04:12

    Error determining the latest version -- check log

    It seems odd that 3 completely different ISP's (Ziggo, KPN and 4G Mifi) should have the same problem!?

    I can browse to the kiwisdr.com site. my.kiwisdr.com respond with "No KiwiSDR(s) found for your public ip address: xx.xx.xxx.xx which is my local IP-address." This we determined ourselves already ;-). But why on 3 different ISP's?

    I cleared all the blacklist entries, my local and the Kiwi blacklist, a fresh start didn't help either.

  • Also strange: "Register on rx.kiwisdr.com? kiwisdr.com registration status:

    rx.kiwisdr.com registration: successful" although I don't see my SDR at http://kiwisdr.com/public/ and http://rx.linkfanel.net/snr.html (also not after an hour). Why successful when the SDR is "stealth"?

    Obvious that this test returns with an error. But again why at 3 different ISP's and IP-addresses of perfectly sane internet connections?

    "Check if your external router port is open: Does kiwisdr.com successfully connect to your Kiwi using these URLs?

    If both respond "NO" then check the NAT port mapping on your router.

    If first responds "NO" and second "YES" then domain name of the first

    isn't resolving to the ip address of the second. Check DNS.

    http://gti.proxy.kiwisdr.com:8073 :

    Error checking port status

    http://:8073 :

    Error checking port status"

    Maybe it's better to delete the reverse proxy service and apply for a new one although no new application is granted? The only option for me right now is to dump the KiwiSDR in the trash because it can't connect to the outside world :-(.

  • Hm, after all the things done above, I perform a hard (5 VDC) reset on the SDR and connected the Mifi with 4G dataplan (forrest location) and guess what, it worked!!

    However this strange outcome: "Does kiwisdr.com successfully connect to your Kiwi using these URLs?

    If both respond "NO" then check the NAT port mapping on your router.

    If first responds "NO" and second "YES" then domain name of the first isn't resolving to the ip address of the second. Check DNS.

    http://gti.proxy.kiwisdr.com:8073 :

    YES

    http://83.232.58.20:8073 :

    NO"

    Back to my own local network. It fails, ports closed. MAYBE my ISP changed settings in the modem during several updates last 3 years?

    Tomorrow I'll be back at the remote location and try if the SDR works (again) on their modem, nothing changed since a few days so why shouldn't it work? When the SDR still not works, I'll temporary change to the expensive 4G dataplan (Mifi), 1 public user, no camping, no non-Kiwi apps and extentions like WSPR allowed.

    I think/hope the problem was the black list so I don't need the Mifi tomorrow. I changed every setting back to the old ones, the cleared local and Kiwi blacklist is the only real change which helped cure the problem I guess.

  • I didn't follow everything you said (I've got a million things on my plate today). But this is entirely normal:

    The first is an incoming connection to your Kiwi, successfully going through the proxy to get there. That is the entire purpose of the proxy after all. I was able to connect to your Kiwi fine.

    The second should fail as this is your ISP blocking incoming connections and, again, the purpose of the proxy.

    It's perhaps the case you had transient DNS problems that were cleared by the hard reset. We've seen things like that before and the cause is not always clear.

    Yesterday I added a new blacklist entry: 199.247.0.0/19. This address range is one of those cloud providers with servers possibly in Frankfurt. So it's difficult to see how that would impact your connection. The range does not appear in a traceroute to your 83.232... public address.

  • When Yes/No is okay then it is good. Why I don't find my SDR in the S/N and public listing, no idea but this is the least I'm worried about.

    I think it was my LOCAL blacklist John. After so many things above changed, I switched to the Mifi and found out that it worked so I can't go back what the exact cause was. Today (remote location) I performed minimal 10 hard resets, that didn't help. Most important, it works. Tomorrow step 2.

    This evening most were software restarts but I think I had the "wrong" IP-address locally blacklisted, maybe the reverse proxy server :-)? I saw you entering the log, 240 at the end of the IP.

    Hopefully it works tomorrow, I'll leave the local blacklist empty in the future, to "dangerous" for a network dummy like me... Why my local ISP or modem prevents the SDR working doesn't bother, I'll use the SDR at the remote location.

    John, thanks for the help. Your guidance helped me to get to the local blacklist!

  • Your Kiwi is listed on rx.kiwisdr.com now. It always takes a little time to show up. map.kiwisdr.com takes longer and the SNR sites even longer (I don't admin any of them).

    This is the traceroute from proxy.kiwisdr.com to the last hop before your router (i.e. some router at your ISP). Do any of these IPs (the ones in parentheses) appear in you local blacklist? Maybe you didn't save a copy before you removed it. None of these IPs are in the global/downloadable blacklist I don't believe.

    traceroute to 83.232.58.20 (83.232.58.20), 30 hops max, 60 byte packets

     1 23.92.24.3 (23.92.24.3) 0.781 ms 0.820 ms 23.92.24.2 (23.92.24.2) 0.422 ms

     2 if-11-1-5-0.gw2.fnc1.us.linode.com (173.230.159.68) 0.275 ms if-1-1-4-0.gw2.fnc1.us.linode.com (173.230.159.84) 0.355 ms if-0-0-0-0.gw1.fnc1.us.linode.com (173.230.159.80) 0.330 ms

     3 ce-0-18-0-1.r02.snjsca04.us.bb.gin.ntt.net (192.80.17.169) 2.335 ms 2.352 ms ae0-100.gw1.fnc1.us.linode.com (173.230.159.8) 0.368 ms

     4 * ae-11.r24.snjsca04.us.bb.gin.ntt.net (129.250.3.120) 1.693 ms *

     5 ae-2.r24.asbnva02.us.bb.gin.ntt.net (129.250.6.238) 60.250 ms 60.164 ms 60.094 ms

     6 ae-13.r21.parsfr04.fr.bb.gin.ntt.net (129.250.6.5) 143.742 ms ae-2.r24.asbnva02.us.bb.gin.ntt.net (129.250.6.238) 60.046 ms 60.005 ms

     7 ae-0.r20.parsfr04.fr.bb.gin.ntt.net (129.250.3.47) 134.635 ms ae-13.r21.parsfr04.fr.bb.gin.ntt.net (129.250.6.5) 143.413 ms 143.415 ms

     8 ae-6.r21.amstnl07.nl.bb.gin.ntt.net (129.250.4.137) 154.958 ms ae-0.r20.parsfr04.fr.bb.gin.ntt.net (129.250.3.47) 135.399 ms 135.493 ms

     9 ae-6.r21.amstnl07.nl.bb.gin.ntt.net (129.250.4.137) 147.931 ms 144.698 ms 148.082 ms

    10 ae-1.a00.amstnl09.nl.bb.gin.ntt.net (129.250.2.233) 144.984 ms * *

    11 * * ae-0.kpn.amstnl07.nl.bb.gin.ntt.net (81.20.65.10) 262.396 ms


  • I waited for around one hour to let the data show up in the lists before going to sleep, I think it took longer than expected. Normally it takes about 15-20 minutes? No problem.

    The "external (classic)" SNR is average and always the same, it doesn't depend on what location your antenna is or even if an antenna is attached at all. Can I erase this value like others in the list did and/or test again or is it a once in a SDR "lifetime" measurement? Mine is S/N 3670, maybe to old for a better score? A high score is not the holy grail, a lot of "good" SDRs are horrible depending on the frequencies/bands you are interested in, in my case <2 MHz. All sorts of man made noise, tune to e.g. BBC Radio 4 at 198 kHz, other SDRs produce crisp and clean audio (without hum/rattle etc.) although they have a crap score. These "bad" SDRs most of the time are good also over the whole 0~30 MHz range. I saw 15000 kHz is the only test frequency to tell if an SDR is good or bad. I must say, the test is better than Marco's test (Sibamanna) because all SDRs with a strong signal in the neighborhood, like SDRs near city's, were splendid and most of the time they aren't.

    Unfortunately I erased all (local) IPs to get the SDR going, only the last 3 (last few days) I noted because before this date everything worked. These 3 IPs are not in your list.

    I'll go now to the remote location, let's hope everything works fine again on their "solid" network so I don't have to use the Mifi with expensive 4G dataplan. Thanks for all the work, is greatly appreciated!

  • I just installed the SDR at the remote location, everything works fine like always on this network!? What the exact cause was, I never know because after erasing the blacklist, both local network and Mifi 4G didn't work. Later the Mifi suddenly worked, the local network not but it worked tomorrow. Strange things happen but the most important, it works!

  • I'm not sure what SNR lists you're talking about. Remember, I don't run any of them. I don't know how they work or how to change them. You have to ask their authors, not me.

  • The SNR list I'm referring to is http://rx.linkfanel.net/snr.html . The KiwiSDR itself generates this SNR score (admin page "Log"), you can change settings in the "Control" tab in the KiwiSDR admin page. I disabled the measurement because it gives a complete wrong picture of the REAL SNR of a KiwiSDR. No problem, has nothing to do with the KiwiSDR itself, simply a wrong interpretation of data.

    This reverse proxy thread can be closed, problem solved. Not sure what the cause was in the end.

  • No. The SNR measurement made by the Kiwi itself (enabled on the admin "control" tab and listed in the "log" tab messages) is purely a local thing. It is not logged by any public website I know of. You can access the data from your local network at, for example, my_kiwi:8073/snr And some people create logs and graphs themselves for their own use (I think the wsprdaemon folks may do this).

    rx.linkfanel.net (linked to by snr.kiwisdr.com) polls Kiwis independently. I think they told me once they use a similar SNR measurement method to mine (waterfall bin sorting and percentile sampling).

  • Thanks for the explanation John.

    I'll NOT use the SNR poll because it is far from a good SNR test in comparison to the ears.

    Example, your SDR has a SNR of 28/27 dB (daytime). According to the SNR list, you own a good SDR and your ears tell the same thing, a clean analog noise and no man made qrm.

    Suddenly the farmer next-door switches his electric fence on because the cows are back in spring. Unfortunately the other neighbor is back from holiday and turns his PLC, many switched PSU's and solar panel "optimizers" on. The SNR test will show the same SNR but suddenly your so called good SDR is garbage! Test and get my point, the SNR tests are useless.

    I rather would have a good noise blanker like in the analog transceiver days. A noise blanker who is able (+/- buttons?) to regulate the time between the pulses to filter the pulse out. The electric fence I'm talking about gives a pulse every 1,320 sec. 24/7 for 8 months 🙁. It seems to be easy to filter this pulse out like you would do with Adobe Audition. The best would be a setting in an admin page so the listener has a much better SDR to listen to without fiddling around with settings which are not working right now for this type of simple(?) pulses.

  • I just found the new noise blankers. After fiddling around a few minutes with the sliders and both noise blankers, I managed to filter about 60% of the pulse out.

    It would be perfect to set a preset in the admin page (like BW to a station frequency) so everybody can benefit after the timely fineadjustment is done by the admin user.

Sign In or Register to comment.