Cold temperatures shut down BBB?

It seems cold temperatures may shut down and/or prevent starting of my kiwi/BBB. The kiwi/BBB is out in my shed connected to a long beverage antenna. On these very cold days, sometimes it shuts down, or will not boot up if I cycle the power. When I bring the system inside to troubleshoot, it works every time. I haven't dug into this too much yet other than I know my voltage is good at the board (5.15V under load). I'm pretty sure this is a BBB problem since it does not connect to my wifi network. So while it could be many things, it seems related to the cold. It's been around -10° to -20°C here lately. Interestingly, it seems many of you have had problems with heat. My kiwi/BBB is in an enclosed metal case with no fans or anything. In the summer here it gets up to 35°C or higher and I do not have issues. I'm thinking about putting a simple temperature sensor IC on the board since it seems like there is not an on-board one.

The main intention of this post is to see if anyone else has experienced issues with the beagle in cold weather.

Nick

Ref: https://groups.google.com/g/beagleboard/c/p_DK-HE1Ds4 This post makes reference to the 24.576MHz oscillator possibly being a 0-70 part.

Comments

  • edited February 7

    Hi Nick,

    I'll throw some questions out as this is the first I've heard unless related to DC cabling or connectors in the cold.

    Frost and mist provides good attenuation of 2.4GHz so

    Where is the BBB antenna located?

    Also how do you know it has not booted as apposed to not connected the wifi?

    What type of PSU are you using and is there a ground path on the antenna side?

    Is it using a decent 5.5mm/2.1mm barrel plug and lead?

    Stu

    One other thought, are you powering via the Kiwi cape or the BeagleBone Black?

    I seem to remember when I tried one I used the Beagle power connector.

  • Greetings, Stu!

    I'll answer/comment on your questions in the order you presented them:

    • It's located in my shed and it's pretty close to the AP, maybe 100ft, and the AP reports full strength when it's connected.
    • I do not know whether it's booted and not connected or not booted. Great point. I will say in the past when I've had (I think) wifi connection issues a power cycle from the breaker brings it back (in more comfortable wx). A power cycle here was not as effective, until I brought it in the house.
    • It's a Power One linear 5V beefy metal frame supply, rated for 5A I think. My cabling could probably be better, but I'm pretty sure I doubled up the conductors. I may replace with a better cable if I can't prove it's something else.
    • The antenna is a beverage coupled with a small 9:1 voltage transformer - no DC path to the antenna.
    • The barrel is good, fits snug, there's no intermittents when wiggling. I'll have to check whether it's plugged into the kiwi cape or direct to the BBB. I think it's into the kiwi cape.

    Certainly this problem needs more empirical data! Next time it drops out, I'll go out there, bear the freezing cold, and unscrew the box. At least I'll be able to see status lights and probe voltages. I'll also try to keep a record of the temp when I have problems. It's above freezing today and it's been running solid all day.

    Tangentially related, I have a 2 homebrew ESP8266 projects that control my chicken coops and one of them has trouble in the cold. I opened it up and breathed into it for a few minutes and it came back...

    Nick

  • Just manage your thermodynamics better. The Kiwi draws at least 1A @ 5V. So that's 5W of heat generation, which is huge, relatively speaking. But all that heat will be easily dissipated in those kind of temperatures, especially if there is any kind of draft.

    So dump the whole thing in a couple of nested cardboard boxes. Use some crumpled newspaper, bubble wrap etc. in the space between the boxes. Don't tape the boxes shut because you want some heat to leak out. And the cables need a way to exit as well. You'll probably have to undo this "solution" during summer.

  • Nick,

    As there is proper answer from John I'll stand down, but will just fill in why I asked a couple of those questions.

    WiFi, you must be in a much more rural location than myself, WiFi here at 30ft gets knocked out by competing devices and if I'm on their 'secondary' channel only when they start moving lots of data (intermittent breaks). I went optical.

    Power supply, the most common issues, one that can be a pain to track down as the BeagleBone power management is very quick to protect the device from momentary drops, the kind of drops that are hard to spot but easy to create with normal DC cabling. We did have one on here where the lead was a bit longer, and then dropped enough voltage to reset, as the enclosure flexed in some weather conditions.

    I had not thought about lower end temperature issues, interesting, the BBB is only supported down to about 0°C it seems (from a quick web search).

    Leading on from Johns advice I wonder if placing the PSU lower than the Kiwi and ducting warmth from that could assist in really cold temperatures.

  • Beagle team have more expensive BBB-Industrial version: https://beagleboard.org/black-industrial with temp range from -40C to +85C (it's 2x expensive).

    But I know many users who use KiwiSDR (BBG/BBB - simple version, no indastrial) in the small barn without heating with winter temperature -20 ... -25C and don't have any problems with connectnvity, they use ethernet connection to 4G/3G ISP router.

  • Thanks for the input and suggestions, guys. My box is metal and it is completely sealed. I expected some issues with this configuration in the summertime but haven't really experienced that.

    Stu, great minds think alike! Over the weekend when I was messing around with this, I did put the power supply under the kiwi box!

    If I continue to have problems I will probably solder on a temp sensor to the BBB and have a little program log the temp every n minutes. Then if there's a problem I can go back and look at the logs. I'll also consider some insulation around the enclosure.

    Regarding the wifi question, I have a little script that checks connectivity and will attempt to reconnect (connmanctl) every five minutes. When I have looked at that log, there is nothing of interest, i.e., it doesn't look like it disconnected or tried to reconnect during these instances. It is not an "RF crowded" area for wifi.

    Yuri, thanks for the info on the industrial BBB. That may be the best solution if I continue to have problems, assuming I can find one!

    Nick

  • This winter had a similar problem twice due to low temperatures. The receiver is located in a barn without heating. The first time there was a power outage for one hour. And the WiFi USB dongle couldn't start because of the cold. The second time again problems with WiFi USB dongle. It was cold and strong wind. And the dongle stopped responding. Simply turning the USB off and on didn't solve the problem. I had to warm the dongle with my hands and it helped.

  • My solar-powered (ethernet-connected) kiwi is also located in a barn where the temperatures are almost the same as outside. In winter, it is only turned on if needed, to save energy. As it is off most of the time, it always starts without any preheating by itself. It's always running fine, no problems so far - at temperatures of "up" to -10° C.

  • I thought about this issue when it started to get cold out. Fortunately, I haven't noticed any issues as of yet. I have my Kiwi running in a shed in the backyard. Connected using a TP-Link TL-WR802N router configured as a WiFi adapter. Temperatures have dropped well below -4°F (-20°C) many days since the beginning of January, with a good number of days that never went above 0°F (-17.8°C). A few nights that dropped close to -20°F (-28.9°C). Given it's typically a little bit warmer in the shed than actual outside temperatures, I have noticed it below 0°F in there a few times this season.

    Maybe some foam or fiberglass insulation lining the inside of your box would help retain some heat in the winter? Or placing the metal box in a wood box with insulation between the two...

    Otherwise, an incandescent light bulb placed nearby may provide enough heat to keep it just warm enough.

  • edited February 8

    Low temperatures is not so terrible for the equipment. It heats itself up. But a strong change in temperature can be harmful. I have a WiFi dongle Dlink DWA-125 (in a round case). According to the specification, it works from 0℃. According to experiments, it works at a temperature about -20℃. But if it is turned off for a long time, it will not be able to start itself . I need to heat it up. Now I have put some wool socks on it. I think everything will be OK!

Sign In or Register to comment.