My Kiwisdr reboots itself [fixed in v1.485]

Every so often it reboots by itself.

From syslog:

Dec 27 15:17:01 kiwisdr CRON[10282]: (root) CMD (  cd / && run-parts --report /etc/cron.hourly)
Dec 27 15:27:24 kiwisdr kiwid: 02:47:09.608 0... 0  PWD admin config pwd set FALSE, auto-login TRUE
Dec 27 15:27:24 kiwisdr kiwid: 02:47:09.612 0... 0  PWD admin ALLOWED: no config pwd set, but is_local
Dec 27 15:31:59 kiwisdr minissdpd[446]: method CACHE-CONTROL, don't know what to do
Dec 27 15:37:08 kiwisdr kiwid: 02:56:54.445 01.. 1   810.00 kHz am z0 "79.18........(deleted for privacy)
Dec 27 15:37:21 kiwisdr systemd[1]: kiwid.service: main process exited, code=dumped, status=11/SEGV
Dec 27 15:37:21 kiwisdr kiwid[10310]: DEBIAN 8
Dec 27 15:37:21 kiwisdr kiwid[10310]: USE_SPIDEV
Dec 27 15:37:21 kiwisdr kiwid[10310]: LOAD_SPI = no
Dec 27 15:37:21 kiwisdr noip2[10073]: v2.1.9 daemon ended.
Dec 27 15:37:21 kiwisdr kiwid[10310]: Stopping kiwid:
Dec 27 15:37:22 kiwisdr systemd[1]: Unit kiwid.service entered failed state.
Dec 27 15:37:32 kiwisdr kiwid[10329]: DEBIAN 8
Dec 27 15:37:32 kiwisdr kiwid[10329]: USE_SPIDEV
Dec 27 15:37:32 kiwisdr kiwid[10329]: LOAD_SPI = no
Dec 27 15:37:32 kiwisdr kiwid[10329]: Starting kiwid
Dec 27 15:37:32 kiwisdr kiwid[10329]: Start kiwid: OK
Dec 27 15:37:32 kiwisdr kiwid[10329]: Mon Dec 27 15:37:32 UTC 2021
Dec 27 15:37:32 kiwisdr kiwid: 00:00:00.051   KiwiSDR v1.482 -------------------------

Can anyone explain to me why? What can I check or set to solve this problem?

Thanks

fabio

Comments

  • Almost certainly inadequate power. Just like all the other cases of this we've seen. See here: http://kiwisdr.com/quickstart/index.html#id-power

  • I had ruled out a power problem because in the log I saw that the reboot was starting, which should not have been written in the log (I supposed).

    I will try with a better power supply.

    thanks

  • Remember that your power supply can be fine, but if the cable is too long or uses too small of a wire gauge there can be under voltage at the Kiwi during peak current draw. This will cause the Kiwi power controller chip to shutdown (voltage < ~4.75V). See the link I posted.

  • I have replaced the power supply with the recommended Mean Well GST18A05-P1J but the reboot problem continues, 4-5 every day.

    Jan 13 05:26:10 kiwisdr kiwid: 13:04:54.976 0... 0  11750.00 kHz am z9 "192.168.0.5" Modugno, Italy (ARRIVED)Jan 13 05:33:43 kiwisdr kiwid: 13:12:27.816 0... 0  PWD admin config pwd set FALSE, auto-login TRUE
    Jan 13 05:33:43 kiwisdr kiwid: 13:12:27.820 0... 0  PWD admin ALLOWED: no config pwd set, but is_local
    Jan 13 05:41:36 kiwisdr systemd[1]: kiwid.service: main process exited, code=dumped, status=11/SEGV
    Jan 13 05:41:36 kiwisdr kiwid[10120]: DEBIAN 8
    Jan 13 05:41:36 kiwisdr kiwid[10120]: USE_SPIDEV
    Jan 13 05:41:36 kiwisdr kiwid[10120]: LOAD_SPI = no
    Jan 13 05:41:36 kiwisdr kiwid[10120]: Stopping kiwid:
    Jan 13 05:41:36 kiwisdr systemd[1]: Unit kiwid.service entered failed state.
    Jan 13 05:41:46 kiwisdr kiwid[10139]: DEBIAN 8
    Jan 13 05:41:46 kiwisdr kiwid[10139]: USE_SPIDEV
    Jan 13 05:41:46 kiwisdr kiwid[10139]: LOAD_SPI = no
    Jan 13 05:41:46 kiwisdr kiwid[10139]: Starting kiwid
    Jan 13 05:41:46 kiwisdr kiwid[10139]: Start kiwid: OK
    

    Could there be another reason?

  • jksjks
    edited January 13

    Is this your publicly listed Kiwi? If so, can you email me the admin password? I should be able to run the debugger on the core file and get a traceback from the crash.

  • I sent you an email

    Many thanks

    fabio

  • jksjks
    edited January 13

    The crash traceback happens while transferring dx labels to the page. It's not completely clear what's wrong. I added some debug code to log more information the next time it happens.

  • in fact I'm often adding dx label...

Sign In or Register to comment.