Will not update [fixed]

I have KiwiSDR #5743. It is in perpetual update mode.

I have tried to load the software off the SD card but same results. I can get into the admin area no issues.

When I try to access the SDR, I get:

Installed version: v1.2, built Aug 10 2016 21:12:11

Update to version v1.461 in progress

I have let it go over 12 hours each of many attempts.

The LAN lights on the internet connection appear to show activity. I'll try another chord next.

any ideas to try?

Duncan KL7QT


  • jksjks
    edited August 2021

    Just to check I tried it from here. A Kiwi re-flashed using a stock v1.2 sd card updated to v1.461 in 50 minutes. So this means it is probably some network problem. We've seen all sort of issues over the years including ISPs messing with DNS, other problems contacting github.com, DHCP issues, ...

    Do you know how to ssh/PuTTY into Dedian running on the Beagle? Then you could run the update manually and see what sort of error messages you get. The tools that help with this in the Kiwi admin interface are unfortunately not present in v1.2

  • Thanks,

    I am going to visit my son tomorrow who does this exact thing for a living. I have no idea how to ssh/PuTTy but I'm sure he does.


  • edited August 2021


    It turns out it needed was a password. I did that and if sprung to life. The software update had already been downloaded, it was just looking for that to operate.

    All it needed was an admin password.

    It will be on line as soon as I get up a real antenna!



  • I'd like to better understand what you mean in case there's really a bug here or others have a similar issue.

    What was asking for a password? You said earlier you could connect to the admin page while it was building. But also that the build process never completed. It kept saying running v1.2 and building v1.461?

  • On some of my attempts the blue banner would appear saying it would reboot when updated. This was on the STATUS page, I think.

    When I created a password on the security page in the Admin Password box, the radio came to life. No waiting for v1.461 to load, it was immediate.

    I have got out and got back into the radio many times, no issues.

    From when I performed to SD Card load to entering the admin password was about 4 hours, so it had plenty of time to load the update.

    Starting from the first time I powered up, the Ethernet LEDs showed activity for hours.

    I was always able to access the Admin functions using http://kiwisdr.local:8073/admin

    I was never asked for a password, I was just looking for anything when I noticed the

    "No password set: no admin access from internet allowed" box. I stuck in a password and it all came to life.

    That's my story

    Duncan KL7QT

  • Okay, thank you.

Sign In or Register to comment.