GPS remains stuck on PAUSED status [fixed]

edited May 2021 in Problems Now Fixed

I am setting up a new KiwiSDR. The GPS never acquires any satellites, apparently because acq remains as "paused". I have tried without any users connected to the kiwisdr, and I have tried all the settings/check boxs on the GPS tab. It still remains as paused after reset or power downs.

The Installed version is: v1.451, built May 2 2021 09:46:19

Status states:

Config: v1.451, 4 SDR channels, 12 GPS channels

GPS: acquire pause, track 0, good 0, fixes 0

SNR: All 2 dB, HF 2 dB

I have found an older similar post in the forum which stated to try:

cp admin.json
sed -i 's/"enable_gps":false/"enable_gps":true/' admin.json

When I run the above, the status remains paused in the GPS tab.

Any help would be much appreciated.

Thanks, Nestor 5B4AHZ


  • Genuine Kiwi or clone? (it saddens me that I have to ask this now)

    If it isn't set already, try checking the "acquire if Kiwi busy" box on the admin GPS page. It takes a little while before this change has an effect.

    Can this Kiwi be made accessible from the Internet? That would probably mean redirecting port 8073 from your Internet router to the Kiwi's local ip. If you can't do this then we can use the proxy service as an alternative. Please email with your public ip.

  • It seems genuine. There is a serial number on there: 5545, and was purchased from a reputable European seller.

    I don't have it connected to the network yet. I'll arrange to do that tomorrow.

    If this 'helps'... when I first switched it on, and before it's firmware was upgraded to the latest version, I did click to the button to switch off the GPS, while exploring it's menu.

  • So I found admin.json containing "enable_gps":false despite what you said above. As soon as I change it to true and restarted the GPS worked fine. I restarted again after a few minutes and the setting persisted.

    The admin user interface to change enable_gps was removed long ago. So it's a mystery to me how it would have become set to false. The default on installation is true of course. No one else seems to have this problem.

  • Thank you so much for your help and support John.

    MUCH appreciated. I'll keep an eye out for it, and I hope it'll hold.

    Soon the unit will be relocated to a site away from the city. It will be a location in the middle of nowhere. I hope it will be a positive addition to the world network of kiwisdr's.


    de 5B4AHZ

  • Yes, this location will be most welcome from a TDoA point of view. So thank you considering making it public.

Sign In or Register to comment.