Good morning....

in recent weeks by accessing my kiwi locally via the URL
http: //kiwisdr.local: 8073 /
the Mozilla browser page either doesn't open until you repeatedly press the Reload button or it has a latency time of more than 10 seconds, does anyone know the reason for this problem?

I add that I reset the Kiwi server without getting any improvement. if I use the Chrome browser this problem does not exist. This problem does not exist with other Kiwis on the net.

How can it be solved?

thanks for any kind of help


  • jksjks
    edited June 2020
    I don't think this will help but I'm curious if it makes any difference: Go to admin page, "webpage" tab (use Chrome if necessary). Scroll to bottom. Change "Web server caching?" option from "yes" to "no". Go to "control" tab and click restart.

    In Mozilla/Firefox (or whatever Mozilla-based browser you're talking about) be sure to hold down the shift key when clicking the reload button. This will force a proper cache clear in case there is something funny about caching. Or go to the browser preferences and do a full cache clear.

    We've seen excessive load time (10s of seconds) for parts of the Kiwi web page in only a few instances. When the Internet connection is extremely slow (not a factor in your case since it's a local subnet). And when there has been an intermediate caching device on a corporate network that is "improperly" caching the Kiwi pages. The exact failure situation for the second case is not fully understood. Browser caching is a complex topic. The workaround was to add the "no caching" option to the Kiwi web server and side-step the problem. It cured the particular case of the misbehaving corporate caching device at the expense of greater data transfer when first connecting to the Kiwi.
  • thanks for the answer I will do some tests.
  • edited June 2020
    I have not found any improvement, the Kiwi page remains white or after repeated reloads it appears after 7 seconds.
    and if I try to launch an extension like DRM after logging in to KIWI nothing happens.
    I enclose a copy of the log file.

    I send you in private (e-mail) the restart LOG of my KIWI if it can be useful.

  • edited June 2020
    What OS is this on?
    I did wonder about IPv6 and that logs shows a mix of IPv4 and IPv6, it's quite often that an OS will prefer IPv6 and if it is not successful timeout and use v4, would give that sort of delay and often not seen by ping as that uses a different mechanism (I believe).

    If you are on Linux there is a fix to stop Avahi using v6 and causing v6 timeouts.

    Chrome may not show the issue as that does everything via Google (so they can properly track you ;-) )
  • jksjks
    edited June 2020
    The Kiwi log is not helpful in this case. Debugging caching problems is complex and requires information directly from the browser. You say Mozilla. Are we talking Firefox here? Is it upgraded to the latest version?

    What you do is open the "developer tools" window at the bottom of the browser page, select the "network" tab and reload the page. Then you have to study all that information carefully, including the timing diagram on the right, to try and figure out why things are so slow. I cannot give you more information than this. It is a very complex topic.

    It is not a Kiwi problem because you have other browsers that work. And the failing browser works with other Kiwi sites on the Internet. This is a browser and/or networking problem.
  • edited June 2020
    the operating system is Windows 10 Version 10.0.19041 build 19041, networked with FTTC technology with VDSL2 up. 75 down. 21 Mbps

    the browser is Firefox version 77.0.1 64bit

    the problem occurred in the last 4 weeks previously these latency problems had never occurred or the Kiwi management page was not opened.

    I emailed JKS a PDF file with the Firefox and Google network cards if it could be useful to find the problem.

    For the rest I do not know what to add, in any case thanks for the help information.
  • On my Mac the network tab doesn't look like that for FF 77.0.1 which is strange. The problem is not with those two entries. Those are the long-lived web sockets that persist after the page is loaded.

    The real problem with that output (the one you emailed me) is the long (4+ second) "DNS resolution" times in pink with a lot of those GETs. Double-click on the colored bar to see an explanation of what the colors mean. Why is your DNS taking 4+ seconds to resolve kiwisdr.local sometimes? Try using the Kiwis local ip address instead ( I think from your log output?) This is definitely a networking problem of some sort. Probably a Windows 10 problem.
  • with the local IP address the rise of the application is immediate, maybe I will use this option to launch the application.

    however, if I understand you attach the string dellla DNS resolution as you had previously written, for each utility.

  • NOT a Kiwi problem. A DNS problem.
  • edited June 2020
    This is something you could test if you want to keep using the "local" address rather than IP.

  • edited June 2020
    Thanks for your help.
    I made the change as per your instructions, but it doesn't seem to have had the desired effect as I subsequently restarted the operating system and launched Firefox with the Kiwi.local URL ...... but as you can see from the Attached image there are 2, 13 seconds for DNS resolution on the first string, while on the second this string there are 1.60 seconds of waiting for a blocked [BLOCCATO in Italian]

    I also tried to launch the Kiwi.local URL ..... also on CHROME with the results you can see from the attached image [pending].

    Exactly SND and F what they are, sorry for my ignorance on the subject but I can't understand their meaning.

  • I add the same strings when I access any kiwi on the network with firefox

  • OK thanks for testing that.
    Without dragging this out too much more (as JKS says it is not Kiwi specific) it is probably to do with the web browser and how it gets the network address for the local Kiwi (DNS, or mDNS) and then data, it would happen with other local device accessed using the same discovery method.

    --cuts out load of my waffle about Zeroconf and mDNS--

    As you can get to the Kiw by IP address I'd do that.
    Not sure what is actually blocked there but again that is probably part of the browser extensions, tracking blocking, or even local antivirus setup.
    Too many variables to bother with if you have another method.

Sign In or Register to comment.