Building 1.384 fails on BBAI


my Kiwi on BBAI fails to compile 1.384, coming from 1.383.

The server log shows this:

Wed Apr 1 11:07:16 29d:06:07:11.047 .... [00] ADMIN connection closed
Wed Apr 1 11:07:33 29d:06:07:28.467 .... UPDATE: build error, check /root/build.log file, status=0x00000200 WIFEXITED=1 WEXITSTATUS=2
Wed Apr 1 11:07:33 29d:06:07:28.468 .... task update_task:P3:T05((1000.000 msec) TaskSleep) exited by returning
Wed Apr 1 11:07:35 29d:06:07:29.997 .... [00] send_msg: 0x4b2bb00

Log file contents:
File: build.log
======== checking for updateWed Apr 1 11:00:16 UTC 2020========
buildingWed Apr 1 11:00:22 UTC 2020Removing Makefile.1
From * branchHEAD-> FETCH_HEADAlready up-to-date.rm -rf obj obj_O3 obj_keep kiwi.bin kiwid.bin *.dSYM web/edata*rm -rf *.dSY
M pas extensions/ext_init.cpp kiwi.gen.h kiwid kiwid.aout kiwid_realtime.bin .comp_ctr(cd e_cpu; make clean)make[1]: Entering directory '/root/Beagle_SDR_GPS/e_
cpu'rm -rf ../../build/tools/asm* ../../build/genmake[1]: Leaving directory '/root/Beagle_SDR_GPS/e_cpu'(cd verilog; make clean)make[1]: Entering directory '/ro
ot/Beagle_SDR_GPS/verilog'rm -f kiwi.coemake[1]: Leaving directory '/root/Beagle_SDR_GPS/verilog'(cd verilog/rx; make clean)

Any idea?




  • ... a simple reboot did solve it. Strange anyway, but it worked now.

  • 2 of my BBAI upgraded w/o a issue... one per schedule, one I forced
  • I did not try it on my BBAI here (should have). But that build.log file looks okay, but it is short. I was expecting a lot more messages that might have also contained an error explaining why the build failed. I'll give the BBAI here a try. Glad to hear a retry from a reboot worked. But still it shouldn't have failed.
  • Worked okay on my BBAI.

    It's a shame your cut-and-paste didn't get the last part of the log file. It looks like the line breaks got removed and that's why all the messages are run together. This in turn has caused a buffer overflow someplace due to the long line of text. And as a result we only see the first several messages and not the last few which is where some error info might be located.

    Each build truncates the log file so it doesn't grow without bound. So the evidence is gone now..
Sign In or Register to comment.