The KiwiSDR 2 online store is open for orders! Please visit kiwisdr.nz

New out of box KIWI updating issue. Compiles the same files over and over again. [git fetch issue]

2»

Comments

  • edited January 2020
    I reserved the internal IP to 192.168.1.8 (which is what it had changed to) and I opened port 22 for you. Is it still not right?

    The external ip is dynamic I think. I will check whether it has changed and report back.
  • Just gets a timeout after a while. Can you ssh/PuTTY to the Kiwi from another computer on your local network? That would rule out the Kiwi sshd.
  • Sent you a pm with the new external IP and all current details. The internal address is now reserved.
  • Re-routing the "git pull" connection to Github in Sydney worked fine (it's building now). So most likely a Github configuration problem in Manchester. But this is just going to happen all over again on the next update, so a permanent fix is still needed. A dozen or more UK Kiwis updated to v1.376 yesterday without problems it seems looking at the map. I should check one of them and see if a pull from github.com also goes to Manchester.
  • I sent you a pm with the new external IP and internal too.The ssh port is open.
  • Sorry we crossed there. I doubled my post. I think I was looking at the first page and thought it hadn't worked. (dumb fellow) :((

    Hopefully, it will just work now and when it comes back the sound will be back. Somehow I started out with sound, but it vanished. .
  • I stopped the Kiwi server while building the new release (it builds somewhat quicker that way).
  • You sir, are a total wizard.!!!!

    Looks great. Sound is back. This old git is very pleased - and impressed with what you did there.

    Thanks a million. Looks like we are in business. I'll give it a whirl and tell you what it is like.

    Thumbs up to you for that.
  • jksjks
    edited January 2020
    Okay, you should be running v1.376 now.

    I checked another Kiwi in Somerset which showed a git pull going all the way back to San Francisco. So maybe this is some shenanigans being played by your ISP (an attempt to cache content that backfires and results in the TLS failures). We had a similar case with Telstra in Australia a few years back.
  • v1.377 contains a fallback that retries the git pull using a fixed ip address for github.com. Interestingly, about half way through checking the fix on Tony's Kiwi the git pull to github.com (using the domain name) started working. So that means this was probably a mirror server configuration issue by Github as opposed to an ISP issue. Anyway, the fix is in and will hopefully save someone some grief in the future.
    KA7U
  • Great to see such excellent customer service John. Delighted with the product here. Had a go at making a better antenna and dropped the noise pick up dramatically. The thing performs really well, but I will try to get a lower noise floor by experimenting.


    :)
    WA2ZKDG0LUJ
Sign In or Register to comment.