Unable to recover to SD card backup

Hi John,

As part of my attempt to recover my KiWi that had previously been used in an attempt to add a WiFi dongle (and had been running via an ethernet port, but wouldn't stick to a fixed IP address), I've tried to regress to a previous known good backup on SD card (V1.286).

Unfortunately it's just running in a continuous cycle of reboots and double LED flashes, then "cylon" LEDs and another reboot and self power up.

The ethernet port is active and the yellow and green LED's are up with occasion green flashes, but it doesn't seem to get an IP address allocated.

I've tried http://kiwisdr.com/scan/ and it doesn't even find my active KiWi, so that's not much help.

I've now tried four different SD card backups and it always behaves in the same way.

I thought the SD card re-loaded the OS from scratch in addition to the KiWi S/W but maybe this is not the case ?

Any suggestions ?


Martin - G8JNJ


  • Update.

    I made an up to date backup of one of my other KiWis which is at v1.359.

    Unplugged that KiWi and plugged in the problematic one.

    Plugged in the SD card and it seemed to load, but then I just get sequences of bright and dim (I had set the LEDs to dim in the KiWi admin interface) and then "cylon" LEDs again.

    I tried updating using the backup of my WiFi edited config and that updated and ran OK, so I know that the hardware is OK.

    I just seem to have somehow trashed the underlying OS and I can't recover from it using the SD card.


    Martin - G8JNJ
  • Hi Martin, might be wrong here but doesn't it cycle the leds while writing to the onboard memory? it can take a very long time, like walk away for 40minutes then come back see if it is dark.
    With no leds showing take the card out and power cycle it.
  • Hi Stu,

    I've waited for >two hours :-(

    I got it running again with a v1.359 SD card copy of the other KiWi after previously loading a v1.309 with the WiFi configs (Loading v1.359 didn't work when I'd previously used the v1.286 backups to try and get it up again).

    When it was running using the v1.359 copy of the otehr KiWi I then changed the IP address back in the admin page to what I wanted it to be and rebooted. But now it's no longer getting an IP address again.

    I'll leave it on overnight just in case some network tables somewhere are not getting flushed out and the IP / MAC association is screwing things up because I've swapped KiWi's and IP's around so many times.


    Martin - G8JNJ
  • Final update.
    1. Got the problematic Kiwi to run using a v1.359 SD card copy of another KiWi.
    2. Changed the KiWi IP address to a static IPv4 and confirmed ARP rule setup in router.
    3. Rebooted but still got assigned a DHCP address.
    4. Kiwi admin page shows fixed address is selected and saved, and a message with green background below address entry box on network admin page confirms this.
    5. Changed KiWi back to DHCP and rebooted, but still got assigned a DHCP address.
    6. Rebooted KiWi and router, but but still got assigned a DHCP address.
    7. Changed KiWi back to static address, which was still stored in text box on KiWi admin page and rebooted.
    8. Kiwi now running on specified static address.

    Next problem is my trashed wsprdaemon which doesn't want to run properly after I changed the target KiWi IP address in the config file.


    Martin - G8JNJ
Sign In or Register to comment.