Problem with static IP address

Hi All,

I had a power outage yesterday and realised that one of my KiWi's wasn't using a static IP address on my network.

I've tried setting a static IPV4 address in the KiWi and also tried various combinations of static ARP settings on my router, but I can't seem to get it to stick, as it's still allocating dynamic IP addresses.

Any suggestions ?


Martin - G8JNJ


  • Using ethernet and not wifi?
    You've set the correct parameters in /etc/network/interfaces, and commented out the eth0 dhcp definition?
    Example like this.

    auto eth0
    # iface eth0 inet dhcp
    iface eth0 inet static

    What do the logs on the DHCP server say when the Kiwi stands up on the network asking for configuration details? Is the MAC address staying the same each reboot?
  • When you change the DHCP/Static mode are you then clicking the confirmation button? The one in yellow that appears near the top of the screen that says "Are you sure? ..." After confirming you will be prompted to reboot. If you don't reboot (NB: not simply restart) the change won't go into effect.

    The Kiwi code is supposed to edit the fields in /etc/network/interfaces. You can check that file as Cathal recommends. Don't edit that file directly. The Kiwi will then be out-of-sync between what the file contains and what its configuration thinks the DHCP/static state actually is.
  • Hi Cathal & John,

    Thanks for that, it's just reminded me that I think this KiWi was the one I tried to (unsuccessfully) add a WiFi adaptor to some time ago.

    So it's probably messed up the eth0 interface settings.

    I'll try reverting to a backup I made before the WiFi tests and see if that fixes it.


    Martin - G8JNJ
Sign In or Register to comment.