GPS is always Paused

I am setting up a new KiwiSDR. The GPS never acquires any satellites, apparently because acq is "paused" and never "yes." This true for zero users and any setting/check box on the GPS tab that I can find. It survives any reset or power down. If I run a receiver, it shows "v1.356, 4 SDR ch, 12 GPS ch, GPS acq pause, track 0, good 0, fixes 0." Somehow this must be set in a config file in the BBG? I can't see where others have this problem. Can someone help me?? Thanks, Bob


  • jksjks
    edited December 2019
    Hmm. Try something for me?

    Connect to the admin page. Select the "console tab". Click the "connect" button.
    On the "enter shell command" field at the bottom of the page type these commands:
    gr enable_gps admin.json
    In the output that appears in the box above do you see, in red, "enable_gps"? Is it followed by "true" or "false"?

    Also, is your Kiwi available from the Internet? If so please email the ip address or URL to and I'll look at it.
  • Long shot, renew the admin connection (Ctrl +F5 to refresh or close and reopen the browser).
    On the GPS tab try these settings then see what it is doing.

    It might be that it was doing the full update so paused but the page has not properly refreshed.

    As I said long shot but good to refresh the admin page first whenever something does not seem right.

  • jksjks
    edited December 2019
    Good point Stu. If the Kiwi is new out-of-the-box and has recently had its first Internet connection it might be in the middle of the initial long upgrade (20 to 30 minutes). During that time you can connect to the admin page. But user connections and GPS are disabled to give more CPU cycles to the upgrade process. I should probably make it display a message saying that..
  • It has many hours of operation, and several restarts and the "Paused" persists, so it doesn't seem to be a temporary Pause.

    OK, Running the BBG Console:
    root@kiwisdr:~/kiwi.config# gr enable_gps admin.json


    all":true,"sdr_hu_register":false,"api_key":"replaced with API key from","port_ext":8073,"firmware_sel":0,"tlimit_exempt_pwd":"","server_enabled






    The interesting variable would seem to be "enable_gps":false

    It is not available yet on the internet as I am still learning router-speak. Soon, I hope.

  • jksjks
    edited December 2019
    Okay, do as before but this time type the commands:
    cp admin.json
    sed -i 's/"enable_gps":false/"enable_gps":true/' admin.json
    Note carefully the mix of single ( ' ) and double ( " ) quotes in that command. Type it exactly. Get it wrong and your Kiwi might become bricked.
    Then immediately go to the "control" tab and click "KiwiSDR server restart" and "Confirm" without doing anything else in-between.

    "enable_gps" is an old config setting that was superseded by the three GPS system settings (Navstar/QZSS/Galileo). There is code to force it "true" but somehow that has failed us here.
  • Good news is that everything is "not-bricked."

    Success, "gr enable_gps admin.json" produces ..."enable_gps":true, ...

    The GPS tab no longer shows acq:paused

    AND We are tracking satellites:GPS: acquire yes, track 5, good 2, fixes 0

    Given time and maybe better antenna position (it is inside now) all will work.

    Thanks much. I don't know how it got there, but its FIXED. Bob
  • jksjks
    edited December 2019
    I see an improvement I can make in the code to eliminate this in the future. Thanks for calling it to our attention.
Sign In or Register to comment.