Problems updating dx.json


I've just noticed a problem when trying to copy a dx.json file across from one KiWi to another.

I use WinSCP to transfer files to and from my windows PC and KiWi's.

I copy the 'good' dx.json file which I regularly update from just one KiWi to the PC, and then use WinSCP to delete the existing dx.json file of the other KiWis and replace it with the more recent version.

This method has worked perfectly OK for the past year or so, but now I don't see the updated tags in the KiWi GUI, even though if I check the dx.json file with a text editor I can see the new file date and additional entries, proving that the file has indeed been updated.

I tried different browsers, cache clearing and KiWi reboots, but the problem remains.

Any suggestions ?


Martin - G8JNJ


  • jksjks
    edited July 2019
    Make sure the Kiwi server is not running on the destination Kiwi where you are going to replace the dx.json file. You can't change the file on-the-fly while the server is running. It reads the file once at startup and that's it. However it gets written each time a change is made from the Kiwi UI.
  • Thanks John,

    That worked, and having thought about it, it should have been pretty obvious to me too.


    Martin - G8JNJ
Sign In or Register to comment.