Can't communicate with Kiwi [fixed in v1.301]

edited July 2019 in Problems Now Fixed
My Kiwi is connected to the switch for my local LAN.
Per MyLANViwer, it was assigned .
I can ping it with no problems.
However, browser access to the Kiwi always says the device can not be found.
I've tried Chrome and Edge.
I've tried //, , and
I've also tried the kiwisdr.local:8073/admin and kiwisdr.local:8073 .

My only and wild guess is that pinging only relies on the Beagle firmware but the 8073 port requires Kiwi software. True?
I may or may not have a happy Beagle: the left LED flashes twice. Other LEDs are on. I don't know what they mean so they may have a message I need to understand.



  • My only and wild guess is that pinging only relies on the Beagle firmware but the 8073 port requires Kiwi software. True?

    Can you login as root to the Beagle using ssh/PuTTY? If so, try these commands to see what is going on:
    Look for looping behavior (Kiwi server restarting over and over again) and paste a chunk of the messages here.
  • edited July 2019
    --sorry missed that you did try

    I know it's probably a typo or three but what is the real address?
    You said it got "" (which is probably because that is a normal class C private address
    Then you tried addresses that are not the real address or the typo'd one?

    Try (not https:// as some browsers default to now) intially (unless you have already got in by SSH)

    Only other observation/question what type of PSU are you using?
  • Yes, I can log into the Beagle at as root with a blank password.
    cdp executes but produces no output to the terminal. ms1 gives me a command not found message.
    As for looking for looping behavior, I suppose that means output to the terminal, right?

    And yes, if I typed 158 in the address, it should have been the normal 168. Bad eyes yield many typos.

  • PS I always used 168 - the 158 was just a posting mistake.
  • jksjks
    edited July 2019
    Sorry, those commands are aliases (shorthand, I am lazy).
    cdp = "change directory project". Produces no output, goes to the Kiwi build directory.
    msl = "make short log". That's the letter L, not the number one.
  • I've been searching the forum and found something that seems suspiciously relevant.
    I didn't mention this as I didn't see the connection but now I'll mention that maybe 30 minutes after first power up I tried to connect to port 8073 and was told "software update in progress".
    Since then, I've gotten the "cant connect to page" message from Edge.

  • jksjks
    edited July 2019
    Okay, I'm looking at a problem now related to updating from v1.2 which ships from the factory with new Kiwis.
  • Monsieur ujks:
    I tried ti test again but when I getti the Beagle password via putty, a blank password does not get me in.
    What do I do?

  • Make sure you are logging in to the "root" account. There is no password on the root account. There is no way that could have changed (unless you changed it, which you probably didn't).

    When you get in again try the two commands "cdp" and "up" and see if that fixes the problem.
  • Yes! The cdp and up did the trick. After perhaps 10 minutes, the update finished and now opens the Kiwi page and I hear the receiver.
    So apparently the version of software in my Amazon unit locked up when it tried to do an automatic update?

  • Yes, there were a couple of problems here. One my fault and one Google's fault (apparently). I introduced a bug in the v1.299 release that caused server boot-looping after an update from the v1.2 factory image. Google supposedly (if you believe reports on the net) changed some package key "without telling anybody" which caused the Kiwi's installation of the clang compiler to fail. Again on an update from the v1.2 factory image.

    v1.301 fixes both of these issues. Apologies for the inconvenience.
Sign In or Register to comment.