New Kiwi from Mouser.. can't update [fixed in v1.287]

edited May 2019 in Problems Now Fixed
I bought 2 Kiwi from Mouser for a work project. They booted v1.2 and went off and tried to update themselves. I tried a few known kiwi-capable PSU and even went the SD fresh start mode. I can get them to report Update in progress, but after that, they will not respond on port 8073.
I can however ssh into them.


  • Interesting.

    I just received one from the last Massdrop that I'm currently setting up. The initial update to the latest version was taking forever.

    In the end I cheated and used one of my SD backups from a KiWi with a more recent version to get it close to what I wanted, then let it update and configured the rest.

    Just an observation, but maybe the supplied image and SD backup is now getting a bit 'old' and a newer version should be supplied with the KiWi ?


    Martin - G8JNJ
  • Jim, can you make port 22 on one of them accessible from the Internet? (be sure to put a root password on the Beagle first)
    Also, were they trying to update from your home network or at work? If at work there might be a problem with accessing github and/or using git. We've seen corporate network strangeness with this before.

    I really, really, really, don't want to ask Seeed to do anything different. It was enough of a pain to get them to do things properly the first time. There is no reason an update from v1.2 to the current version should be any worse than if Kiwis were shipped with a newer version. You're always going to network update no matter what.
  • edited May 2019
    Thanks John
  • Its empty blank /root/kiwi.config/admin.json file thats sending it into fail 30 second restarts.
  • John, see my email, PW is same
  • edited May 2019
    @jimcny yes I see that file as empty. scp of one from another kiwi fixed it
  • Guys, I know all this. But I'm not going to ask the average new user to start moving admin.json files around. That's a recipe for disaster from a support perspective.

    And it's also not completely correct. Since v1.2 there was a point at which some parameters from kiwi.json were moved to admin.json. But if after this problem you simply copy admin.json from a different source (another Kiwi or the prototype directory in Beagle_SDR_GPS) then you are missing the step of removing the old parameters from kiwi.json. This may not give you an immediate problem. But you now have duplicated parameters in both files. A possible ticking time-bomb that might get triggered for some reason in a future update. Rebuilding from scratch from v1.2 to v1.287 was designed to completely avoid that situation.

    And the file was not empty, but rather contained an empty json definition of "{}". That was pretty much the clue to the entire problem.
  • after installing v1.287, both would still not come up for SDR access. I copied my admin.json from my 1.287 running system and then both v1.2-> v1.287 ran fine. So not sure what I have to do next to get things right
Sign In or Register to comment.