wsprdaemon - A Raspberry Pi WSPR decoding service



  • edited May 2020
    Anybody notice Europe (WSPR anyway) is fairly on fire today?
    solarham doesn't look too active but some stations are heading for 40,000 spots today.

    Of course my Grafana has given up since a recent dist-upgrade but the WSPR numbers are very unusual.

    So what are they doing? using HARP to power up the west coast US for a big one? Joke!
  • Yes we have Sporadic-E since two days almost non-stop, 10m was/is open all over Europe!
    Even at this time (local midnight) i still receive S9+ signals from UK on 10m.
  • Hi Folks -

    I've had Kiwi for just a few days but already love it. A second is on the way to use as an 8 channel WSPR receiver.

    A question about wsprdaemon:

    I'd like to use an Ubuntu-friendly SBC like Odroid as the wsprdaemon host machine. I use Ubuntu daily, but for my work as a writer. :-) So I'm not the world's greatest - in fact, I'm one of the world's worst - CLI / Terminal jockeys. I can follow directions and "read the forums", but I have little common sense or offensive skills to attack problems.

    The question: Do recent versions of wsprdaemon still easily install (as people reported before) on Ubuntu machines? And will I be buying myself additional headaches if I go that route?

    I guess I'm also assuming that, with wsprdaemon running 8 channels, there will be enough CPU left on the Odroid to do something else - like periodically reload and display a map of WSPR spots.

  • Hi Edward,

    WD installation remains as automatic as I can make it on any Ubuntu ARM and i86 platform.

    An Odroid or Pi4 has plenty of CPU power to service 2 Kiwis both in 8 channel mode and at the same time act as a modestly performing Linux desktop machine. But the Pi 4 is so cheap that most WD users dedicate it to WD and run their desktop on a i86 laptop.

    For more information look at

  • I have an Odroid XU4 running Ubuntu and wsprdaemon.... connected 2 each KiwiSDR/BBAI... 28 channels at once. Runs just fine.
  • I am starting with fresh install, but running into issues


    1. I can't monitor my spots using the commands Rob suggested:
    • pi@Maui-Pi85:~/wsprdaemon/uploads.d/wsprnet.d/spots.d $ cd /home/pi/wsprdaemon/uploads.d/wsprnet.d/spots.d

      pi@Maui-Pi85:~/wsprdaemon/uploads.d/wsprnet.d/spots.d $ ~/wsprdaemon/ -d

    because I don't have an uploads.d subdirectory...only hashtag.d and kiwi.d

    2. When I enter ./ -a I get the following errors at startup

    /usr/bin/wsprd: error while loading shared libraries: cannot open shared object file: No such file or directory

    Tue 04 Aug 2020 06:04:02 PM EDT: INFO: /usr/bin/wsprd is version 1, so set command line flags to '-d -C 10000', but you should update to wsprd version 2.x

    3. When I type ./ -s it says the PID are running, but I don't see any spots uploaded. I am using the sample config file from (modified for my Kiwi IP address)

    I know I am so close (thanks to Tom WA2TP)...I appreciate the help in advance.

    Mark Lunday, WD4ELG
  • Got it working!

    First, I did some reading on the web about missing Fortran libraries, and tried

    sudo apt install gfortran

    and it gave me an error. Suggested I run

    sudo apt --fix-broken install

    which ran successfully. Then I ran wsprdaemon again and no error this time.

    Still no spots.

    I just noticed in my KiwiSDR it says "WSPRDAEMON v2.3"

    I originally followed the install instructions from the KiwiSDR thread from last year. When I realized I was using v2.3, I upgraded following the instructions here:

    Even a caveman (me) can do it! I remember being intimidated when I first reviewed the instructions, but Rob Robinett has done a fabulous job, and it's fun tinkering with an R Pi and Linux!

    Mark, WD4ELG
  • One for Rob (no follow up needed),
    Checking my Grafana plots, 40m together with 60m were virtually a straight line, all the others looked normal.

    Long story short I had a -1000dBm/1Hz recorded at the same time on those two bands so the "Auto" scale was doing it's best to keep everything in view.
    1:36AM was the exact moment we had a fairly local, singular, lightning discharge.
    I am somewhat impressed that it caught it, equally disturbed that all my Kit was connected to the antennas at the time.


Sign In or Register to comment.