Problems with the "Click/tap to start OpenWebRX" prompt on Android mobile devices? [fixed in v1.261]

edited January 2019 in Problems Now Fixed
Is anyone having problems not being able to get past the "Click/tap to start OpenWebRX" prompt that should appear on mobile devices and some pc browsers? I've had a report of this being broken for about 5 days on Android. But I don't yet know any specifics about Android OS version, mobile device type, mobile browser type, etc. The only thing I know is that the reporter said Kiwis worked fine using pc Firefox & Chrome. So that rules out local networking problems.



  • Can't get past it on Android 8.0.0 running on a Moto e5play phone with a (mobile) Chrome browser.
    PCs, both Linux and Windows fine.
  • Okay. Does it work with any other browsers on this phone? When you say "can't get past" does that mean it just doesn't do anything when you tap on the screen? Is the waterfall flowing behind the white "play button" overlay? Do you hear any audio despite not having tapped the screen yet?

    Has this broken recently or has it never worked on this phone? Has it worked on an older Android version on this phone?

    Sorry for all the questions, but without them it's extremely difficult for me to guess what might be going on. Thanks.
  • It does nothing. No waterfall. No sound. No interaction. semi-transparent "Click to start..." over control and normal screen.
    I'm not certain that it ever worked on this particular phone. I think it has previously but not sure which phone I was using.
    Must find another browser to try and load it onto phone. Late here so must QRT until tomorrow.
  • Correction. SW update was in progress! waited and now I get past the "click to start" and am able to select modes. No sound though. Waterfall not running. Doesn't look like splash screen (customized) ever came up, at least not the image I had.
    Refresh of the URL got me back to "Click to start" with no interaction again. Waited 2 minutes and "click to start" disappeared and back to control panel w/o custom image. Can collapse/enlarge control panel. Can move decoded/rx frequency. no WF and no audio.
    RX operates and looks normal on PC/browser and is serving several rx's of remote WSPR.
  • For what it is worth just tried my Android phone, no issues seen. Might pay to clear the browser data and see if there are any apps affecting browsing.
    Is the phone fairly recent or a good few years old?
  • What Android version is your phone running?

    The only Android device I have here runs 4.4, which by now is ancient (and the Kiwi stuff runs fine on it). So I guess I need to buy the cheapest tablet I can find running 8.x to do some debugging.
  • Upon rechecking this morning I find that after a minute or two, it enters a normal display. There is evidence of a waterfall having been recorded, as in cache or something, but no sign of new data. Status indicates "Audio underrun", flashing 1 PPS. and Audio 0|48xyz with xyz changing at 1 pps .Extensions come up but take no data. Zoom can be changed but no data. Trace on spectrogram is always off screen.
  • Works fine here on my Moto Z Force Droid, Android ver. 8.0.0
  • Is there a reason you guys don't run 8.1 on your Moto's? From what I've read recently it should be offered on the E5 and Z. Maybe the update isn't pushed automatically and you have to do something to get it.
  • Not yet offered. Still running the 8.0.0 from October. I'm not sure it's possible to get it until it's released by the provider.
    The page does run just fine on an older Kindle Fire, Sept 2018 with a "Silk" browser. Waiting for an update to If it stops running when that's installed I'll let you know.
  • When I check for an update, the phone service provider shows 8.0.0 as the current version for the system. So the updates are pushed and I don't know how to update out of the system provider's schedule. What is more, I do not know the consequences of updating ahead of their schedule, or if the phone would need to be unlocked to update out of the system agenda.
  • who is the provider? Verizon, AT&T ?
  • Comcast using Verizon on my Android 8.0.0 phone that is not working.
    Kindle updated to with Silk continues to work fine.
  • Verizon is my cell provider and version 8.0.0 works fine on this phone.
  • jksjks
    edited January 2019
    The v1.261 release may fix the recent issues with the Kiwi user interface freezing at different points during startup on devices running Android 8.1.x. Please let me know if this release improves any problem you might be having.

    I was able to replicate the issue using a new, but highly underpowered Lenovo Tab E7 tablet running Android 8.1.0 ("Go" version). I had to change a Javascript algorithm to not be so demanding (cpu cycles needed within a realtime constraint). This is very odd because the previous Kiwi version ran just fine on an old Huawei T1 7.0 tablet running Android 4.4.2 and a fairly recent version of Firefox. So this is probably not a mobile browser problem.

    Amusingly, I noticed in general Android 4 on the Huawei was much more responsive than Android 8 on the Lenovo. The two devices use very similar processors (quad core 1.2 vs 1.3 GHz ARM A7).
  • My Moto e5 Android 8.0.0 that previously did not work now works.
  • Several users who had long ago complained that Android 7.x stopped working on their particular device now report that this fix makes their device work again. So if you're in that category give a Kiwi running v1.261 or later a try and see if it now works. And please let us know here if it doesn't.
Sign In or Register to comment.