Can't upgrade from v1.242 [fixed with reinstall of Beagle_SDR_GPS git clone]

edited December 2018 in Problems Now Fixed
One of my Kiwis is stuck at v1.242. 'Force software build' has no effect and when executed 'top' shows 'make' running briefly and then kiwid resumes running.
It appears my source tree is corrupt, but it isn't clear to me how to clean it out and run a build:

root@kiwisdr:~/Beagle_SDR_GPS# git pull -v
error: object file .git/objects/1c/fc685261f650315aea5b7a5c6f3d8c69d810a4 is empty
error: object file .git/objects/1c/fc685261f650315aea5b7a5c6f3d8c69d810a4 is empty
fatal: loose object 1cfc685261f650315aea5b7a5c6f3d8c69d810a4 (stored in .git/objects/1c/fc685261f650315aea5b7a5c6f3d8c69d810a4) is corrupt
fatal: The remote end hung up unexpectedly
root@kiwisdr:~/Beagle_SDR_GPS# alias | grep -i make
alias m='make'
alias m0='make OPT=O0'
alias mc='make clean'
alias mcd='make clean_dist'
alias md='make debug'
alias mdi='make disable'
alias mdu='make dump'
alias men='make enable'
alias mfu='make force_update'
alias mgit='make git'
alias mi='make install'
alias mi0='make install OPT=O0'
alias mk='make -k'
alias ml='make log'
alias mn='make -n'
alias mr='make run'
alias mre='make restart'
alias ms='make status'
alias msa='make start'
alias msl='make slog'
alias mst='make stop'
alias mu='make users'
alias muc='make update_check'
alias mw='make --dry-run --debug=a'
alias syl='make syslog'

'make force_update' seems like a good candidate to rebuild the Kiwi, but it errors out after compiling a couple of files.

This Kiwi is a 2 hours drive from me and I can't gain physical access to it for a week. Is there are make command I can run to perform a clean update and build?



  • jksjks
    edited December 2018
    The git clone seems to be trashed. Assuming there isn't more general filesystem corruption, try setting the clone aside and building from a new one:
    Login as root to the /root home directory.
    Do a "df" and make sure you have at least 300 MB free on your filesystem.

    "cdp; mst; cd" (stop if currently running; go back to root dir)
    "mv Beagle_SDR_GPS Beagle_SDR_GPS.bad"
    "gclone Beagle_SDR_GPS" (this is an alias for "git clone")
    "cdp" (cd project)
    "mi" (make install)
    "ku" (kiwi up)
    wait a bit
    "ms" (check status)
  • thanks. that was easy and worked perfectly
  • Okay, glad to hear it wasn't general filesystem corruption which requires manual intervention to recover from (re-flash from sd card).
  • jksjks
    edited December 2018
    Something I should mention for future readers of this topic. Reinstalling the Kiwi clone in this manner doesn't reset your configuration customizations because those are stored in the /root/kiwi.config directory (separately from /root/Beagle_SDR_GPS). Also true for third-party extensions (only the antenna switch at present) since those are stored in /root/extensions.

    The Kiwi auto-update feature does something slightly less drastic. If a new version is detected the code does a "make git" in which the Makefile invokes the usual git clean/checkout/pull process on the current clone.
  • Hello, I'm trying to follow this discussion in order to solve a problem, my Kiwisdr does not upgrade and does not show up anymore on the site.
    Unfortunately when I run the "mi" command here is what it comes out:

    ../build/obj_O3/s4285kalman.d:1: *** missing separator (did you mean TAB instead of 8 spaces?). Stop.

    Any suggestion? I'm not so expert with Linux to be able to solve it and the unit is far from my QTH.
    Thanks a lot, Jack.
  • jksjks
    edited April 2019
    That file would have to be corrupt for that message to occur. Clean and rebuild by typing:
    mc    (cleans all the build files including the ".d" files mentioned in comment above)
    mi    (make sure there are no errors from the "mi")
    Or email the login info to and I can have a look.
Sign In or Register to comment.