Kiwi will not update from 1.237 to 1.238 [stale git lock file]

edited October 2018 in Problems Now Fixed
Following the issue with updating to 1.237 using the information from Martin everything has been working fine.
However I noticed that the auto update to 1.238 had not happened so attempted to do it manually from the admin update tab
The Kiwi says there is an update but when I try to run it I get the Admin page will restart etc. message but nothing happens.
I then tried the SSH/cdp/up sequence which seemed to run but at the end I am still at 1.237.
Any ideas of what to try next would be appreciated.




  • While upgrading manually on your Kiwi I got this message from git:

    "git checkout .
    fatal: Unable to create '/root/Beagle_SDR_GPS/.git/index.lock': File exists.

    If no other git process is currently running, this probably means a
    git process crashed in this repository earlier. Make sure no other git
    process is running and remove the file manually to continue."

    So you had a stale lock file somehow. What surprised me was that git didn't clear the lock after a reboot, although I guess there might be a valid reason for this in some cases. Anyway, I removed the lock and the rebuild worked.
  • Hi John

    First time I have been able to look since my previous post due to some pc issues I had/have.
    Many thanks for resolving the update problem.

    Best Regards

  • While upgrading manually on your Kiwi I got this message from git:

    Are you able to access other people's kiwis?
  • I got this "lock file" error on one of three Kiwis that I operate. Interestingly, in the state of "unable to upgrade" the WSPR decoders would not auto-start.

    Deletion of the lock file and issuing another "up" brought that Kiwi back in line with the rest.
  • I noticed the same thing with the WSPR decoders failing to auto-start.
    In fact I seem to recall that WSPR decoders not running first alerted me to a problem.

    Daniel, yes John can access other people's Kiwis.
  • I noticed that the two KiwiSDRs that did successfully upgrade from '137 to '138 ( and its #2 counterpart) were not able to automatically upgrade from '138 to 139 - and one of these (#1) seemed to unable to restart the SDR after the attempt.

    A manual "cdp->up" from the terminal on each unit seemed to fix the problem.

    What these have in common, in addition to the same local network, power supply and antenna is that they are both running multiple kiwirecorder sessions, but this may be coincidental.

  • Hi
    I have this problem
    Installed version: v1.237, built Oct 19 2018 12:41:57
    Available version: v1.240
    and if I force upgrade , I am still back on 237
    I have also try CDP and UP with ssh
    and still same

  • Ari, do you mean the Kiwi at ? Because that seems to be running v1.240 successfully.
Sign In or Register to comment.