Your Kiwi must be running the v1.690 (or later) release to use the proxy service and be in the public Kiwi list (rx.kiwisdr.com, map.kiwisdr.com)

Please visit kiwisdr.com (documentation) and kiwisdr.nz (online store)

WSPR decodes stop working when last RX is used for radio listening [known limitation]

edited October 2018 in Problems Now Fixed
Hello,

I have a KiwiSDR configured for 7 x WSPR auto-run RXs and the remaining one available for a general coverage radio session.

By accident I have just noticed that the WSPR decode function seems to stop when the last available RX is used for radio listening.

I was looking at the spots on the WSPR website map and database views and everything was working okay. I then opened up a browser and listened to Radio New Zealand, some 40m traffic and some 80m traffic.

Then when I looked at the WSPR website database view I noticed that there were no logged spots during my 40 minute radio listening session.

Here is that log:

2018-10-04 08:34 BV0NCU 10.140190
2018-10-04 08:32 VK4ZF 3.594202
2018-10-04 08:32 VK5FQ 10.140163
2018-10-04 08:32 K5HYT 7.040073
2018-10-04 08:32 VK8AR 14.097116
2018-10-04 08:28 K3SC 7.040079
2018-10-04 08:28 VK2ZMT 28.126077
2018-10-04 07:44 N8VIM 7.040148
2018-10-04 07:44 VK8AR 14.097115
2018-10-04 07:42 ZL3TKI 14.097102
2018-10-04 07:36 ZL3TKI 7.040101
2018-10-04 07:36 ZL4EI 10.140141
2018-10-04 07:34 F5JNV 10.140280
2018-10-04 07:30 ZL3TKI 14.097103

Then I looked at the admin log on the KiwiSDR and it showed much the same problem.

Thu Oct 4 07:37:40 19:08:25.196 0.234567 WSPR DECODE: UTC dB dT Freq dF Call Grid km dBm
Thu Oct 4 07:37:40 19:08:25.197 0.234567 WSPR DECODE: 0734 -23 0.0 10.140280 0 F5JNV IN98 17160 33 (2.0 W)
Thu Oct 4 07:39:29 19:10:14.498 0.234567 WSPR DECODE: 0736 -17 0.1 10.140141 0 ZL4EI RF74 2161 30 (1.0 W)
Thu Oct 4 07:39:38 19:10:23.698 0.234567 WSPR DECODE: 0736 -6 0.1 7.040101 0 ZL3TKI RE66 2193 20 (100 mW)
Thu Oct 4 07:45:34 19:16:19.475 0.234567 WSPR DECODE: 0742 10 0.1 14.097102 0 ZL3TKI RE66 2193 17 (50 mW)
Thu Oct 4 07:47:38 19:18:24.004 0.234567 WSPR DECODE: 0744 -24 2.1 7.040148 -4 N8VIM FN42 16164 37 (5.0 W)
Thu Oct 4 07:47:40 19:18:25.556 0.234567 WSPR DECODE: 0744 3 0.0 14.097115 -2 VK8AR PG66 2102 23 (200 mW)
Thu Oct 4 07:49:04 19:19:49.187 01234567 1 PWD kiwi ALLOWED: no config pwd set, allow any

** RX SESSION LOGIN **

Thu Oct 4 07:49:14 19:19:59.958 01234567 1 7425.00 kHz am z7 "VK2YCJ" 124.168.17.228 Aberglasslyn, Australia (ARRIVED)
Thu Oct 4 08:27:27 19:58:12.373 01234567 [16] PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 124.168.17.228
Thu Oct 4 08:27:27 19:58:12.373 01234567 [16] PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip 124.168.17.228 ip_client 124.168.17.228/0x7ca811e4 ip_server[IPv4] 10.1.1.173/0x0a0101ad nm /24 0xffffff00
Thu Oct 4 08:27:27 19:58:12.376 01234567 [16] PWD admin config pwd set TRUE, auto-login TRUE
Thu Oct 4 08:27:38 19:58:23.677 01234567 [16] PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 124.168.17.228
Thu Oct 4 08:27:38 19:58:23.677 01234567 [16] PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip 124.168.17.228 ip_client 124.168.17.228/0x7ca811e4 ip_server[IPv4] 10.1.1.173/0x0a0101ad nm /24 0xffffff00
Thu Oct 4 08:27:38 19:58:23.681 01234567 [16] PWD admin config pwd set TRUE, auto-login TRUE
Thu Oct 4 08:29:50 20:00:35.539 01234567 1 3661.00 kHz lsb z7 "VK2YCJ" 124.168.17.228 Aberglasslyn, Australia (LEAVING after 0:40:46)

** RX SESSION LOGOUT

Thu Oct 4 08:31:37 20:02:22.536 0.234567 WSPR DECODE: 0828 10 0.2 28.126077 0 VK2ZMT QF57 79 37 (5.0 W)
Thu Oct 4 08:31:37 20:02:22.646 0.234567 WSPR DECODE: 0828 -15 1.1 7.040079 0 K3SC FM19 15647 37 (5.0 W)
Thu Oct 4 08:31:50 20:02:35.946 0.234567 [16] ADMIN connection closed
Thu Oct 4 08:31:51 20:02:36.916 0.234567 [14] PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 124.168.17.228
Thu Oct 4 08:31:51 20:02:36.916 0.234567 [14] PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip 124.168.17.228 ip_client 124.168.17.228/0x7ca811e4 ip_server[IPv4] 10.1.1.173/0x0a0101ad nm /24 0xffffff00
Thu Oct 4 08:31:51 20:02:36.919 0.234567 [14] PWD admin config pwd set TRUE, auto-login TRUE
Thu Oct 4 08:31:59 20:02:44.442 0.234567 [14] PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 124.168.17.228
Thu Oct 4 08:31:59 20:02:44.442 0.234567 [14] PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip 124.168.17.228 ip_client 124.168.17.228/0x7ca811e4 ip_server[IPv4] 10.1.1.173/0x0a0101ad nm /24 0xffffff00
Thu Oct 4 08:31:59 20:02:44.445 0.234567 [14] PWD admin config pwd set TRUE, auto-login TRUE
Thu Oct 4 08:35:37 20:06:22.138 0.234567 WSPR DECODE: UTC dB dT Freq dF Call Grid km dBm
Thu Oct 4 08:35:37 20:06:22.138 0.234567 WSPR DECODE: 0832 -18 0.1 7.040073 0 K5HYT EL06 13284 37 (5.0 W)
Thu Oct 4 08:35:37 20:06:22.146 0.234567 WSPR DECODE: 0832 -5 0.1 10.140163 2 VK5FQ PF95 1178 23 (200 mW)
Thu Oct 4 08:35:38 20:06:23.632 0.234567 WSPR DECODE: 0832 3 0.1 14.097116 -1 VK8AR PG66 2102 23 (200 mW)
Thu Oct 4 08:35:38 20:06:23.677 0.234567 WSPR DECODE: 0832 -19 -1.2 3.594202 0 VK4ZF QG62 623 23 (200 mW)
Thu Oct 4 08:37:08 20:07:53.405 0.234567 WSPR DECODE: 0834 -15 0.2 14.097110 0 JH1ARY PM95 7727 27 (501 mW)
Thu Oct 4 08:37:23 20:08:08.937 0.234567 WSPR DECODE: 0834 -5 0.9 10.140190 0 BV0NCU PL04 7167 40 (10 W)
Thu Oct 4 08:39:11 20:09:56.485 0.234567 WSPR DECODE: 0836 -32 0.1 14.097115 -2 VK8AR PG66 2102 23 (200 mW)
Thu Oct 4 08:41:35 20:12:20.199 0.234567 WSPR DECODE: 0838 -27 0.7 7.040135 0 WA4KFZ FM18 15634 37 (5.0 W)


Have I done something wrong or could this be a bug ?


Thanks, Jamie VK2YCJ

Comments

  • This is almost certainly the Beagle running out of cpu cycles so that none of the 7 WSPR auto-run decoding tasks is able to complete a successful decode within the two minute window when you are logged in on the 8th channel. Try running with only 5 or 6 WSPR auto-runs and then login and see how it does.
  • Hello John, yep that's what we figured. Up until now we have run 6 x WSPR sessions and left 2 x general coverage radio sessions available. In that configuration we had seen the waterfall display run very slowly and guessed that 6 x WSPR sessions running simultaneously would knock things around. However with the 6 / 2 combo the WSPR sessions appeared to work as normal. I'll go and test that over the next few days.

    I have 3 x KiwiSDR radios and the plan is to have one dedicated to doing 8 x WSPR sessions and the other two used for general coverage receivers - all at the same location and using the same antenna. With the symptoms shown above it looks like the 8 x WSPR session config may have a chance of working.

    I'll try what you say and report back.

    Thanks, Jamie VK2YCJ
  • implement Rob's kiwiwspr scheme. It can handle 800+spots/hour
  • Hello John and WA2ZKD,

    Yep, that is the problem - exactly as you explained. We tried running 5 and 6 WSPR auto-runs and it worked reliably. Running 6 WSPR auto-runs plus 1 x general coverage radio session broke it.

    So Rob's kiwiwspr scheme with the Rpi-3 sound like a good solution. Where can I find more info on that WA2ZKD ? Is there a webpage on it ?

    Thanks, Jamie VK2YCJ
  • I see you found it!
Sign In or Register to comment.