The forum is open to new posts.

More GPS Problems - Damaged hardware?

A few days ago, the cat chewed through the GPS antenna cable. I repaired it as best as I could, but noticed poor GPS results, usually getting just a few satellites and maybe only 1 good one, max. This happened around the time of the Galileo outage, so it was difficult to determine what the true cause(s) were.

Figuring the cable repair was causing signal loss, I swapped it out for another patch antenna. Same results. I then put the patch antenna on a paint can lid and propped that out the window to get it outside. Same results. I'm not getting any fixes now, of course.

Occasionally it will acquire lots of satellites, but usually only one good one, see below. Is it possible some of the GPS hardware has been damaged, perhaps a front end RF amp? I have a 40 dB external GPS antenna on the way to try, but now I am concerned that there's a hardware failure, and it won't help.

Ideas? Suggestions?

«1

Comments

  • Is there still voltage for the GPS antenna? Maybe the cat caused a short.
  • Yes, I just checked, 3.28 volts, seems close enough to 3.3 volts.
  • Is the "patch antenna" truly just a patch or does it have a built-in +28 dB pre-amplifier like (most of) the active modules do? Without the preamp the Kiwi won't hear a thing. Definitely try the +40 dB antenna before drawing any conclusions about the Kiwi hardware.
    http://kiwisdr.com/files/gps/gps_ant_issues_r1_5-07.pdf
  • Hi Chris,

    Can you check what current the GPS patch antenna is drawing - even if you just power it from a bench supply ?

    I'd expect something in the region of 20 - 50mA.

    But I can confirm once I've measured mine.

    Regards,

    Martin - G8JNJ
  • Yes, it's the standard GPS antenna with a built in preamp. I have actually tried three of them, one is the antenna that came with the Kiwi. I also have a 10 MHz GPS reference that I use with my netSDR, and the antennas work with it. So I think they're OK, of course the one with the splice cable may be a bit dodgy :smile:
  • Now (1506z) I have 2 sats, 2 good, and am getting 29 fixes/min with 1785 over the past hour. I haven't touched or changed anything, honest :smile: Still far fewer sats than most seem to get.
  • Hi Chris,

    I measured the current draw of my KiWi supplied GPS puck.

    A bit lower than I expected.

    8.45mA @ 3.3V and 8.9mA @ 5V

    Regards,

    Martin - G8JNJ
  • Is your puck on any ground plane and which side of the building is it on?
  • I have it sitting on a large sheet of aluminum foil as a ground plane, in front of a south facing window.
  • Have you measured the voltage while the antenna was attached?
  • The new 40 dB antenna arrived. I connected it via a short (10 ft) run of high quality RG6 coax with an F to SMA connector on the KiwiSDR end and a F to N connector on the antenna end. Insert hand waving to ignore the small impedance mismatch if either end is expecting a 50 ohm cable.

    Same results as before, very poor. It's actually yet to acquire a single satellite in about an hour. Yes the antenna is still inside but I would expect performance equal to or greater than what most get with the supplied GPS antenna?

    The voltage on the GPS connector on the KiwiSDR is 3.28 volts unloaded. Connecting the 40 dB antenna, it drops to 3.06 volts. The 40 dB antenna is spec'd to run from 3.3 to 9 volts, with less than 30 mA current draw at 5 volts. Obviously the 3.06 volts is below the spec'd 3.3 volts, whether this is normal or indicative of a hardware problem I'll leave to the experts :smile:

    Reading the SE4150L datasheet I see a 50 mA short circuit limit on the bias, I didn't see a spec for the operating range.

    Not too encouraging.
  • in front of a south facing window
    But it's indoors? If possible it would be interesting to temporarily get the antenna outside with a reasonably full view of the sky and see what happens (i.e. use a long Ethernet and power cable).

    I know you've seen more sats in the past, but the Kiwi GPS doesn't have the software processing gain of professional GPS solutions that really allows it to make effective use of the small aperture of a window.
  • As a further test I used a DC inserter to supply 5V to the 40 dB antenna, same results. Or lack of results I should say.

    No easy way to get the antenna outside without taking everything outside (and did I mention it is going to be close to 100F today?), but I previously picked up satellites, and others have the supplied low gain antenna setting on a desk or bookshelf with the entire window filled with satellites. So I am guessing the GPS interfacing hardware might not be as short circuit protected as hoped.
  • You can short the GPS port all day long and it will be fine. The RF path is capacitively coupled and the bias path has short-circuit protection inside the front-end chip. The SE4150L, used in hundreds of millions of devices worldwide, would never have been a success otherwise. Kiwi schematic: http://kiwisdr.com/docs/KiwiSDR/kiwi.schematic.pdf
  • OK, that's certainly good to know. I am going to try relocating the antenna here inside the shack, and see if that makes any difference. Beats going outside into the heat :smile:

    Thanks for all your help, jks. I haven't given up quite yet.
  • Definitely don't give up just yet. The +40 dB antenna should make a world of difference given your inside location. If you wade through people's past postings about GPS reception problems you'll see it's a common issue. Not much different from difficult RFI/EMI issues. But persistence often pays off.
  • An update... moving the 40 dB antenna to the other side of the shack, so maybe 10 ft, helped. 9 sats / 4 good right now, and I have seen higher numbers. It's on top of a tripod of sorts standing on the floor. Rube Goldberg for sure, but it works.

    What's interesting is that antenna placement seems to be critical. If I move it a foot, or even a few inches (and of course give the system a few minutes to settle down) I notice a dramatic difference in the number of sats. I can think of a few possible causes, either the structure of the house (wood frame, I am on the second floor, it is a Cape Cod style so not too much roof (asphalt shingle) above me), or perhaps the distance from RFI sources. With quite a few computers, routers, and such who knows how much junk is landing on 1575 MHz. It's also possible that the original antenna can be made to work, assuming I can precisely position it, and prevent cats from moving it.

    This does motivate me to get the antenna outside. Unfortunately the weather does not :smile: I will have to figure out how I can mount it outside and run cables. I think I want to consider putting it on the wall opposite from where the KiwiSDR is, as that is where the computers are also. Even if it means a longer GPS antenna cable. I can always move the KiwiSDR also at some point and use a longer ethernet cable, although that also means re-routing the HF antenna cable. All these things sound like a good fall project. I may be able to live with it as it is now for a few months.

    Thanks everyone (jks in particular) for bearing with my rants.
  • I missed your 7:36 post about getting 3.06V. That doesn't seem right. 10' of RG-6 (center conductor 18 AWG nominally) shouldn't have that much voltage drop. But it all depends on the current draw. Can you measure that somehow? Although interesting in your later post that it seems to work at this voltage.
  • I can probably rig together something to let me measure the current draw. BTW this is the antenna I bought, it's NOS, looks like the seller has some more left if anyone else needs a high gain antenna https://www.ebay.com/itm/Lucent-GPS-40dB-High-Gain-Timing-Antenna-Lightning-Surge-Protection-Mount-Kit/323860563230
  • I measure 3.13V directly at the kiwis SMA connector, connected to a commercial timing antenna which draws 28 mA from a 3.4 V lab supply.
  • jksjks
    edited July 2019
    The active antenna spec'd to ship with the Kiwi is supposed to work from 3-5V (note: 3V not 3.3) http://kiwisdr.com/KiwiSDR/files/gps/Active.Antenna.pdf
    With it connected I measure 3.28V at the Kiwi SMA (it uses 3m of rg-174) . I can't easily measure the current right now but the above spec says current draw is 13.5 mA typ. 15.5 max.
  • jksjks
    edited July 2019
    Also to consider: The DC bias choke is a TDK MLK1005S39NJ 0402/1005 (Imperial/Metric) SMD which has a max DC resistance of 1 Ohm and 0.65 typical. This is a critical part because the self-resonance must be above the GPS L1 band.
  • edited July 2019
    I ran some quick tests this morning while checking the email and drinking tea:

    When I checked the Admin page, I had 8 sats, 7 good. So it did well overnight. This is with the 40 dB antenna in another part of the shack, fed with a 15 ft (I think) RG6 coax, with an SMA adapter on the KiwiSDR end and an N adapter on the antenna end.

    I then used a DC inserter from an cheap old active TV antenna to feed 5V to the antenna. It's probably not very well made and I figured it would be lossy. Sure enough, it was. I would get maybe 1 good sat. I do have a better inserter for satellite TV that I would like to try using for a better test.

    Next I went back to powering with the KiwiSDR, and added an extra 100 ft of RG6 as a torture test. This antenna is advertised has being good for installations with long cable runs to overcome loss. Sure enough, I have 8 satellites right now, 6 good. And this is with the antenna still inside, same location as the other tests. I don't plan on using 100 ft of coax, but it is nice to know I can. And performance should be even better outside. Actually... that might make it possible for me to relatively quickly and easily locate the antenna outside, even if I cannot get it high in the air I can get it out in a relatively open area with good views of the sky.

    Update 12 sats, 7 good now.
  • edited July 2019
    with the 40dB gain antenna and short coax, you may be putting too much signal in... so the long coax is a good thing
  • Quite possible there was too much signal. I ran another test, this actually solves another problem.

    I have a Trimble Thunderbolt 10 MHz GPS reference I use with my netSDR. It has a 5 volt antenna bias. I have a cheap 28 dB patch antenna here in the shack for it, which mostly works (as jks mentioned these receivers typically are more forgiving with weak signals). I cobbled together a Tee adapter so I have both the Thunderbolt and KiwiSDR connected to the 40 dB antenna, with a DC block on the path to the KiwiSDR, so it is powered by the Thunderbolt at 5 volts.

    It's a bit of a mess since the Tee is BNC so the path is Antenna / N-F adapter /115 ft RG6 / F-BNC adapter / Tee / BNC - F adapter / 1 ft RG6 / Thunderbolt. Then also Tee / BNC-F adapter / F-DC-Block / F-SMA adapter / KiwiSDR.

    But it works! 6 sats / 5 good right now, it varies up and down of course. Still with the 40 dB antenna inside. For fun I checked the KiwiSDR GPS map. Not only is it on my house, it is on the right end of my house :smile:



    Next step may be moving the antenna outside.
  • edited July 2019
    I relocated the 40 dB antenna outside, it is currently mounted on the kids's wooden swingset. I have a lot of trees in my yard so any low angle sats are probably blocked:



    Very good results, this is with 100 ft of RG6 and powered as I described above from the Trimble Thunderbolt GPS reference and a tee through DC block to the KiwiSDR:



    The moral of the story seems to be that you can get very weird/poor/inconsistent results with the antenna inside. Plus the problem with cats :smile:
  • Hi Chris,

    I use passive satellite TV splitters with an inbuilt DC block (or steering diodes) on all but one port.

    This sort of thing with suitable adaptors.



    I use a two way to feed two more two ways, so that I can feed the office and workshop (Trimble) with a mid point split, This gives about about 7-8dB loss in total on each leg, which is fine with an antenna with 40dB of amplification.

    Regards,

    Martin - G8JNJ
    ChrisSmolinski
  • Thanks Martin! Off to eBay to look for one!
  • SMA ==> F adaptors
    DC blocks
    Not necessarily the cheapest but available
  • Some further notes for anyone who may pick up this thread at a later date and wish to copy this information.

    If you wish to split the GPS signal from the antenna to feed multiple KiWI's.

    Do not attempt to simply use a tee adaptor or similar to split the feed, as this will introduce unpredictable impedance excursions on the coax cables, which is turn will result in very deep 'notches' in the signal amplitude at various frequencies.

    You can only use passive splitters if the antenna has sufficient gain to overcome the splitting losses and cable losses ahead of the KiWi.

    2 way split = approx 3.5dB additional loss
    3 way split = approx 5dB additional loss
    4 way split = approx 7dB additional loss

    Try to find passive splitters that only have a DC pass on one port. This will save having to fit additional external DC blocks in order to prevent one KiWi feeding DC back into another via the GPS connectors.

    Make sure they are rated up to 2GHz, like this model / style

    https://www.amazon.com/Ideal-85-332-2-Way-Digital-Splitter/dp/B003QM9UHS/ref=sr_1_2?keywords=ideal+2+way+splitter&qid=1563704237&s=gateway&sr=8-2

    https://www.amazon.com/Ideal-85-334-4-Way-Digital-Splitter/dp/B003V18KQ6/ref=sr_1_3?keywords=ideal+4+way+splitter&qid=1563704346&s=gateway&sr=8-3

    You can obtain 'F' type male to SMA male patch cables on Ebay at under $4 each. It's better to buy ones that are longer than you need, so that there is room to wrap them around ferrite rings if required. Make sure you choose the correct sex of connectors, as reverse SMA is quite common.

    https://www.ebay.com/itm/RG316-Cable-F-Type-male-plug-to-SMA-male-plug-RF-Pigtail-Coax-Jumper/273406498020?hash=item3fa84c14e4:m:mFvLi09dwBokRt1mcM3MNiQ

    Hope this helps anyone else following in these footsteps.

    Regards,

    Martin - G8JNJ
    WA2ZKD
Sign In or Register to comment.