The forum is open to new posts.

Audio queue depth slowly drops to zero, then resets, causing audio underrun - 8 receiver mode

I've been using some of the receiver capacity to run WSPR decoders while allowing public access for general listening, but this intermittent audio problem is very noticeable when it happens. It does not seem to happen in 4-receiver mode where the queue depth stays reliably at 4 or 5. It happens more often when WSPR has a lot of decoding to do.

I've only seen it happening in 8-receiver mode with several WSPR decoders on active bands configured at startup. Over a variable period of a few minutes, the audio queue depth drops from 5 to zero and then resets to 5. There are slight 'skips' in the audio as the queue depth drops and then a short gap when it resets from 0 to 5. The underrun indicator flashes and the counter increments.

I'm using Chrome on Windows 10. KiwiSDR 1.261, unit 3663. I had a look through the bug list and didn't see anything that seemed to fit this description. Any suggestions you have that could alleviate the problem are greatly appreciated.

Comments

  • Are you running external WSPR decode (with a recorder.py etc.) or the WSPR extension? running external decoding would be a better move in this setup I believe.
    WV5L
  • Just using the extension. There seems to be adequate cpu and fpga resources, but obviously something is being over used.
  • The extension is simple but there are benefits to using the external decodes, the detection rate is higher by default.
    WV5L
  • AI6VN's wsprdaemon.sh code really works well. The #1 wspr reporter in North America as of late, KD2OM, runs 2 8-channel kiwis and cover all 14 bands
    WV5L
  • jksjks
    edited January 2019
    The WSPR extension decoding process (not the sampling during the two minute sampling interval) is hugely compute intensive. And if you are in an area where lots of WSPR signals are being received on multiple bands simultaneously, causing heavy decoder load, and you have other regular connections on an 8-channel system then it is possible the realtime scheduling requirements cannot be met leading to audio underruns.

    This behavior is a bug, but also difficult to fix. So it probably won't be anytime soon given everything else that is being worked on.
    WV5L
  • Thanks for that assessment. I'll look at the workarounds mentioned above. Or I might get another KiwiSDR to handle WSPR work just to keep it simple.
Sign In or Register to comment.