The forum is read-only currently.

v1.250: 20 kHz bandwidth mode, 10/100 Ethernet speed selection, k/M frequency/passband suffixes

Three channels at 20 kHz is subject to being reduced to only two depending on experiences with stability. I would have set it at two but I couldn't get the FPGA code to compile using only two channels for reasons I still don't understand. From the CHANGE_LOG file:
v1.250  December 31, 2018
    Add 20 kHz wide audio bandwidth mode.
        A third entry to the list of FPGA configurations. See admin "mode" tab for details.
    
    Add Ethernet 10/100 speed select to admin network tab.
        The speed changes after a few seconds of delay (no Kiwi restart required).
        This allows you to be looking at a waterfall in another window and see if
        the Ethernet spurs (if present at your installation) improve or not.
        Be sure the device (router, switch) your Kiwi connects to supports 10 Mbps Ethernet.
    
    Accept 'k' & 'M' scaling suffixes in frequency and passband parameters.
        Examples: Type "/15k" in frequency box to get a 15 kHz wide passband. Or "/2.7k", "-5k,10k" etc.
        Use a URL of "...?f=7.4M/16.5k" to set a frequency of 7.4 MHz and passband of 16.5 kHz.
        Note uppercase 'M' since 'm' is already keyboard shortcut for mute.
        You can remember this because the 'M' in MHz is always capitalized whereas 'k' in kHz is not.
        Note also 'k' used to be paired with 'j' as the frequency up/down jog shortcut.
        Now use the 'j' and 'i' keys are used (also 'J' and 'I' to jog faster).
        Using the 'i' key is actually more natural because it fits the placement of your
        index and middle fingers better than 'j' and 'k'.
        Finally, 'i' was previously used to select IQ mode. Now use 'q' instead.
        Type 'h' or '?' to see the complete keyboard shortcut help panel.

image

Attachments:
http://forum.kiwisdr.com/uploads/Uploader/12/26235e829f2447198499bdb071ae86.png
elitedataPowernumptynjc

Comments

  • edited December 2018
    thank you JKS for creating this as an option B)
  • edited December 2018
    ive taken the step to identify my receiver on sdr.hu as one with 20Khz BW since there is not yet a method to filter for 20Khz BW receivers versus 12Khz BW receivers on sdr.hu.
  • I'm listening to http://ka7u.no-ip.org:8075/?f=1010.00/18kiqz7 and sounds great to my deaf ears. But the URL is not presented with the green arrow in the control box.


    Ron
    KA7U
  • In the past the passband info was never added to the link URL. Just the freq, mode and zoom level. This was because you had some bandwidth selection implicit in the mode values (e.g. AM vs AMN).

    There's been a long-standing question of whether the mode buttons should be reorganized, with additional default bandwidths. And the new 20 kHz mode makes this question even more pertinent. For example, should the two AM/AMN buttons become a single AM button that toggles between showing AM, AMW, AMN (maybe a fourth?) with values that depend on the 12/20 kHz mode? (e.g. 12, 10, 5 in 12 kHz mode; 20, 15, 10, 5 in 20 kHz mode). These values should probably also be sensitive to the current frequency band just like the ---/+++ buttons are (i.e. AM BCB 9 kHz vs 10 kHz channel spacing).

    Same for LSB/USB with the addition of some bandwidth choices (2.4k, 2.7k ESSB etc.) and CW/CWN.

    And of course in the mythical future when there are user preferences, all of these values and behaviors should be configurable by each Kiwi user.

    This discussion must also consider the question of capability vs UI simplicity. I see evidence on the Internet of people using the Kiwi without ever zooming in the waterfall or taking advantage of the many other features that are really quite simple to use. This is such a shame.
  • jksjks
    edited December 2018
    Elite: good point. What I can do is add an little icon and "20 kHz" to the last line of the listing along side the software version, GPS and antenna switch indicators. You can't rely on the user count saying "N / 3 users" to mean the Kiwi is in 3 channel, 20 kHz mode because the "3 users" number might simply be a 4 channel, 12 kHz Kiwi with one channel password protected (which is not reflected in the count).
    elitedataPowernumpty
  • If you have multiple kiwi you need to put them all on 10 Mbps and then turn one at a time back to 100
  • John: thanks so much for the new mode/BW. I intend to use it for some multipath studies.
  • WA2ZKD - i use your Kiwi's often, the increased BW will prove useful when the HF pirates with HQ AM/SSB audio come on - its finally nice to hear them with good audio through my sound system when i cant receive them locally.
  • The 10mbs speed certainly is effective. Now if I could only find and eliminate the remaining spurs. Hi Hi
    Ron
    KA7U
  • jksjks
    edited December 2018
    I didn't mention this, but the new Ethernet speed setting is "sticky". So when the Beagle is powered-up or rebooted the Ethernet will come up in 100 Mbps mode by default. But when the Kiwi server starts and sees 10 Mbps mode has been set in the configuration it will change the interface speed back down to 10.

    There is also a new Linux command 'e' that is an alias for 'ethtool eth0' to show the interface state including the speed setting. Also 'e10' and 'e100' for manually setting the speeds.
    elitedataKA7U
  • KA7U, i get the same thing after observing your video (the video is certainly helpful as i did not know where the spurs where located) but only half as strong as seen in your video.
  • elitedata, I picked the strongest spur location. I notice the spur strength varies from one unit to the next. Not sure why, but I suspect the antenna is picking up the spurs and it depends on the sensitivity of the antenna where the spurs are the strongest. There is some common mode transmission of them as well and common mode chokes help with that. They are a nuisance and wishing them gone doesn't do it. Hi hi
  • @jks
    I checked to see what happens if the /etc/rc.local is setting the speed. I set the admin network speed to 100mbs and rebooted the KiwiSDR. After it came up the admin network tab showed the 100mbs but the kiwiSDR was set at 10mbs. So apparently the /etc/rc.local file is read after the Kiwi configuration file is read. No big deal, just something to know. I think I'll comment out the /etc/rc.local setup and just work with the "sticky" admin network speed control.
    Ron
    KA7U
  • Ron, interesting. I didn't even know about /etc/rc.local. The comment block in the file says it waits until all the stuff at run level is finished before executing. So I guess that means it wait for the Kiwi server to be fully up and running and has changed the eth0 speed if necessary.
  • v1.251 is out now with the status line change to sdr.hu for 20 kHz mode mentioned above.
  • edited January 2019
    I just realized that Linux/Chrome on my system does not display the 20 KHz etc. icons on sdr.hu, just a little square box. Firefox is OK though.
  • jksjks
    edited January 2019
    Hmm. The display of Unicode characters can be a bit of a crapshoot# depending on your browser/OS. I saw the Unicode "musical note" (U+1F3B5) character using Chrome 71 on OS X. Does your Linux/Chrome show the majority of the characters from here? http://www.endmemo.com/unicode/symbols_and_pictographs.php

    # outside NA: https://en.oxforddictionaries.com/definition/crapshoot
  • edited January 2019
    my Chrome shows now of the little sdr.hu icons... seldom look there until the 20 KHz edit: none on the endmemo page either.... font install to OS fixed it. But why firefox didn't need it?
  • Getting back to the sticky nature of the change. I tried, from the admin page to set this to 10mbs, had been running well at 100mbs. This seemed to make my ethernet switch unhappy. The beagle comes up at 100mbs, and I can ssh into it, but after a bit, it seems to switch to 10mbs and I lose connectivity. Unfortunately, typing e100 at the command line seems to not work and is not sticky. Apologies for being a newbie with ethtools, but the equivalent comment as the e100 seems to kill my connectivity as well. I suppose one way of attacking this would be to edit the file that contains the sticky ethtool command. May I ask where it is?
    I'm thrilled with my kiwisdr and very much appreciate all the work that goes into support.
  • jksjks
    edited January 2019
    Yes, you should really check to see if your router/switch supports 10 Mbps mode before trying it. Especially if the Kiwi is located remotely.

    To rescue out of the situation: The Kiwi server waits 30 seconds after boot before doing anything. This should give you time to ssh in and type "cdp; mst" which will stop it. Then "cdk" to get to the configuration directory and edit the file kiwi.json. Change the "ethernet_speed" parameter from 1 to 0 to go back to 100 Mbps. Then "cdp; ku" to start up again.
  • Thanks so much. Fortunately, it was local. Also, swapped the switch, which also improved noise levels. As someone who comes from the SWL/Monitoring side of things, let me share my appreciation.
  • I have corrected my above post to say "1 to 0 to go back to 100 Mbps". Zero is the value indicating 100 Mbps interface speed (first item in the admin page menu).
Sign In or Register to comment.