The forum is read-only currently.

LSB passband settings from admin CONFIG-menu are not used

Hi,

the LSB passband default values from the admin config menu are ignored.

Instead some unusable settings are put in place and I have to change them every time I start the KIWI.

I deleted the browser data completely, used another PC and different browser,

did server restart, beagle reboot and made a rebuild with no success.

Do I have to edit some settings files on the beagle? Which ones and how?


73

Andreas

Comments

  • I tried it and can't confirm your problem (v 1.470).

    On admin config page, section "Default passbands" I selected LSB and changed "passband low" temporarily to -4000. In Frontend with LSB selected, the change is reflected as expected as soon as I klick "restore passband".

    So this looks like an individual problem, something seems to be broken ...

  • OOOPS ...

    After trying to restore my old settings after the above test, I seem to have a similar problem.

    I'll try to investigate in order to be able to understand more precise what's happening.

    Sorry for the confusion.

  • You can get yourself in a mess if you manually set the bandwidth of the LSB, USB or CW so that it includes the side band you don't want.

    Likewise if you use Ctrl + to increase the passband, you can go beyond the point of it being single side band and it becomes double sideband.

    Normally if you drag the passband for each mode to the bandwidth you require or click on a tag that has the passband defined, then it should sort itself out, and return to that setting the next time you use the browser.

    However a Shift click on the appropriate mode button will reset you to the default passband for that mode.

    The various options for defining and changing the passband is described in the Passband adjustments section of the KiWi user guide.

    http://kiwisdr.com/quickstart/#id-user-pbt

    Confession - I had to look up the keystrokes to reset the passband, as I couldn't remember them.

    Hope that helps.

    Regards,

    Martin

  • edited October 21

    Okay, summary (and hopefully my last posting in this matter)...

    • My test changes were effective immediately after "restore passband".
    • But my changes back to the original settings weren't. Frontend did still show the test setting, even after "restore passband".
    • I found that a CTRL+F5 in the frontend tab (page reload with cache cleaning) was necessary. Afterwards, all was okay again.


  • edited October 21

    I am aware of the possible problems of low sideband attenuation when setting the passband beyond zero.

    I have to be more precise what I want: After opening the KIWI-page with my browser I would like to have the same settings as with my last session or the default settings from the admin config menu would be ok too.

    I am pretty sure, until yesterday the behaviour was like this. Now I get a very unusual passband setting I never set as an default.

    I can set the default passband settings from the config menu with SHIFT+LSB, but that is not exactly what I want.

    http://dl2kcl.selfhost.eu:8073/

  • I learned how to get access to the files on the Beagle.

    The file with the passband-settings is kiwi.json in /root/kiwi.config .

    To edit the last_ and last_hi in:

          },

          "lsb": {

             "lo": -2900,

             "hi": 30,

             "c": -1480,

             "lock": false,

             "last_lo": -950,

             "last_hi": 30

          },


    was not sufficient to solve the problem. The default values -950 and 30 were used even after a KIWI-server restart.

    I then left the last_lo and last_hi values empty and restarted the KIWI.

    Now the default values lo and hi are used. So all working fine now again ;-)


    Andreas

Sign In or Register to comment.