The forum is read-only currently.

v1.462: MANUAL INTERVENTION REQUIRED to receive future updates

13»

Comments

  • jksjks
    edited September 22

    @JP1ODJ

    これはjp1odj-air.proxy.kiwisdr.com:8073のキウイ用ですか?

    ビルドが完了すると、自動的に再起動します。 電源を入れ直さないでください。 ビルドの途中で電源を入れ直すと、インストールされているソフトウェア全体が破損する可能性があります。

    ビルドの実行中に、ユーザーページへのログインが表示されます。

    申し訳ありませんが、ソフトウェアの更新が進行中です。 数分後にもう一度確認してください。


    Is this for your Kiwi at jp1odj-air.proxy.kiwisdr.com:8073 ?

    After the build completes it will restart automatically. Do not cycle the power. If you cycle the power in the middle of a build you may corrupt the entire installed software.

    While the build is running a login to the user page will show:

    Sorry, software update in progress. Please check back in a few minutes.


  • that's right. It is KiwiSDR of jp1odj-air.proxy.kiwisdr.com:8073.

    I understand. Does not turn the power off/on.

    It doesn't change. It is v1.462.

    I will try again.

  • @JP1ODJ

    再試行する場合:必ずユーザー接続を試してください。 「ソフトウェアの更新が進行中です」というメッセージが表示された場合は、ソフトウェアをビルドしていることがわかります。

    When you try again: Be sure to try making a user connection. If you get the "software update in progress" message then you know it is building the software.

  • @jks

    Entering ext_send ('SET force_check = 1 force_build = 1') does not update.

    Is there any other way?

  • @JP1ODJ

    はい、別の方法があります。 別のコンピューターからsshまたはPuTTYプログラムを使用してKiwiBeagleに接続する必要があります。 「root」アカウントとしてログインします。 パスワードは、Kiwiシリアル番号または管理者パスワードが設定されている場合はKiwi管理者パスワードになります。 次に、次のコマンドを入力します。

    cdp

    up


    Yes, there is another way. You must connect to the Kiwi Beagle using the ssh or PuTTY program from another computer. Login as the "root" account. The password will be the Kiwi serial number or Kiwi admin password if an admin password had been set. Then type these commands:

    cdp

    up

  • @jks

    I was able to update!

    http://jp1odj-air.proxy.kiwisdr.com:8073/

    Thank you very much!!

  • @JP1ODJ

    優秀な。 しかし、私もその問題について非常に申し訳ありません。

    Excellent. But I am also very sorry for the problem.

    John, ZL/KF6VO

  • Tried multiple time over the last week. On first 2 tries it seemed not to have worked as I got the message that the software was up to date but was still reading 1.462.

    On the next try I also got the up to date 1.462 message and it did not seem to be doing anything within the first 4 or 5 min. So, I walked away and left it. When I returned about 15 min. later it was in the process of updating so I left it over night. Did the server restart in the morning and everything was upgraded.

    Thanks for the update

    Rich, WD3C

  • edited October 17

    Made it to 1.470 with no problems.


    Thanks John! Off to do another.


    Two of Two....

  • You can get more progress messages when running update_fix by issuing the command

    sh -x ./update_fix

    rather than just

    ./update_fix

    This invokes the shell with the -x option, which shows each command in the script as it is being executed.

    I also had to log in via ssh, rather than use the "console" tab in the admin page, because I run two KiwiSDRs remotely.

    Phil

  • Rebuild went fine. Thanks info!

  • how do I do it remotely?

  • @W6FNO If you've failed to set a Kiwi admin password (so you could connect to the admin page remotely), or don't have an ssh port open on the remote sites router, then you're out of luck.

    How did you intend to do remote maintenance/configuration at this remote site?

  • I do nave a remote access password set. When I login and go to the console page and click connect, I get "CONSOLE: only available to local admin connections"

    I am not familiar with ssh and its use

    I have two at remote mountain top locations about 80 miles from my home

  • I guess I'm confused. If this Kiwi is 80 miles away how are you connecting to the admin page without using a password? This shouldn't be possible. Otherwise anyone could do this if they simply knew the ip address or domain name of the Kiwi.

    However, assuming you are connected then this is how you get around that particular error: On the admin page, security tab, change the setting "Restrict console connections to the local network?" from "Yes" to "No". Now you should be able to use the "Connect" button on the console tab.

  • Thanks, I do have a remote access password set. The update worked after changing the security setting, as you suggested.

  • Problems updating over 1.462. Kiwisdr was unplugged for about 2 weeks, saw the notice, ran update_fix, but pressed beagle restart instead of server restart. Still at 1.462. I ran update_fix twice more, and am getting error messages that say unable to fetch sqlite3-0. Messages below. Will continue to try running update_fix.

    CONSOLE: open connection

    root@kiwisdr:~/Beagle_SDR_GPS# update_fix

    From https://github.com/jks-prv/Beagle_SDR_GPS

     = [up to date]   master   -> origin/master

     = [up to date]   dev    -> origin/dev

     = [up to date]   drm    -> origin/drm

    Already up-to-date.


    Err http://security.debian.org/ jessie/updates/main libsqlite3-0 armhf 3.8.7.1-1+deb8u4

     404 Not Found [IP: 151.101.194.132 80]

    0% [Working]            Err http://security.debian.org/ jessie/updates/main libsqlite3-dev armhf 3.8.7.1-1+deb8u4

     404 Not Found [IP: 151.101.194.132 80]

    0% [Working]            E: Failed to fetch http://security.debian.org/pool/updates/main/s/sqlite3/libsqlite3-0_3.8.7.1-1+deb8u4_armhf.deb  404  Not Found [IP: 1

    51.101.194.132 80]

     

    E: Failed to fetch http://security.debian.org/pool/updates/main/s/sqlite3/libsqlite3-dev_3.8.7.1-1+deb8u4_armhf.deb  404  Not Found [IP: 151.101.194.132 80]

     

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

    extensions/HFDL/Makefile:45: recipe for target '/usr/lib/arm-linux-gnueabihf/libsqlite3.so' failed

    make: [/usr/lib/arm-linux-gnueabihf/libsqlite3.so] Error 100 (ignored)



    clang-6.0 -Dv1_470 -Ofast @../build/gen/Makefile.inc -c -o ../build/obj_O3/ac_data.o extensions/HFDL/dumphfdl/src/ac_data.c

    extensions/HFDL/dumphfdl/src/ac_data.c:14:10: fatal error: 'sqlite3.h' file not found

    #include <sqlite3.h>

         ^~~~~~~~~~~

    1 error generated.

    Makefile:862: recipe for target '../build/obj_O3/ac_data.o' failed

    make[1]: *** [../build/obj_O3/ac_data.o] Error 1

    make[1]: Leaving directory '/root/Beagle_SDR_GPS'

    Makefile:85: recipe for target 'all' failed

    make: *** [all] Error 2


    Installed version: v1.462, built Sep 11 2021 06:59:50

    Error determining the latest version -- check log


    Log file says:

    Sat Nov 13 01:20:35 00:01:52.881 ....   L UPDATE: force update check by admin

    Sat Nov 13 01:20:35 00:01:52.885 ....   L UPDATE: checking for updates

    Sat Nov 13 01:20:35 00:01:53.253 ....    UPDATE: fetch origin status=0x00008000

    Sat Nov 13 01:20:36 00:01:54.154 ....   L UPDATE: Makefile fetch error, no Internet access? status=0x00008000 WIFEXITED=1 WEXITSTATUS=128

    Sat Nov 13 01:20:36 00:01:54.157 ....    task update_task:P3:T003(-) exited by returning



    tried update_fix for the 3rd time - still unable to fetch the sqlite3:


    After this operation, 1066 kB of additional disk space will be used.

                Err http://security.debian.org/ jessie/updates/main libsqlite3-0 armhf 3.8.7.1-1+deb8u4

     404 Not Found [IP: 151.101.2.132 80]

    0% [Working]            Err http://security.debian.org/ jessie/updates/main libsqlite3-dev armhf 3.8.7.1-1+deb8u4

     404 Not Found [IP: 151.101.2.132 80]

    0% [Working]            E: Failed to fetch http://security.debian.org/pool/updates/main/s/sqlite3/libsqlite3-0_3.8.7.1-1+deb8u4_armhf.deb  404  Not Found [IP: 1

    51.101.2.132 80]

     

    E: Failed to fetch http://security.debian.org/pool/updates/main/s/sqlite3/libsqlite3-dev_3.8.7.1-1+deb8u4_armhf.deb  404  Not Found [IP: 151.101.2.132 80]

     

    E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

    extensions/HFDL/Makefile:45: recipe for target '/usr/lib/arm-linux-gnueabihf/libsqlite3.so' failed

    make: [/usr/lib/arm-linux-gnueabihf/libsqlite3.so] Error 100 (ignored)

    (cd e_cpu; make OTHER_DIR="")

    make[1]: Entering directory '/root/Beagle_SDR_GPS/e_cpu'

    clang++-6.0 -I. -I./asm -D_GNU_SOURCE -g asm/asm_util.cpp asm/asm.cpp -o ../../build/tools/asm

    ../../build/tools/asm -o ../../build/gen 

  • I'm able to ping that ip address, but not sure why the number 80 is there - odd results with it in place.

    ping 151.101.194.132 80

    PING 80 (0.0.0.80) 56(124) bytes of data.

    ^C

    --- 80 ping statistics ---

    8 packets transmitted, 0 received, 100% packet loss, time 7149ms


    matt@matt-All-Series:~$ ping 151.101.194.132

    PING 151.101.194.132 (151.101.194.132) 56(84) bytes of data.

    64 bytes from 151.101.194.132: icmp_seq=1 ttl=56 time=17.3 ms

    64 bytes from 151.101.194.132: icmp_seq=2 ttl=56 time=19.1 ms

    64 bytes from 151.101.194.132: icmp_seq=3 ttl=56 time=19.6 ms

    64 bytes from 151.101.194.132: icmp_seq=4 ttl=56 time=25.9 ms

    64 bytes from 151.101.194.132: icmp_seq=5 ttl=56 time=18.2 ms

    64 bytes from 151.101.194.132: icmp_seq=6 ttl=56 time=28.8 ms

    64 bytes from 151.101.194.132: icmp_seq=7 ttl=56 time=18.4 ms

    64 bytes from 151.101.194.132: icmp_seq=8 ttl=56 time=20.8 ms

    ^C

    --- 151.101.194.132 ping statistics ---

    8 packets transmitted, 8 received, 0% packet loss, time 7010ms

    rtt min/avg/max/mdev = 17.360/21.052/28.870/3.857 ms

  • I'm still getting error messages above that it cannot update sqlite3-0 or reach the update server.

    Should I try those suggestions about apt-get update or --fix-missing?

  • jksjks
    edited November 13

    @WB2EEE Try this please:

    cdp

    m INSTALL_CERTIFICATES

    update_fix


  • That did it! Thank you! 1.470

    Matthew

  • Okay, good. THANK YOU for reporting this because it turns out to be the bug causing problems with the v1.471 HFDL update which I am now fixing.

  • You're welcome. Glad to help.

Sign In or Register to comment.