The forum is open to new posts.

v1.462: update problems



  • Can you not watch the syslog?

    The upgrade will start after boot of the SD Card version so unless you are disabling upgrade in the image the upgrade process should start after boot, then you are ALSO passing the update_fix command, which I assume is expected to be used with the update mechanism not working.

    Just something I didn't see the logic for. If for you the SD Card image is not automatically updating I guess that is one way to read the mail.

  • Tried once more early sunday morning:

    • start kiwi with newly written flash card, vers 1.390
    • after kiwi switched off, take out flash card and restart kiwi - as soon as kiwi web-admin (showing vers 1.390) switch off automatic update
    • in vers. 1.390 go to network tab and set fixed IP-adress, netmask, gateway, DNS
    • go to console, connect and input update_fix
    • update starts
    • takes about 90min then update finished - I checked the total process and cannot find any error message
    • then go to connect and restart server

    Result so far: version 1.464 installed !


    • I set my original admin password to be able to reach the web-admin page remotely from different network
    • It works - I can connect the web-admin kiwi with that complicated password under 1.46


    • I checked, if the ports are open (due to port forwarding) so shows ok as well as my IP-adress number.. sounds ok
    • however, when I input in my browser URL window I reach nothing: ' this side cannot be reached'


    • I have used the noip DUC, they offer to download for windows and used it to confirm the service works.


    • go to network tab to set dyn.dns service with
    • as soon as I input the account data any refresh of the kiwi web-admin would immediately break the connectivity and I get " this IP/adress cannot be reached" error
    • If (instead of refreshing the web-admin page), I check with the DUC of the web-admin page whether noip-dynDNS service works, it says 'checking....' and runs forever. All LEDs are constantly on at this moment and won't change... refreshing the web-admin page results in 'cannot be reached error

    So Result:

    I have updated from flashcard containing vers, 1.390 to vers. 1.464, so that it would be usable from internal network, or from outside with the strong password.

    But dyn.DNS service from breaks the system and results ' site unreachable' error for everyone...

    I will now stop evaluation and wait for further advice...

    It is clear, that there were several other issues in the beginning as well:

    • possibly defective SD-cards (although I have tried 4 different ones of different brands)
    • the github update process was totally different today as yesterday (I compared the scripts and different files where downloaded today compared to yesterday, although content of the flash-card with Vers 1.390 is exactly the same than yesterday = same card)
    • sometimes update process is interrupted or completely stopped
    • may be more...

  • edited September 2021

    OK so couple of comments:

    I don't know if you are connecting from the same network when you say

    That might be down to the network not allowing loop back (LAN>InternetURL>WAN>LAN). Anything you try on the public URL after that is going to be stopped by the router/network not the Kiwi.

    From the PC that you are using for the admin browser - can you either "nslookup" or "ping"?

    From here it obviously resolves to your public IP address, if it does the same at your end it is very unlikely you will be able to loopback for reasons stated above, not a Kiwi issue.



    "I have used the noip DUC, they offer to download for windows and used it to confirm the service works."

    So is the correct WAN address for the same as for the Kiwi? if not using the windows client to update/test (and not completely removing it) might have reset your Dynamic URL to the wrong WAN IP. I get is that correct? I'm not sure if they have a update frequency limit like once a day?

  • "...I have used the noip DUC, they offer to download for windows and used it to confirm the service works."

    It doesn't matter - from the same network or from outside...

    "...I get is that correct?"

    Yes it is correct

    My ISP doesn't change IP adresses often... I think I have this IP at least for a year now...


    can never be reached - I checked with GSM via Phone Network

    But kiwi shows that this port is open, if you connect to my IP-adress under that port - obviously, because I route all requests of that outside port to the inside port of the kiwi...

    So - there is some problem!


  • Hi Ulli,

    It looks your Kiwi at is online at the moment.....

    73 Ben

  • Connecting my IP-adres directly with

    indeed reaches the kiwi correctly !

    So this shows, there is a problem with!

    I should better use a different service then...they may have changed something, which breaks the proper dyn-DNS service - well I used the free-of-charge service, but this stopped working although their own DUC shows in the windows PC - all ok, still valid 18days, before I need to renew it...

    (remember the FOC service requires manual renewal every 30days)

    Strange that there was no problem with Kiwi-OS version 1.461 before... coincidence ?!?

  • Now - I have written a new Sandisk Ultra SD-card with Vers 1.464 to flash directly

    It works with the first kiwi, with the second kiwi - the third kiwi breaks with 'this site cannot be reached' error - all other kiwis are always off... only one kiwi at a time

    I stop it... it is crazy - no reliable operation, that is clear!

  • edited September 2021


    Non-authoritative answer:


    Address: << Well that ain't right

    Also, restoring three from one backup means it is possible to get into issues with manual IP and port settings (especially in relation to port forward), even if you correct them after boot there can be a lag on the router/switches. I've never really got on with manual IP in the network settings, I always assign it at the router, then specific BeagelBones are marked on the Ethernet top "123" etc. I also tend to change the hostname to contain the port number "kiwi8073" etc, then I know if "kiwi8073" comes up on x.x.x.123 it will already have 8073 port forwarded.

    There is also the DUC settings to consider and many updates sent might trigger some bar.

    For the sake of the 1.462 thread I'd question if this should be split this off, as restore from image and upgrade to latest seems fine, the rest is unrelated networking issues?

  • not correct - please try again. The Address is correct

    I had reset the interfaces at the router site - so for a very short moment (max 10min) the adress was wrong as you state - but not any more...

    Fact is, that since the update from vers1.461 was triggered all kiwis are down here - I was not even at home... nothing changed!

    When I came back in the shack all updates failed and Kiwi's were dead

  • As one Kiwi has been successfully upgraded to the current software and works, that suggest there is not a problem with the password.

    There could be some setting carried forward from the image that is causing issues. I'd take one of the non working ones, restore it to an early image and just let it upgrade itself, then that is a genuine test of the supplied software.

    I can't say what happened but as currently 60%+of the public Kiwi's are on v1.464 it makes me think this is local. My restores from 1.2 - then self update, have been completely uneventful.


  • Hi all,

    I am not a professional with these LAN/WAN stuff so my apologies if I ask/sound stupid. I just wanted to make sure that you are NOT running´s DUC software in a pc inside your LAN where you Kiwi is. If you do that it will break your routes because it tells that the public/dyndns is actually your PC not your Kiwi. Also you do NOT define any dyndns services in your router. All you need to do with is DUC service in your Kiwi config. That´s how it works for me, at least. And make sure that "DUC Domain" is active (=green) before you leave the page. :).

    Yours sincerely,

    Pekka aka PSO Kotka

  • And from inside your LAN you naturally can not access your Kiwi´s puclic address. It works only with If you want to test it, do it via your phone´s internet :). Well, that´s how things work here. I hope you get things sorted.


  • Great news! All your six(!) SDRs are visible here. With an IP-number or domain and a port number. You got it fixed.


Sign In or Register to comment.