The forum is open to new posts.

No admin auto-login on v 1.482

On the 3 Kiwis I upgraded from 1.473 to 1.482 I now must supply the admin password even though my browser is on the same LAN as the Kiwis. I have tried toggling the Security->"User auto-login from local net even if password set?" button on those 3 Kiwis with no effect on that behavior.

This would not be so bothersome if the Mac's Keychain or the Lastpass manager I also use would recognize the need to fill in the Kiwi's login dialog box. But I have refrained from upgrading the other 10 Kiwis I manage so that I won't have to spend half my day typing in Kiwi passwords ;=)

Comments

  • Anyone else seeing this? Works fine here with v1.482

    To debug your situation I need to see some messages from the admin page, "log" tab. The Debian syslog won't do as some required messages are not logged there.

    Get a window connected to the log tab. Then try connecting as admin from another window (same local network) so you get the unexpected password prompt. Then look in the log tab for the debug messages associated with the second login. Cut and paste to the support email. If you sanitize any of the password fields indicate if they contain the expected or unexpected values.

    Something like this, although the details will be different:

    Wed Dec 29 23:55:51 05:05:56.554 .... [00] PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 192.168.1.3

    Wed Dec 29 23:55:51 05:05:56.555 .... [00] L PWD isLocal_if_ip: TRUE IPv4/4_6 remote_ip 192.168.1.3 ip_client 192.168.1.3/0xc0a80103 ip_server[IPv4] 192.168.1.103/0xc0a80167 nm /24 0xffffff00

    Wed Dec 29 23:55:51 05:05:56.556 .... [00] PWD admin admin conn #0 force_notLocal=0 isLocal=1 is_local=1 auth=0 auth_kiwi=0 auth_prot=0 auth_admin=0 check_ip_against_restricted=0 restricted_ip_match=0 from 192.168.1.3

    Wed Dec 29 23:55:51 05:05:56.557 .... [00] TLIMIT exempt local connection from 192.168.1.3

    Wed Dec 29 23:55:51 05:05:56.557 .... [00] PWD TLIMIT exempt password check: ipl=<(redacted)> tlimit_exempt_pwd=<(redacted)>

    Wed Dec 29 23:55:51 05:05:56.557 .... [00] L PWD admin config pwd set TRUE, auto-login TRUE

    Wed Dec 29 23:55:51 05:05:56.558 .... [00] L PWD admin ALLOWED: config pwd set, but is_local and auto-login set

    Wed Dec 29 23:55:51 05:05:56.558 .... [00] PWD admin admin RESULT: allow=1 pwd_s=<(redacted)> pwd_m=<(null)> cant_determine=0 is_local=1 isLocal(enum)=1 192.168.1.3

    Wed Dec 29 23:55:51 05:05:56.558 .... [00] L PWD admin admin ALLOWED: from 192.168.1.3

    Wed Dec 29 23:55:51 05:05:56.560 .... [00] PWD admin admin AUTH=1 badp=0 auth_kiwi=0 auth_prot=0 auth_admin=1


  • edited December 2021
    Wed Dec 29 23:23:54 6d:06:01:58.227 .... [00]   PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 192.168.158.85
    Wed Dec 29 23:23:54 6d:06:01:58.227 .... [00] L PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip 192.168.158.85 ip_client 192.168.158.85/0xc0a89e55 ip_server[IPv4] 169.254.155.121/0xa9fe9b79 nm /16 0xffff0000
    Wed Dec 29 23:23:54 6d:06:01:58.231 .... [00] L PWD admin config pwd set TRUE, auto-login TRUE
    Wed Dec 29 23:24:15 6d:06:02:20.034 .... [00]   PWD isLocal_if_ip: flg=0x18 fam=2 socktype=1 proto=6 addrlen=16 192.168.158.85
    Wed Dec 29 23:24:15 6d:06:02:20.034 .... [00] L PWD isLocal_if_ip: FALSE IPv4/4_6 remote_ip 192.168.158.85 ip_client 192.168.158.85/0xc0a89e55 ip_server[IPv4] 169.254.155.121/0xa9fe9b79 nm /16 0xffff0000
    Wed Dec 29 23:24:15 6d:06:02:20.039 .... [00] L PWD admin config pwd set TRUE, auto-login TRUE
    


    I can see that the Kiwi thinks its IP address in the auto-assigned 169.254.0.0. space, so that would explain why the Kiwi wants a password. But I don't know why the Kiwi thinks 169... is its LAN

    I cannot access the console through the 'Console' tab. When I click on 'Connect' I get:

    CONSOLE: only available to local admin connections

  • Probably a faulty DHCP server on your network. I assume on the admin network tab the Kiwi is set to use DHCP rather than a static ip address in the 192.168.x.x range. If the Linux network stack doesn't hear from a DHCP server after some time it will self-assign an ip from the 169.254.x.x range. This is standard networking behavior, not something specific to the Kiwi.

    What URL are you using to access the Kiwi if it's on 169.254.x.x anyway?

    You can access the console in this case by changing the setting on the admin security tab to "Restrict console connections to the local network?" to "No".

  • Yes that Kiwi is set for DHCP and my router gave the Kiwi's ethernet port the address 192.168.158.73. I can ssh to that Kiwi at that address and I see no evidence of the self-assigned address.

    Perhaps the Kiwi rebooted when my ethernet switch was down and self-assigned and address, but later the DHCP client was run and got that 192.168.158.73. If that happened, could the Kiwid have cached that 169.254 address as its LAN and not been informed of the new 192.168.158.73 address? If so, I expect that restarting kiwid will remove the password prompt, but you are welcome to explore that Kiwi before I do that.


    ==================


    root@192.168.158.73's password:

    Last login: Thu Dec 30 03:29:34 2021 from c-73-223-61-94.hsd1.ca.comcast.net

    root@kiwisdr:~# ifconfig

    eth0   Link encap:Ethernet HWaddr 98:5d:ad:7e:fe:ca

         inet addr:192.168.158.73 Bcast:192.168.158.255 Mask:255.255.255.0

         inet6 addr: fe80::9a5d:adff:fe7e:feca/64 Scope:Link

         UP BROADCAST RUNNING MULTICAST DYNAMIC MTU:1500 Metric:1

         RX packets:19015546 errors:0 dropped:0 overruns:0 frame:0

         TX packets:21301193 errors:0 dropped:0 overruns:0 carrier:0

         collisions:0 txqueuelen:1000

         RX bytes:1410939112 (1.3 GiB) TX bytes:121849658 (116.2 MiB)

         Interrupt:173


    lo    Link encap:Local Loopback

         inet addr:127.0.0.1 Mask:255.0.0.0

         inet6 addr: ::1/128 Scope:Host

         UP LOOPBACK RUNNING MTU:65536 Metric:1

         RX packets:1786 errors:0 dropped:0 overruns:0 frame:0

         TX packets:1786 errors:0 dropped:0 overruns:0 carrier:0

         collisions:0 txqueuelen:1

         RX bytes:141042 (137.7 KiB) TX bytes:141042 (137.7 KiB)


    usb0   Link encap:Ethernet HWaddr 98:5d:ad:7e:fe:cc

         inet addr:192.168.7.2 Bcast:192.168.7.3 Mask:255.255.255.252

         UP BROADCAST MULTICAST MTU:1500 Metric:1

         RX packets:0 errors:0 dropped:0 overruns:0 frame:0

         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

         collisions:0 txqueuelen:1000

         RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


    usb1   Link encap:Ethernet HWaddr 1c:ba:8c:a2:ed:73

         inet addr:192.168.6.2 Bcast:192.168.6.3 Mask:255.255.255.252

         UP BROADCAST MULTICAST MTU:1500 Metric:1

         RX packets:0 errors:0 dropped:0 overruns:0 frame:0

         TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

         collisions:0 txqueuelen:1000

         RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)


    root@kiwisdr:~#

Sign In or Register to comment.