Windows 10 related audio popping & clicking [should be fixed in Chrome version 90]

edited April 9 in KiwiSDR Discussion
This discussion was created from comments split from: v1.440: C-QUAM & channel queueing/camping.
«13

Comments

  • Hello, After upgrading to v1.440, I am experiencing mild audio popping and short glitches. Happens only on SAM,SAL,SAU,SAS and C-QUAM modes. Using Win 10, Edge and Brave browsers. Tried on other online Kiwis and same thing. No audio underrun indication. Anyone else experiencing this? Thanks Bob

  • @WB4klj Yes a little with Brave, Waterfox seems smoother.

  • Just an update. I also experience this on online Kiwis with v1.438. Since I upgraded from v1.436 straight to v1.440, I didn't notice it til then. Thanks Bob

  • The mild audio popping is observed here, too. It is since 1.438. Interestingly, when recording the popped audio, it is not in the recordings. I wanted to upload a recorded sound sample this morning, but it was clear while the original sound was not.


    Eckhard

  • I thought I might have heard this during development. But now I'm having no luck replicating the problem. Can anyone give me more details? How often does it occur? At least every 10 secs? Only a few times per minute? Only with strong signals or also listening to background noise?

    Thanks.

  • edited March 14

    That is ten seconds of some random station

    http://m0aqy.uk:8073/?f=1035.00samz6

  • I did some tests ... it seems to me depending on the signal strength. On very strong stations it is significant, a popping from two times every second to one time every one or two seconds. Not regular, its changing all the times. On weak stations its hard to hear, I'm not sure if it is audible, maybe there is something.


    Eckhard

  • Go there http://erserver.ddns.net:8073/ and use 1215kHz .

    Eckhard

  • jksjks
    edited March 14

    Well, I don't get it. On my Mac I tried Firefox, Safari and Chrome on http://erserver.ddns.net:8073/?f=1215 They all sound fine in any SAx/QAM mode. I ran the audio FFT extension in waterfall mode to look for glitches. Nothing seen.

    I have a very old Windows 10 laptop. Guess I'll have to fire it up. It's so slow it takes an hour to boot/update after not running for a while. I hate Windows/M$.

  • That's really strange! This minute I'm running it, and there is this popping in audio! And again I tried to record it using the Kiwi recorder - and there is nothing in the recorded audio. Strange ...


    Eckhard

  • I'm sure the issue is in the javascript in the browser that handles the audio (resampling, filtering etc). Recording, whether with kiwirecorder or the internal record button, bypasses most of that.

    I assume you're using Windows?

  • Here is somethong for you: https://www.dropbox.com/sh/lrzkpkwm8boh7k9/AAC8G3Q7pUrzgQQgmc4A1hf3a?dl=0

    Especially towards the end of the clip the popping can be heard very clearly.


    Eckhard

  • And yes, I'm using Win 10 Prof.

    Eckhard

  • Going offline now, have to start early tomorrow morning.


    Eckhard

  • Eckhart try using audacity, that was how I captured it.

    For the record (excuse the pun) other SDR software has had a fair bit of audio issues with Win10, I looked into it assuming it would be an easy fix but went down the rabbit hole of "Change WIFI Drivers" get Realtek network card drivers direct, use the latency tool, download **** from github reset the CPU power plan, disable interfaces etc. If you search for stutter Win 10 there are quite a few "Eight / Ten ways to fix stutter in Win10". I think it is often to do with 10ms chunks expected by Win10 drivers now or something. That might not relate to this issue but if you thought you hated Win 10 try Win 10 sound issues...

    For me Firefox (Waterfox actually) works fine, Brave (Chrome based) stutters like someone real close if sending morse key clicks, initially I did look for that person on the spectrum.

  • Yeah, that's awful. I think my W10 laptop has finished updating now. Will give it a try..

  • Also, please try it on a fresh browser start where you don't have 50 tabs open. FF has been known to get into states after long run times where weird things happen with audio (primarily audio silence though).

  • jksjks
    edited March 14

    I had mixed results with Windows 10 on the laptop. But I discovered some clues.

    I never saw the consistent, periodic pops reported above using Firefox and Chrome. However there were occasional pops. Especially as I was using other parts of the user interface. The short duration of the pops, the fact that no underrun errors are seen and some interesting behavior in Chrome pretty much tells me what the problem is.

    Instead of pops (very short periods of audio silence), W10 Chrome repeats samples giving a stuttering effect. This tells me that the Javascript interpreter/scheduler is not keeping up running my audio code to fill whatever buffering it has for the 44.1/48 kbps audio output to W10.

    This issue can be caused by many things. It's possible I have introduced a bug such that some Javascript code is in a loop using up CPU cycles. The browsers have some tools for recording performance but I have not used them much. If Javascript is running in the other 50 tabs you have open (but hidden) that can be a big factor. Similarly if W10 is busy doing other stuff and not giving the browser CPU cycles often enough to avoid audio buffering problems.

    So please try and simplify your test setups. Use a fresh browser start. Maybe even a fresh reboot. Compare SAS/QAM versus IQ modes since they move the same amount of data and cause the same kind of processing on the Javascript side (AM and SAM are similar). Try running with the waterfall turned off or at 1 Hz. You can search for Kiwis running older versions of the code by doing "rx.kiwisdr.com/?s=v1.436" etc. See if you can find what version exactly things changed. Then I can compare code changes which will help tremendously.

    Thank you.

  • jksjks
    edited March 15

    Well, so far I'm at a complete loss. The "performance monitors" built into the browsers don't show anything out of the ordinary. Anyone can use them. While connected to a Kiwi channel just bring up the Javascript console (from the browser menu) and select the "performance" bar at the top (details vary, I'll describe Firefox in particular). Click record start/stop for 5 seconds or so. Then afterwards select "JS flame chart". Zoom in and you should see plenty of purple idle space surrounding the areas where the Javascript code and browser are running performing Kiwi-specific tasks.

    Now if on Windows you see long periods (several to tens of milliseconds) of non-idle time, or the "frame rate" graph drops to a low number then there is a problem that may prevent the audio output code from running causing the popping. The fact that I don't see this with any browser on my Mac means it's unlikely I've introduced a simple "infinite loop" or long-running code Javascript bug.

    It might be that I have to TeamViewer into one of your Window 10 machines and do this myself in order to debug this. So far I've been unable to run the perf mon effectively on my W10 laptop because it has such limited memory.

  • Hi,

    I'm not sure what else to do ... it is an i7 10th generation machine with 64G RAM, some open tabs do not bring the audio down. However, I did what you said, but it does not change anything.

    I checked on Chrome, Edge and Firefox, it' all the same.

    I do not have too much time for my hobbies this week, a lot of work to do. If you like we could have a tem viewer session the coming weekend.


    Eckhard

  • jksjks
    edited March 15

    I think this might be related to Javascript memory garbage collection. I have a little bit of evidence on my W10 laptop of this, but it is not conclusive. But I don't know why that would be. There shouldn't be anything different for the SAx modes related to JS memory allocation. And I don't know why it would be worse on W10 than OS X.

    I am going through the 3700 lines of code differences between v1.336 and v1.441 😥

  • I got it wrong my main laptop is Win 8.1 but I do have a Win10 I can fire up and let it update before testing. Just tried Brave on Win 10 home, no issue. Vivaldi chugged for a second or two then was fine.

    My Win 8.1 install is long in the tooth so assume that is too unknown for any diagnostic time (at least three virtual audio cables, disabled). I'm just trying to get an i5 laptop reinstalled to win7 and then up to 10 so I'll test on that.

    If I can actually see it on a clean Windows install I’ll report back.

  • Hi John, Thanks for working on this. I may have been premature to blame this on a firmware update. I wanted to play with the new C-QUAM decoder and plugged in some headphones so I could experience the stereo separation. That's when I noticed the popping sound. I believe now I'm hearing it on all modes, but most prominent in SAx/C-QUAM modes.

    I can hear the popping on WA2ZKD kiwi v1.423 (1180kHz) and PY3CEJ kiwi v1.397 (1080kHz).

    2 laptops both Windows 10 Home ver. 20H2 OS build 10.0.19042.867 Edge browser ver. 89.0.774.54 .One laptop has Brave browser (ver. 1.21.76Chromium:89.0.4389.86)

    Then I pulled out a laptop that I hadn't used in 2 months. NO popping on all 3 browsers. I quickly quarantined it from the internet before it could update anything. It has Windows 10 home ver. 2004 OS build 10.0.19041.746. Edge browser ver 87.0.664.75, Firefox 84.0.2 and Chrome 87.0.4280.141. These browsers did have some distortion on very strong audio peaks in SAL and SAU. I believe I first noticed this when you added that Normal/null SAL/ null SAU drop down menu to the audio tab that only shows when you are in SAM mode.

    Maybe its something to do with recent update to OS or browser and there is nothing you can do. Maybe others can verify. If it's just me having problem then too much trouble for one person.

    Thanks,

    Bob

  • Need some help: Could someone who experiences regular, periodic popping, like what Stu's graph depicts above, do an experiment for me?

    When your Kiwi is in that condition, using SAS or QAM mode, click the IQ mode button and nothing else. Does the popping stop? You may have to wait tens of seconds for things to stabilize.

    Thanks.

  • I just tried this. The popping does not stop in IQ, even after waiting a while. It stops when in regular AM mode.

    I've found the pops happen on Windows 10 and my Android Pixel2 (Chrome).

    One thing to note: My popping is not as regular as Stu's graph indicated. It's about as frequent, but more random.

  • jksjks
    edited March 16

    Okay, that's good intel. Thank you.

    Would you mind comparing AM vs SAM (which move similar amounts of data to the browser) vs SAS/QAM? Make sure on the audio tab the "comp" button is lit when in AM/SAM mode.

  • OK I just played with it for quite a while. SAM/SAS/SAL/SAU/QAM/CW and IQ modes all pop. In fact it's most obvious in CW (with the carrier in the passband). I don't hear it in the AM or SSB modes.

    It happens on strong and weak AM signals. It does not happen on a freq where there is no signal. I played around with a lot of different WF/audio/AGC/etc. settings trying to get it to change but was unable to. This was all on Win10.

    COMP was lit.

  • Okay, thanks. I think this plus Bob's recent observations makes this another case of Windows-10-update-breaks-browser-audio. We've had W10 updates break other browser behavior before. There's nothing to do really but wait and hope it goes away, eventually. Someone, right now, is probably screaming at M$ support.

    Note that the SAx/QAM modes will pop when you tune in 9/10 kHz steps on an AM BCB full of carriers. This is because the PLL is re-locking every time you step and there is a glitch. I'm thinking about adding some PLL parameter controls to the audio tab. Warren Pratt's wisp source code even suggests this should be done. Maybe we need some soft-muting on retuning as well.

  • I think it might be a Chrome/Chromium issue, perhaps OS dependent. I installed Firefox on Win2012 Server R2 and it does not have the pops. Also on my Android phone Chrome has the pops, Firefox doesn't.

    So it seems for now the work around is to use Firefox.

  • I'm getting clean play with Midori. Thou when I move the volume slider I get the similar pop but just once per movement. Pop with others might be volume path related.

Sign In or Register to comment.