Connection lost every day

Every day I have to change my ip adress after connection is lost........why is this hapening?

Comments

  • where is "connection lost" reported?

    What IP address do you change?

    My guess is this is a question caused by the ISP changing your public IP address every few hours and something not reflecting that, but it is hard to tell from the short question.

    If that sounds about right, see if your router supports DDNS.

    Stu

  • Hi Stu

    I have to change the private ip adress inside my router.

    what must I do about the DDNS?

    Hank

  • Still don't quite get the issue (again - where is the "connection lost" - from outside your network or inside?) but here are are few points to consider (all details on http://kiwisdr.com/quickstart/ )

    1. Fix the Kiwi IP address inside your network - on the router if you can.
    2. If you want to get to it from outside, set up port forward through your router to the fixed Kiwi address.
    3. If you want to get to it from outside by name use the built in DDNS or router DDNS (if it exists), that way from outside you can use a URL like sdr1.dynamic-dns-service.url

    Probably what is happening is when you change the IP address something is updated so that from outside it links the right name to current public IP Address.

    If the router has DDNS when it sees the WAN address change it updates the DDNS entry.

    Tell us what type of router and I'll see if it has DDNS.

    If the issue is inside the network it is possibly Firewall or power saving.

    Sorry for the long answer, short questions with few details cause too much guessing.

    Cheers

    Stu

  • jksjks
    edited January 30

    Yes, question is too short to understand exactly what is being talked about.

    But to me it sounds like it's the local (private) ip address that the router is moving around for some reason. E.g. you y initialldiscover it's 192.168.1.101 and make a connection. But then later after trying to reconnect there is no response at that address and you have to go through the rediscovery process again only to find it's now at 192.168.1.107.

    This might be caused by the DHCP server in the router configured with a really short "lease time", like minute or hours instead of days or weeks. Ideally the Kiwi's Ethernet MAC address should be bound to a fixed private ip address in the DHCP static ip configuration table. But that takes some effort to setup (that's what I do here). That way the local ip addresses never move.

    Make sure this is not the problem before you send him off on the goose chase that is DDNS, lol.

    Powernumpty
  • I connected the Kiwi to an Engenius ebc300. It is in client bridge mode. My router is a Technicolor TC 7210 z

    Every few hours the ip adress changes. I have to type the correct ip into my Technicolor to get connected from outside. My kiwi adress is pa3emx.ddns.net:8073

  • jksjks
    edited January 31

    Okay, so you're already using DDNS. And I see you've publicly registered your Kiwi. Public registration causes a ping to be sent to kiwisdr.com every 20 minutes (last seen Jan 30 23:58 UTC). I would have thought this would have been enough activity to keep your router from changing the local ip.

    One problem is that DDNS on the Kiwi only assists with the ISP changing the public ip. It can't do anything about your router changing the local ip. Increase the DHCP lease time or make a static MAC-to-local-ip mapping.

  • On the Technicolor check if "Power reduction enabled" is ticked on the WiFi setup, if it is, try turning that off.

  • I am not sure what I have changed😊....but it seems to work.....let us hope it stays that way.!....Time will tell

    Thanks for all the advices

Sign In or Register to comment.