The forum is open to new posts.

Adding Kiwi to my website

Hi guys, recently purchased my first Kiwi SDR and have been configuring at today. After a bit of confusion between webpage and public, I managed to get all the information entered in the correct boxes and categories so that the front-end is displaying my information. However, what I am struggling with is how to add a link from my personal website to my Kiwi so that people going to my amateur radio website can simply click on a link and open up the page for my Kiwi.

I suspect it's probably under "connect". There are five options, the first domain name. At the moment, I've got public IP enabled. I did initially put in kiwisdr.g0vqy.co.uk but that didn't work.

Some help would be appreciated

Thanks

Penn
«1

Comments

  • www.yoursite.com:8073 for example
  • Yeah, I did try that but it didn't work. Mind you, I have made some more changes so I will try this again, thanks
  • Unfortunately, that didn't seem to work

    https://g0vqy.co.uk/
  • edited February 2020
    you need to access it with the port number your kiwi is on, typically 8073 and not use https:// so g0vqy.co.uk:8073
  • I don't know what I'm doing wrong. I'm using WordPress and I created a custom link and added HTTP://g0vqy.co.uk:8073 but it didn't make any difference, just doesn't work. I've included a couple of screenshots to show my settings. Maybe this will help
  • can you connect to http://86.185.11.27:8073 from the outside?
  • jksjks
    edited February 2020
    I think your ISP is blocking Internet-originating (incoming) connections.

    This is slightly difficult to explain: On the admin panel the kiwisdr.com and sdr.hu entries will say "success" when the registration request that originates from your Kiwi reaches those sites with the proper data. But then kiwisdr.com and sdr.hu will both periodically poll your Kiwi to see if it is actually operating. If this polling fails then you will not be listed. Right now on kiwisdr.com I can see that your Kiwi initially registered, but subsequent polling has failed.

    If your ISP blocks connection attempts that originate from the Internet (because they don't like the idea of you running a "server" on a residential connection paying residential rates) then you won't get listed and Internet users won't ever be able to connect to your Kiwi.

    You need to use the Kiwi proxy service to get around this problem (setup info on the admin "connect" tab).
  • Does your router direct 8073 traffic to the internal address your kiwi is on?
  • jksjks
    edited February 2020
    I forgot to mention: On the admin "network" tab try the "Check port open" button. Clicking this button sends a request to kiwisdr.com asking it to make an Internet-originating connection to your Kiwi at both the domain you have configured (if any) and the public ip address. If both of these fail, and your NAT is okay, then your ISP is most likely blocking incoming connections.
  • Just had my evening meal guys, I'll read your messages and get back to you in a minute
  • WA2ZKD: no, I just clicked on your link and no page was found.
  • JKS: no, they are not open
  • you have to do some port forwarding work in your router I think
  • Okay guys, I'm in my roots are and I found the Kiwisdr and I opened it. I'm assuming that I've got to open some ports? What do I need to put into the text box?
  • Maybe 8073 - 8073?
  • 8073 to 8073 for the IP address that the kiwi is on
  • Yes, 8073 everywhere, protocol=TCP, rule name can be anything, ip is local network ip address of your Kiwi.
  • Okay guys, I have just done that, let's see what happens
  • Silly me, I didn't click on "add to list". Anyway, I just checked and now saying the ports are open
  • Penn is working now, just needs to do DDNS
  • jksjks
    edited February 2020
    Do you have access to the DNS configuration for the g0vqy.co.uk domain? If so you can now add another A-record for kiwisdr.g0vqy.co.uk to point to the public ip address of your Kiwi. Then references to kiwisdr.g0vqy.co.uk:8073 will work. This is necessary because references to g0vqy.co.uk (remapped by browser to www.g0vqy.co.uk) appear to go to a different public ip than your Kiwi (probably because your website is hosted someplace else).

    But this assumes BT isn't giving you a dynamic public ip address that will change at an arbitrary time in the future. If it is you'll have to do what Jim suggests and setup a DDNS to automatically update the A-record as needed.

    [p.s. Sorry about the spurious rant about ISP blocking earlier. I'll blame it on lack of caffeine and my recent hassles with actual ISP blocking with another customer]
  • I have just purchased a dynamic DNS with NOIP. I assume that where you put in a hostname you can create anything? The default setting is the DDNS. Initially, I created an address called BrixhamKiwiSDR.ddns.com. Does that sound right?
  • Just wonder if you can use .com. I used xxxx.ddns.net for my Kiwis.
  • I would think something as long as BrixhamKiwiSDR might cause issues at some point
  • Okay, I think I'm getting somewhere now. I have put all the relevant settings into my BT Smart Hub under dynamic DNS. I've changed the settings on the Kiwi test. However, I suspect I still have to do make some changes under the ports. My domain is now g0vqy-kiwisdr.ddns.net, however, that still doesn't work.
  • Okay guys, this is where I am at the moment.I've changed all the settings under DUC initially, I enabled dynamic DNS on my router. However, I was told that I didn't leave it on the router and in the Kiwi. So I have switched off dynamic DNS on my BT Smart Hub. I assume this is correct?
  • jksjks
    edited February 2020
    I'm able to connect using http://g0vqy-kiwisdr.ddns.net:8073 from the Internet (i.e. outside your local network). Since the Kiwi has a built-in DDNS client, which it looks like you have configured correctly, it should not be necessary to configure the one in your router. Although it should not be a problem if you do.
  • Okay, so I've done it correctly? So when I set up a link on my webpage I just need to make sure I put the port number on the end. Come to think of it, when you look through all the receivers on SDR.HU they have all got a port number at the end of the address if I'm not mistaken of course.
  • jksjks
    edited February 2020
    Yes, you always need to add a port number to a URL when the target server you want is running on anything other than port 80 (80 = www). The Kiwi defaults to using port 8073.

    It is possible to run the Kiwi on port 80 so that the port doesn't have to be specified in the URL. But this may cause problems. For example since port 80 of your g0vqy.co.uk domain already points to your web server you couldn't also use port 80 of that domain for the Kiwi simultaneously. But of course this is not an issue for you currently since you are using a DDNS domain from noip (i.e. xxx.ddns.net).
  • I finally managed to achieve my goal, getting a link onto my website. Thanks to everybody who helped, very much appreciated, especially Jim who I've been talking to you on Facebook. Thank God for these websites, wouldn't get anything done without the help :-)

    https://g0vqy.co.uk/
    WA2ZKD
Sign In or Register to comment.