Find your Kiwi using my.kiwisdr.com

Got a Kiwi (running v1.330+) on your local network with an unknown local IP address? Like a new Kiwi out-of-the-box? Now from a browser on the same local network you can connect to my.kiwisdr.com and be automatically redirected to the Kiwi. The local IP address of the Kiwi will then show in the browser address bar.

This feature is similar to that provided by other IoT devices. It requires that the Kiwi have access to the Internet when it starts up. And that the computer running the browser is on the same local network as the Kiwi. If there are multiple Kiwis on the network the browser will display a table of Kiwis by serial number and a link that will connect to each one.

Our documentation lists 5 different methods of determining a Kiwi's IP address. But each has its limitations and disadvantages. Now there is a sixth method that is particularly convenient.

If you want to opt-out of your Kiwi sending this information to kiwisdr.com each time it starts then set the switch on the network tab of the admin page to NO: "Register this Kiwi on my.kiwisdr.com on each reboot?".

This feature has not been tested with IPv6 or mixed IPv4/IPv6 local networks. So there is likely some debugging required.
rz3dvpJimo

Comments

  • The multi-Kiwi page has been updated to also include a direct link to the admin page of each Kiwi in addition to the user page link.
  • edited January 12
    I use Zeroconf to find local devices and services. That's a set of IETF standard protocols that originated as Apple's "Bonjour"; they're especially popular for discovering local printers. The KiwiSDR already runs 'avahi', which is the main Zeroconf daemon for Linux. (mDNS is just part of Zeroconf; that's how it responds to "kiwisdr.local".) If you create files under /etc/avahi/services, then it will also advertise those services so they can be found by a Zeroconf client like avahi-browse on Linux, the Safari web browser with the Zeroconf extension, or the third-party Discovery application on Mac OSX. I've attached the files /etc/avahi/ssh.service and /etc/avahi/http.service that I added to my KiwiSDRs. To get them past the forum's file name filter I had to append ".txt" to each one; remove before you place them in /etc/avahi.

    One advantage of doing this, rather than running only mDNS, is that you can still discover a KiwiSDR whose name has been changed from "kiwisdr.local". I have had to do that when there's more than one on my network.
    rz3dvp
  • Is it possible that an ISP could obstruct this kind of service?

    My kiwi is fully updated, has the correct switch set on the admin networking page ,and won't respond to the my.kiwisdr.com request, or to the kiwisdr.local one. It never has done. I just get a message saying No KiwiSDR(s) found for your public ip address:*******.

    As far as I know, everything is set up properly. It works very well in every other feature that I have tried. It's a bundle of fun. Glad I bought it. :smiley:
  • Are you using any kind of VPN?
    I.E. does the browser get to the internet through the same gateway as the Kiwi?
  • jksjks
    edited February 12
    @Tony: kiwisdr.com last saw a registration for the my.kiwisdr.com service from your ip (ending in .214) and Kiwi serial number (ending in "1") on Feb 11. So unless your ip has changed I don't know why it wouldn't work. If you visit http://my.kiwisdr.com/?debug does it show your correct public ip?

    The MDNS/Avahi thing (kiwisdr.local) is unreliable when used from Windows. Sometimes it works, sometimes not.
  • jksjks
    edited February 12
    Although our documentation doesn't currently say so, if you have multiple Kiwis on the same local network (using the default "kiwisdr" hostname) then Avahi will differentiate them by adding "-N" beginning with the second one. I.e. kiwisdr.local, kiwisdr-2.local, kiwisdr-3.local ...

    I just tried this again to verify it works.
  • jksjks
    edited February 12
    @Tony: I just added some debugging code to the my.kiwisdr.com function that triggers on your ip address. Could you try it again please so I can see the debug output and try and figure out what might be going on? Thanks.
  • @Tony: Has your public ip changed from ending in .214? I just looked at the server logs for accesses to my.kiwisdr.com from your ip and I only see two attempts from Jan 31. Nothing more recent than that.

    As I mentioned earlier the only registration from a Kiwi for the service using that Kiwi serial number was from the .214 ip on Feb 11.
  • Sorry for the late response.

    Yes the IP address has changed again. We have been having winter storms and there have been some very short interruptions of power supply so I guess that may account for public ip address changes in the router as it is knocked over by the momentary power cuts.

    The debug page shows the correct, up to date address. I am using your proxy service for access outside the local network. That works fine so the kiwi must be logging in when it reboots.

    I have it set to reboot each night.

    Odd to say, but the mykiwisdr.com command now works as it is supposed to. It REALLY wasn't working when I made that post.

    The other one, http://kiwisdr.local:8073/admin returns a message that the site can not be reached.

    I am mostly using a chrome book for access, also an android tablet and sometimes an android phone, though the only one I've tried the kiwisdr.local:8073 has only been used with the chromebook.

    No big deal John. I don't waant you to go to great lengths to debug this. I'm sure you have enough to do already.

    Cheers
  • What's probably going on is just a side-effect of the dynamic public ip address changes. Your Kiwi only registers for the my.kiwisdr.com service once when it boots. If your public ip subsequently changes then my.kiwisdr.com won't work because kiwisdr.com depends on matching the registered public ip with the public ip presented during the browser query. With some effort this could be fixed. But the service is really intended to help people with initial installation (when the registration and query would be closely spaced in time).
  • edited February 14
    Thanks John. That's completely clear and explains the issue perfectly. It wasn't a biggie at all - I was just curious to understand it.

    By the way - I wrote previously about GPS difficulties caused by my weird location, sheltered from the sky. I disconnected the antenna and in a stable temperature environment, it doesn't matter at all. The thing is dead stable. I check it daily on WWV on 10 mhz and it has been dead on frequency for four days since I made the initial correction manually.

    Great product.
Sign In or Register to comment.